Bug 7101

Summary: xkbdata: Inconsistency between installed packages in SDK and FW
Product: [Maemo Official Platform] Development platform Reporter: Roman Moravcik <roman.moravcik>
Component: SDKAssignee: Janne Johansson <ext-janne.p.johansson>
Status: RESOLVED FIXED QA Contact: sdk-bugs
Severity: normal    
Priority: Low CC: andre_klapper, ext-janne.p.johansson
Version: 5.0-final   
Target Milestone: 5.0-update3   
Hardware: All   
OS: Maemo   

Description Roman Moravcik (reporter) 2009-12-18 09:49:38 UTC
SOFTWARE VERSION:
5.0-final

EXACT STEPS LEADING TO PROBLEM: 
Install Maemo 5.0-final SDK using scratchbox and sdk installer script.

EXPECTED OUTCOME:
Package xkb-data-1.5-2maemo11.1+0m5 will be installed by default

ACTUAL OUTCOME:
Package xkbdata-0.8-0osso39+0m5 was installed by default

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
nothing

OTHER COMMENTS:
According to information in xkb-data package changelog:

xkeyboard-config (1.5-2maemo1) unstable; urgency=low

  * Synchronization with upstream. Replacement of the old xkbdata package.
  * Fixes: NB#116300 - added support for Nokia keyboards to upstream version

xkbdata package is obsolete and it's not installed in device firmware, but it's
installed by sdk by default, because package maemo-core-runtime-5.0+2+0m5
depend on it.
Comment 1 Andre Klapper maemo.org 2009-12-18 14:31:13 UTC
Ahoj,

> EXPECTED OUTCOME:
> Package xkb-data-1.5-2maemo11.1+0m5 will be installed by default
> 
> ACTUAL OUTCOME:
> Package xkbdata-0.8-0osso39+0m5 was installed by default

Note the hypen difference in the package name.

According to
http://repository.maemo.org/stable/5.0/5.0beta2_vs_5.0_content_comparison.html
the final SDK includes:
* xkb-data 1.5-2maemo10+0m5
* xkbdata 0.8-0osso39+0m5

So you say that xkb-data is shipped but not installed for you?
Comment 2 Roman Moravcik (reporter) 2009-12-18 14:50:32 UTC
(In reply to comment #1)
> Ahoj,
> 
> > EXPECTED OUTCOME:
> > Package xkb-data-1.5-2maemo11.1+0m5 will be installed by default
> > 
> > ACTUAL OUTCOME:
> > Package xkbdata-0.8-0osso39+0m5 was installed by default
> 
> Note the hypen difference in the package name.
> 
> According to
> http://repository.maemo.org/stable/5.0/5.0beta2_vs_5.0_content_comparison.html
> the final SDK includes:
> * xkb-data 1.5-2maemo10+0m5
> * xkbdata 0.8-0osso39+0m5
> 
> So you say that xkb-data is shipped but not installed for you?
> 

Yes you are right. xkb-data package is available for download in SDK, but it's
not installed automatically. xkb-data is a replacement for xkbdata package and
it's installed on the real device.

So, in order to have the same versions of xkb definition files
(/usr/share/X11/xkb/*) in the SDK as they are on the real device, I need to
install xkb-data package manually after SDK installation.
Comment 3 Janne Johansson nokia 2009-12-18 16:00:51 UTC
A new meta package 5.0+3 has been created and will be released together with
the next SDK update.
Comment 4 Janne Johansson nokia 2010-01-11 16:53:11 UTC
Update released today.