Bug 7073 (int-142524)

Summary: Changing password on Exchange 2007 makes MfE go crazy
Product: [Maemo Official Platform] Synchronization Reporter: d <d>
Component: Mail for ExchangeAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: activesync-bugs
Severity: major    
Priority: Medium CC: andre_klapper, d, vitaly.repin
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description d@hp23c.dk (reporter) 2009-12-17 14:34:19 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Setup sync on Maemo device.
2. Wait until first automatic sync has occured.
3. Change AD/Exchange password (on your desktop).
4. Wait until MfE tries to sync again.

EXPECTED OUTCOME:
Device complaints aonce, and maybe retries every minute or so.

ACTUAL OUTCOME:
Device keeps trying to reconnect again and again every few seconds, sucking
huge amounts of battery.

REPRODUCIBILITY:
Unknown, I'm almost out of battery. Will retry after a recharge, and
comment/update.

EXTRA SOFTWARE INSTALLED:
Tons.

OTHER COMMENTS:
This is especially bad when you have the device in your pocket, like I did,
only realizing something is wrong after a few hours... With a tiny bit of
battery left.
Comment 1 Andre Klapper maemo.org 2009-12-17 14:51:18 UTC
Thanks for reporting this.

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Setup sync on Maemo device.
> 2. Wait until first automatic sync has occured.
> 3. Change AD/Exchange password (on your desktop).
> 4. Wait until MfE tries to sync again.

This bug report isn't very useful because it doesn't describe the bug well.
As written, Explain in detail what you do (e.g. tap on OK).
Also, which kind of Exchange server is this about? Exchange 2003, Exchange
2007?
Comment 2 d@hp23c.dk (reporter) 2009-12-17 16:06:03 UTC
This is Exchange 2007.

The problem doesn't really have anything to do with clicking anything on the
Maemo device: When you change the AD/Exchange account password (On company PC)
without also updating MfEs stored password, MfE enters a loop that keeps
pounding the Exchange server, instead of backing off, only trying again i.e.
every 10 minutes (I'm 99% sure that the server version is irrelevant), but I'll
revise:

Precondition:
Configured MfE, syncing properly to Exchange server.

Steps:
1. Wait for your old AD/Exhange password to expire (days to years).
2. Arrive to work in the morning.
3. Press "POWER ON" (on PC).
4. Log in (on PC).
5. Read screen asking you to change your password (on PC).
6. Update password (on PC).
7. Wait for N900 to try automatic resync.
Comment 3 Andre Klapper maemo.org 2009-12-17 16:25:29 UTC
Ah, thanks.

Can you please:
1) Install syslog (see
http://wiki.maemo.org/Documentation/devtools/maemo5/syslog ) and reboot
2) Open X Terminal
[optional steps begin]
2A. Enter "sudo gainroot" (to do that make sure that you have installed
"rootfs" from the Application Manager)
2B. cat /dev/null > /var/log/syslog
[optional steps end]
3) Provide the output the following commands:
   gconftool-2 -s --type=int /apps/activesync/AsDaemon/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/modest/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsProvider/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsBackup/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/asapplet/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsStatusApplet/Syslog/MinLogLevel
0
4) Attach the file /var/log/syslog from the device to this bug (if needed, copy
it first to the section that is visible in the File Manager: cp /var/log/syslog
/home/user/MyDocs/.documents/  )
Comment 4 Vitaly Repin 2009-12-17 18:25:54 UTC
No need in more data.

Well known bug.  Fixed internally.

Bug id:  144563
Comment 5 Andre Klapper maemo.org 2009-12-17 18:34:24 UTC
(In reply to comment #4)
> Well known bug.  Fixed internally.
> Bug id:  144563

Ah, thanks a lot.

This has been fixed in package
as-daemon 0.0.2-1+0m5
which is part of the internal build version
2.2009.42-5 
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.) Note that 1.2009.42-11 does not include this fix.
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal exists at
  
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 6 d@hp23c.dk (reporter) 2009-12-18 23:20:35 UTC
Cool, thanks.

Looking forward to next release with the fix. Until then, I'll just have to
remember to update my phone password along with the AD account :)

(Damn corporate policies. In my mind, one STRONG long-lasting password is
better than the useless ones that you have to invent to be able to remember
the-password-of-this-fortnight)
Comment 7 Andre Klapper maemo.org 2010-01-14 12:26:06 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.