Bug 7029 (int-106780)

Summary: Device reboots when trying to connect to WIFI due to Oops in rate_control_get_rate()
Product: [Maemo Official Platform] Core Reporter: Roman Moravcik <roman.moravcik>
Component: KernelAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: linux-kernel-bugs
Severity: normal    
Priority: Low CC: ab, andre_klapper, eero.tamminen
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   
Attachments: crash after trying to connect to WIFI
/dev/mtd2 from recent crashs
oops 03 16 37
oopslog-04EE-2010-03-16-36.rcore.lzo

Description Roman Moravcik (reporter) 2009-12-16 12:01:30 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
Connect to Wifi

EXPECTED OUTCOME:
Device works normally

ACTUAL OUTCOME:
Device reboots

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
ukeyboard, nameday-applet

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sk; rv:1.9.1.5)
Gecko/20091105 Fedora/3.5.5-1.fc12 Firefox/3.5.5
Comment 1 Roman Moravcik (reporter) 2009-12-16 12:06:07 UTC
Created an attachment (id=1776) [details]
crash after trying to connect to WIFI

I had just 3 reboots after trying connect to our company WIFI.

~ $ cat /proc/bootreason
sw_rst
~ $ cat /var/lib/dsme/stats/*
/usr/bin/ohm-session-agent: 1
/usr/bin/hildon-status-menu: 2
/usr/bin/ohm-session-agent: 1
/usr/bin/hildon-status-menu: 1

I was trying to connect to Ovislink WL-1120AP (FW V1.03H) configured in
Infrastructure mode with WPA security enabled.
Comment 2 Andre Klapper maemo.org 2009-12-18 20:37:45 UTC
Hi Roman,
the Alias field set here - did you talk to a Nokia person before filing this or
where does it come from?
Comment 3 Roman Moravcik (reporter) 2009-12-18 23:55:49 UTC
Hi Andre,

(In reply to comment #2)
> Hi Roman,
> the Alias field set here - did you talk to a Nokia person before filing this or
> where does it come from?
> 

Please check Eero's comment in bug 6334:

https://bugs.maemo.org/show_bug.cgi?id=6334#c242
Comment 4 Andre Klapper maemo.org 2010-01-22 19:09:00 UTC
This has been fixed in package
kernel 2.6.28-20100303+0m5
which is part of the internal build version
2010.03-12
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Eero Tamminen nokia 2010-03-09 11:16:11 UTC
This happens only with specific access point(s).  Internally reported bug was
about OpenWrt based AP configured to ad-hoc mode.  Was yours same one?

(And the Oops backtrace & summary update so that this is easier to find.)
[44944.519866] Backtrace: 
[44944.519866] [<c002fe58>] (__bug+0x0/0x2c) from [<bf0cba08>]
(rate_control_get_rate+0xb8/0x150 [mac80211])
Comment 6 Roman Moravcik (reporter) 2010-03-10 10:34:14 UTC
Hi Eero,

as I wrote in comment 1, we have here "Ovislink WL-1120AP (FW V1.03H)
configured in Infrastructure mode with WPA security enabled" and yes, I've got
crash in rate_control_get_rate() function too.
Comment 7 Andre Klapper maemo.org 2010-03-15 20:53:52 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 8 nivw2008 2010-03-16 18:19:25 UTC
Created an attachment (id=2479) [details]
/dev/mtd2 from recent crashs

recently I got sevral crashs that restarted my N900 while connecting to a
coffee house wifi hotspot. can this bug be causing it or is it a new issue?
# cat /var/lib/dsme/stats/*
/usr/bin/Xorg -logfile /tmp/Xorg.0.log -logverbose 1 -n: 3
/usr/bin/Xorg -logfile /tmp/Xorg.0.log -logverbose 1 -n: 2
/usr/bin/systemui: 1
/usr/sbin/browserd -d: 1
/usr/bin/hildon-home: 4
/usr/bin/syncd: 8
/usr/bin/hildon-status-menu: 1
/usr/bin/mafw-dbus-wrapper mafw-gst-renderer: 3
/usr/bin/camera-ui: 65
/usr/bin/ohm-session-agent: 1
/usr/bin/hildon-desktop: 5
/sbin/mce --force-syslog: 1
/usr/bin/systemui: 1
/usr/sbin/browserd -d: 1
/usr/bin/hildon-home: 4
/usr/bin/syncd: 8
/usr/bin/hildon-status-menu: 1
/usr/bin/mafw-dbus-wrapper mafw-gst-renderer: 3
/usr/bin/camera-ui: 65
/usr/bin/ohm-session-agent: 1
/usr/bin/hildon-desktop: 5

oops files are attached next:
# ls -lart /home/user/MyDocs/core-dumps/
-rw-r--r--    1 user     root      1353651 Feb 18 10:01
telepathy-stream-engine-04EE-6-3834.rcore.lzo
-rw-r--r--    1 user     root      1293559 Feb 18 10:12
telepathy-stream-engine-04EE-6-3938.rcore.lzo
-rw-r--r--    1 user     root      3623947 Feb 21 14:22
hildon-desktop-04EE-11-1137.rcore.lzo
-rw-r--r--    1 user     root      6145972 Feb 23 15:01
pulseaudio-04EE-11-770.rcore.lzo
-rw-r--r--    1 user     root      7213730 Feb 23 15:05
mafw-dbus-wrapper-04EE-11-1373.rcore.lzo
-rw-r--r--    1 user     root        37348 Feb 23 21:40
oopslog-04EE-2010-02-23-37.rcore.lzo
-rw-r--r--    1 user     root        47886 Feb 24 16:53
oopslog-04EE-2010-02-24-29.rcore.lzo
-rw-r--r--    1 user     root        51518 Feb 24 17:23
oopslog-04EE-2010-02-24-54.rcore.lzo
-rw-r--r--    1 user     root      1259022 Mar  1 17:34
telepathy-stream-engine-04EE-6-2723.rcore.lzo
-rw-r--r--    1 user     root      1390640 Mar  1 23:25
qtirreco-04EE-11-2237.rcore.lzo
-rw-r--r--    1 user     root           38 Mar  3 14:07
fennec-04EE-11-7450.rcore.lzo
-rw-r--r--    1 user     root           38 Mar  3 14:07
unknown-04EE-6-809.rcore.lzo
-rw-r--r--    1 user     root        55285 Mar  3 16:39
oopslog-04EE-2010-03-03-09.rcore.lzo
-rw-r--r--    1 user     root      1409660 Mar  3 20:02
pulseaudio-04EE-7-766.rcore.lzo
-rw-r--r--    1 user     root        60306 Mar  3 20:16
oopslog-04EE-2010-03-03-25.rcore.lzo
-rw-r--r--    1 user     root        61953 Mar  3 20:19
oopslog-04EE-2010-03-03-24.rcore.lzo
-rw-r--r--    1 user     root        15637 Mar  3 20:19
oopslog-04EE-2010-03-03-26.rcore.lzo
-rw-r--r--    1 user     root        64026 Mar  3 20:31
oopslog-04EE-2010-03-03-55.rcore.lzo
-rw-r--r--    1 user     root        67511 Mar  3 20:40
oopslog-04EE-2010-03-03-04.rcore.lzo
-rw-r--r--    1 user     root        45725 Mar  4 10:29
oopslog-04EE-2010-03-04-50.rcore.lzo
-rw-r--r--    1 user     root      5040579 Mar  5 11:45
telepathy-stream-engine-04EE-6-7094.rcore.lzo
-rw-r--r--    1 user     root      6677836 Mar  5 12:14
pulseaudio-04EE-11-760.rcore.lzo
-rw-r--r--    1 user     root      1355618 Mar  5 16:42
pulseaudio-04EE-11-776.rcore.lzo
-rw-r--r--    1 user     root      4441186 Mar  5 16:42
mafw-dbus-wrapper-04EE-6-1365.rcore.lzo
-rw-r--r--    1 user     root        54037 Mar  7 14:27
oopslog-04EE-2010-03-07-21.rcore.lzo
-rw-r--r--    1 user     root           38 Mar  7 18:44
unknown-04EE-6-812.rcore.lzo
-rw-r--r--    1 user     root           38 Mar  7 18:44
pulseaudio-04EE-6-774.rcore.lzo
-rw-r--r--    1 user     root        63616 Mar 10 09:20
vi-04EE-11-6019.rcore.lzo
-rw-r--r--    1 user     root      1442556 Mar 11 08:54
telepathy-stream-engine-04EE-6-2681.rcore.lzo
-rw-r--r--    1 user     root       264056 Mar 14 15:28
telepathy-sofiasip-04EE-6-3537.rcore.lzo
-rw-r--r--    1 user     root      3706837 Mar 14 17:04
hildon-desktop-04EE-6-1135.rcore.lzo
-rw-r--r--    1 user     root       151815 Mar 15 09:26
mce-04EE-11-754.rcore.lzo
-rw-r--r--    1 user     root        60011 Mar 15 15:50
oopslog-04EE-2010-03-15-10.rcore.lzo
-rw-r--r--    1 user     root        62895 Mar 15 15:59
oopslog-04EE-2010-03-15-02.rcore.lzo
-rw-r--r--    1 user     root        67675 Mar 15 16:19
oopslog-04EE-2010-03-15-06.rcore.lzo
-rw-r--r--    1 user     root        42109 Mar 16 08:35
reboot-32wd_to-04EE-0-0.rcore.lzo
-rw-r--r--    1 user     root        44199 Mar 16 09:35
oopslog-04EE-2010-03-16-19.rcore.lzo
-rw-r--r--    1 user     root     38128311 Mar 16 11:41
browserd-04EE-11-2325.rcore.lzo
-rw-r--r--    1 user     root        47125 Mar 16 13:37
oopslog-04EE-2010-03-16-36.rcore.lzo
-rw-r--r--    1 user     root        53969 Mar 16 13:52
oopslog-04EE-2010-03-16-37.rcore.lzo
drwxrwxrwx    2 user     root        65536 Mar 16 17:01 .
-rw-r--r--    1 user     root       339472 Mar 16 17:01
pulseaudio-04EE-6-773.rcore.lzo
drwxrwxrwx   25 user     root        65536 Mar 16 17:40 ..
Comment 9 nivw2008 2010-03-16 18:25:30 UTC
Created an attachment (id=2480) [details]
oops 03 16 37
Comment 10 nivw2008 2010-03-16 18:26:38 UTC
Created an attachment (id=2481) [details]
oopslog-04EE-2010-03-16-36.rcore.lzo
Comment 11 Eero Tamminen nokia 2010-03-17 19:15:57 UTC
(In reply to comment #8)
> Created an attachment (id=2479) [details] [details]
> /dev/mtd2 from recent crashs
>
> recently I got sevral crashs that restarted my N900 while connecting to a
> coffee house wifi hotspot. can this bug be causing it or is it a new issue?

The mtd2 oops partition content seems partially messed up, but the crashes
there are some kind of null pointer issues. They aren't the same oops backtrace
as in the internal bug, but it's possible they're related.


(In reply to comment #9)
> Created an attachment (id=2480) [details] [details]
> oops 03 16 37

If you attach mtd2 partition, it's not necessary to attach oopslogs.
Comment 12 Andre Klapper maemo.org 2010-04-22 13:03:03 UTC
*** Bug 9673 has been marked as a duplicate of this bug. ***