Bug 6984 (int-150807)

Summary: Show wrong Contact for a SMS after a couple of days
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: redex
Component: MessagingAssignee: rtcomm <rtcomm>
Status: CLOSED FIXED QA Contact: im-chat-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, jorgen.scheibengruber, mikhail.zabaluev, redex
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   
Attachments: The first start after reboot - the correct Name of sender
About one second after - the images are loaded and the screen refreshed - the wrong name appears

Description redex (reporter) 2009-12-15 13:30:06 UTC
SOFTWARE VERSION:
5.0/(1.2009.42-11)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

I received some Messages from T-Mobile with Bill informations.
I have the Number "received from" not in my Contacts and also not at the SIM
Card.
The N900 shows the name "T-Mobile" as sender - searching in Contacts for
T-Mobile without result, but it shows the Name instead of the Number - i don't
know how it works. A special mark in the SMS?

I received the first SMS on 3. December 2009, 11:34 and the last 11. December
2009. There are 3 ones in this Conversation path.

Conversations shows always the correct Name.

Today i saw it shows for this Conversation a wrong Contact Name. When I tap on
the Icon the 3 phone Numbers from the Contact "Alexander Krauß" appears. Not
from T-Mobile.

After a restart of the Phone and open the Conversation the first time it shows
for about a second "T-Mobile" for the Name. After refreshing the screen and
loading a image of a other contact "T-Mobile" disappers and the Contact
"Alexander Krauß" is linked to the Conversation with "T-Mobile".
Closing and reopening the Conversation - "T-Mobile" shows never again as sender
until the next restart of the Device.

I know from my old phone. The Number the SMS was send from T-Mobile has 4
digits and is very short. The Contact "Alexander Krauß" has no number like this
in the contact details.

EXPECTED OUTCOME:
Show always the correct Person a SMS was send from 

ACTUAL OUTCOME:
Shows always the wrong sender for the T-Mobile SMS Conversation. It works
before just fine.

REPRODUCIBILITY:
I would like to say less than 1/10 - there was no bug at the beginning. It
worked just fine. But once the bug appears it appears always and it is
reproducible on my device.

EXTRA SOFTWARE INSTALLED:
Conboy
eCoach
Password Safe
load-applet
Bounce Evolution

OTHER COMMENTS:
Alexander Krauß is a very common name in germany. So no privacy problems. I
will add some screenshots with red marks over the private content. 

Alexander Krauß is not the first Contact in my Contacts. But it could be
possible that his ID in the Database is the lowest or even the ID is 1, because
it is possible that it was the first created contact during the synchronization
with my old phone.

It would be really nice if the conversation could show the real number a sms
was send from. Or the Plain Message as it was received and stored. 

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR
1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022;
InfoPath.2)
Comment 1 redex (reporter) 2009-12-15 13:31:41 UTC
Created an attachment (id=1765) [details]
The first start after reboot - the correct Name of sender

The first start of conversation after rebooting the Device. The correct Name of
the sender is shown.
Comment 2 redex (reporter) 2009-12-15 13:36:25 UTC
Created an attachment (id=1766) [details]
About one second after - the images are loaded and the screen refreshed - the
wrong name appears

About one second after starting the conversations - the images are loaded and
the screen refreshed. Now "Alexander Krauß" appears instead of "T-Mobile" for
the Sender.

I can't find a bug like this in the Database. The only thing that could be
something like this is Bug 6919 . It is diferent and I cant reproduce it. But
it could depend of the same problem.
Comment 3 Mikhail Zabaluev nokia 2009-12-15 14:28:59 UTC
*** Bug 6983 has been marked as a duplicate of this bug. ***
Comment 4 Mikhail Zabaluev nokia 2009-12-15 15:38:08 UTC
Do you see the wrong contact in the conversation list, or in individual
conversation views?

It looks like the problem has been fixed, and the fix will be available on the
next update. Please reopen the bug if it reappears after the update is applied.
Comment 5 redex (reporter) 2009-12-15 17:01:17 UTC
Thanks Mikhail, i don't know how Bug 6983 appears. I had a bad network
connection. So it could be possible I've commited the Bug twice after the
network error. I'm sorry.

(In reply to comment #4)
> Do you see the wrong contact in the conversation list, or in individual
> conversation views?

Just for the completeness. I see the wrong contact in the conversation list and
the individual conversation view. It links on boot views to the wrong contact
and it absolutly seems to the user this wrong contact is the real sender.
Confusing. 
For the first time opening the conversations it seems correct until the
programm loads additional data (pictures of contacts). From that point the bug
appears.

I will send a additional screenshot if the bug also appears after the next
firmware release.

Just a comment from me beside the point: I would love to see somewhere the
plain message details as received by the device. :-)

> It looks like the problem has been fixed, and the fix will be available on the
> next update. Please reopen the bug if it reappears after the update is 
> applied.

Thanks a lot. This are good news. :-)

Could you tell in which Version it will be fixed? 
When it is in the internal Version 2009.50 fixed and 2009.48 is released
someday I know I have to wait until the next but one Version is published.
Comment 6 Jörgen Scheibengruber nokia 2009-12-16 11:21:34 UTC
Does any of the phone-numbers of the contact Alexander Kraus contain something
else than a digit or "+"?
Comment 7 redex (reporter) 2009-12-16 14:56:07 UTC
(In reply to comment #6)
> Does any of the phone-numbers of the contact Alexander Kraus contain something
> else than a digit or "+"?

Hello Jörgen,

No. One number with "01705" and two numbers are beginning with "+49"

For testing I made a backup including the Contacts and Conversations. I used
the N900 build in toolkit. 
I deleted the whole T-Mobile Conversation and triggered my provider to send a
new billing information. The new SMS had the same issue. Only after a reebot of
the Device it showed for a short time T-Mobile. After the refresh only
"Alexander Krauß"

I restored the former Backup I had made before the testing to have the old SMS
again on my device. It included the Conversations and Contacts.
The Bug disappeard. Now it works like before. Without bug. I restarted the
Device twice and received a additional billing report from T-Mobile. It still
works fine. I'm sorry. :-(

I tested it with a N95 and looked at the SMS Details of the sender. It seems
that T-Mobile is sending this SMS without a Number. Only the String "T-Mobile"
instead of a Number. Is this possible?
I can't enter something else than "+", "P", "*", "#" and Numbers for phone
Numbers in the contacts. This makes sense. Nothing else should be allowed.

Could a SMS with such a strange sender cause the problem in some cases?

I don't know how T-Mobile handles this outside of Germany. Could somebody with
a T-Mobile contract confirm this? You can trigger sending a SMS Billing
Information at the Hotline Number: 2000

I keep watching on this issue and leave this Report as resolved fixed. If the
problem appears again (even after the next update) I will report as soon as
possible.
Comment 8 Jörgen Scheibengruber nokia 2009-12-16 15:05:18 UTC
Seems to be a Heisen-bug. We have tried to reproduce this with various
corner-case setups that could lead to problems, but failed to do so.

The "T-Mobile" as a sender is apparently a valid use-case, so that *should* not
cause any problems.

Do you remember if the contact "A. Krauß" got modified shortly before this bug
started to happen?
Comment 9 redex (reporter) 2009-12-17 00:53:17 UTC
(In reply to comment #8)

> Seems to be a Heisen-bug. We have tried to reproduce this with various
> corner-case setups that could lead to problems, but failed to do so.
> The "T-Mobile" as a sender is apparently a valid use-case, so that 
> *should* not cause any problems.
> Do you remember if the contact "A. Krauß" got modified shortly before this bug
> started to happen?

Hmm... okay. Thats a good point of view.

I was constantly editing my contacts the last 2 weeks, because the N900
Contacts Application is not as flexible as the one known from Symbian Devices.
So I'm still comparing and fixing contacts when I had time. Many informations
are still only on my old Nokia N95 stored. 

I had a reboot of the device the day before using the Media Player. I tested a
Video with a very high bit rate. Hm, to high I guess. 
But this is not the topic of this Bug report. It could be possible that the
contacts application and some communicatins were still running when the reboot
appears. :-/

Could a not stored cache of the Contact Database caused such a bug?

When I take a look into the Backup Files. It seems that the Contacts are stored
in: 
"Root\home\user\.osso-abook\db\backup.vcf"
and the SMS Messages in:
"Root\home\user\.rtcom-eventlogger\backup.db"

I guess the backup.db is a direct copy of the internal database. 
Is the backup.vcf a direct copy of the internal stored File or is this a export
and during restoring the Contacts are parsed in some way?

I had only the Backup of the Conversations and Contacts. The bug is gone. :-(

I tryed to check the Database file of the backup, but I can only look with a
hex editor at the SQLite Database.
I can find the String "ring/tel/ringT-Mobile" and even on some places
"ring/tel/ring2000". But nowhere a number or a part of one from "Alexander K.".
I had no contact to this person for more than a year. So no SMS send or
received from this guy on this device. It seems there is nothing stored in the
backup.db file that points to the Contact "Alexander K.".

I checked the part of "Alexander K." in the vcf file line for line. Even the
rest of the file seems okay. The File is with 43686 Bytes large but okay. I
collected 255 Contacts the last 10 Jears. But I read from users with more than
800 contacts. So this shouldn't be a problem.

After restoring the backup once everyting is still fine. :-/
But I restored a Backup taken AFTER the Bug appears. I can't understand.

I'm sorry to waste your time! :-(
Comment 10 Jörgen Scheibengruber nokia 2009-12-17 13:26:32 UTC
(In reply to comment #9)
> Could a not stored cache of the Contact Database caused such a bug?

Ideally not. But no software is perfect ;-)

> When I take a look into the Backup Files. It seems that the Contacts are stored
> in: 
> "Root\home\user\.osso-abook\db\backup.vcf"
> and the SMS Messages in:
> "Root\home\user\.rtcom-eventlogger\backup.db"

The eventlogger is a 1:1 backup of the sqlite database. For contacts, the story
is different, this is actually a export of the database as a vcard. It is a 1:1
export however, after all it is a backup.

> I tryed to check the Database file of the backup, but I can only look with a
> hex editor at the SQLite Database.
> I can find the String "ring/tel/ringT-Mobile" and even on some places
> "ring/tel/ring2000". But nowhere a number or a part of one from "Alexander K.".
> I had no contact to this person for more than a year. So no SMS send or
> received from this guy on this device. It seems there is nothing stored in the
> backup.db file that points to the Contact "Alexander K.".

AFAIK the sqlite3 commandline client is even installed on the device.

> I checked the part of "Alexander K." in the vcf file line for line. Even the
> rest of the file seems okay. The File is with 43686 Bytes large but okay. I
> collected 255 Contacts the last 10 Jears. But I read from users with more than
> 800 contacts. So this shouldn't be a problem.

No, we don't have any limit in the contacts we are able to support. Above 1000
you might see some performance degradation, but otherwise everything is
supposed to work fine.

> After restoring the backup once everyting is still fine. :-/
> But I restored a Backup taken AFTER the Bug appears. I can't understand.
> 
> I'm sorry to waste your time! :-(

No, definitely no waste of time. Thanks for your help!
Comment 11 Andre Klapper maemo.org 2010-01-14 12:28:53 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.