Bug 688

Summary: Let user select default applications for MIME types
Product: [Maemo Official Applications] Settings and Maintenance Reporter: Victor Toni <maemo-bugs>
Component: Control panelAssignee: Erik Karlsson <erik.b.karlsson>
Status: RESOLVED FIXED QA Contact: control-panel-bugs
Severity: enhancement    
Priority: High CC: eero.tamminen, mike_morrison, mr_abruce, quim.gil, roope.rainisto
Version: 2.0Keywords: ITOS2007HE-garage
Target Milestone: Harmattan   
Hardware: All   
OS: All   

Description Victor Toni (reporter) 2006-07-07 19:15:18 UTC
One can install many applications but they cannot be setup to replace existing
applications.
E.g. if one downloads a PDF one cannot select another application to open the
file with.
There are two occasions one would like to select another application, while
browsing the net and while browsing the filessystem.

Maybe having some kind of "registry" where this association is stored (and could
be changed via GUI tools) could solve this issue.
Comment 1 Tommi Komulainen nokia 2006-07-07 20:55:34 UTC
We discussed this while improving the MIME open functionality for IT2006 and
came to conclusion that such feature makes little sense on the product as it is
counterproductive to ship competing applications on such limited space.

We did, however, try to make sure that such an application can be written using
the available APIs. We realize this would be valuable, but at the moment we are
relying on the community to do the implementation.
Comment 2 Victor Toni (reporter) 2006-07-08 01:14:32 UTC
The PDF viewer seems to behave better than in previous releases.
However one may still would like to install ones favourite applications and
since the device has limited space available one might like even to replace the
builtin PDF viewer (or any other application, e.g. the media player).
This won't work if the relation extension <=> application is hardcoded.
Comment 3 Tommi Komulainen nokia 2006-07-09 13:41:08 UTC
Like I said, it was intended that replacing the MIME type handlers would be
possible. As I recall both are based on using the 'defaults.list' file, see for
example gnome_vfs_mime_get_default_desktop_entry and also /usr/include/osso-uri.h
Comment 4 Jakub Pavelek nokia 2006-08-21 13:28:36 UTC
Reassigning to Erik.
Comment 5 Victor Toni (reporter) 2006-08-21 13:56:42 UTC
Being able to use e.g. Evince as the default PDF viewer would be much of an
improvement (at least for me) since it seems to cope better with PDFs.
Comment 6 Erik Karlsson nokia 2006-08-28 10:47:35 UTC
The MIME handling is done using the shader-mime info database (see
http://www.freedesktop.org/wiki/Software_2fshared_2dmime_2dinfo). So the methods
used to modify its default lists apply also to IT2006.
Comment 7 Victor Toni (reporter) 2007-01-24 01:31:44 UTC
The question which still remains if this should be done only by the application
which gets installed or if the user should have the ability to change this
behavior at any time (without tinkering manually with configuration files), I
would prefer the latter.
Comment 8 timeless 2007-08-26 06:35:32 UTC
I'm reorganizing bugs.maemo.org, the general reorganization is described at:
http://maemo.org/community/wiki/bugsmaemoorgreorg/

I'm explicitly moving your bug to a different component. If you object, you're
free to move it where-ever you please at a later time, however, I hope I'm
right.
Comment 10 mike morrison 2008-03-01 05:36:48 UTC
If the mime handling is done using the shared mime info database, shouldn't I
be able to set user specific application defaults? I tried creating the user
specific defaults file (~/.local/share/applications/defaults.list) and adding
some associations to it, but it did not work.
Comment 11 mike morrison 2008-10-17 04:48:03 UTC
Is anyone at Nokia looking into this bug? It is still an issue with the latest
OS (4.1.2) and I would at least like an answer to my previous question (comment
#10).
Comment 12 Eero Tamminen nokia 2008-12-08 19:08:58 UTC
> Is anyone at Nokia looking into this bug?

Not at the moment, other Fremantle functionality is more of a priority.  I.e.
this would need more debugging from whomever would like to have this
functionality (in Fremantle).

Btw. Is there some desktop app that could be used to change the preferred
mime-type application that somebody could port to Maemo and push to Extras
(assuming the lower levels & apps themselves integrate to mime-system fine)?
Comment 13 Quim Gil nokia 2008-12-28 19:14:52 UTC
The summary was a bit vague, hopefully it's clearer now.

Associate MPlayer, Transmission, and other apps as default handlers 
http://www.internettablettalk.com/forums/showthread.php?t=17757

There is an appp there that sets default apps for MIME types. Users cazn't set
their preferred apps, it's the maintainer who provides the types and apps based
on user feedback.

There is a big jump between OS2006 and, say, Harmattan. Maybe this option is
already in the future plans?
Comment 14 Roope Rainisto nokia 2009-01-02 08:48:00 UTC
Yes for Harmattan, no (afaik) for Fremantle.
Comment 15 Quim Gil nokia 2009-01-05 13:28:28 UTC
FIXED in Harmattan, then.
Comment 16 Alan Bruce maemo.org 2009-01-12 20:31:26 UTC
qgil wrote: "Users can't set their preferred apps, it's the maintainer who
provides the types and apps based on user feedback."

Quim, that is incorrect. The app you linked to, DBus Switchboard, has a GUI
that allows the user to set their preferred apps and mime types. This is a
fairly advanced function by its nature, but it is straightforward to set up new
handlers and mime types once you spend some time looking at the example entries
in the GUI.

I am very disappointed in the Harmattan target. To me, that isn't "fixed" at
all. Is there any way to leverage the work already done with DBus Switchboard
to get something into Fremantle?