Bug 6823 (int-145895)

Summary: media player won't play any video files after trying to play a bad video file
Product: [Maemo Official Applications] Media player Reporter: Peter Kay <hi1453>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: media-player-bugs
Severity: blocker    
Priority: High CC: andre_klapper, bas, damnshock, djcaston, dominikowski, eero.tamminen, egoshin, ferd352+maemo.org, g.c.geus, gauthamn, ike.scorp, ilovelinedancing, joppu1, konstantin.starodubtsev, maemo, mail, martin.grimme, martin, mb, miikahuttu, seignon, thefornax, turist, vdv100
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
Attachments: Screenshot of process "bridge-work-que" taking up 100% of CPU
Output of "ps" and "dmesg" while the issue is occurring

Description Peter Kay (reporter) 2009-12-10 21:04:18 UTC
SOFTWARE VERSION: 5.0(1.2009.42-11)
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. uploaded several video files (all .avi encoded with xvid / divx)
2. they played fine
3. played some music files
4. came back a couple of hours later to play the same video file. Says media
format not supported for any video file.
5. turn off phone. turn on... go to video... play file... works!

REPRODUCIBILITY:
unknown

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
using bluetooth headphones for audio

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5)
Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-12-10 22:06:29 UTC
Thanks for reporting this.
This bug report isn't very useful because it doesn't describe the bug well. If
you have time and can still reproduce the bug, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug.
Comment 2 Bartosz Taudul 2009-12-11 02:27:15 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Eugene 2009-12-12 02:22:27 UTC
I also have this bug. Here I have 2 identical devices with 42-11 firmware. The
only difference is that the first is from the summit, another one I got
yesterday. new one does not do any video at all, even "Nokia N900.avi" and
"9.avi" which came with the device. And the old phone eats them all! I even
tried to install additional decoders package from -devel, still no luck.
Comment 4 Eugene 2009-12-18 05:45:49 UTC
On my new N900 I got by DDP reproducibility is 100%. I cannot play any video
file, it fail on everything while Music and Internet radio work like a charm.
It's unbelievable.

P.S. I've tried upgrading firmware and flashing eMMC, no luck.
Comment 5 Dan C 2009-12-18 12:37:59 UTC
I also have this problem. Completely randomly my device decides that it will
not play files that are nromally supported, even the files that nokia put on
the device. However, a reboot fixes this problem.
Comment 6 Andre Klapper maemo.org 2009-12-18 18:10:19 UTC
So, can somebody please provide a good bug description (exact steps, exact
video data etc)? Otherwise we won't have progress here... :-/
Comment 7 Eugene 2009-12-18 19:29:11 UTC
So here is how I reproduce the problem:

1. Get an absolutly clean freshly upgraded to 42-11(emmc,root) system.
2. Boot the OS, enter "English","Netherlands",time/date.
3. Wait
4. Launch Media Player, select Video.
5. Try to play any of the two default files, either "Nokia N900" or "9".

Expected:
watch the selected video clip

Actual outcome:
at the bottom center there 5 "loading" dots. This goes forever.
As a side-effect also process called "gst-video-thumbnailerd" constantly eats
up to 5 percent CPU so battery gets eaten in 5-6 idle hours.

I can provide ssh access to the device through public IP. If any Nokian guys
interested, contact me via email in private.
Comment 8 Geert 2009-12-20 13:57:08 UTC
1. Play a video file
2. Get an incoming call while playing
3. When call is finished, go back to media player, no file whatsoever can be
played

I had this several times.
Comment 9 Andre Klapper maemo.org 2009-12-20 14:24:57 UTC
Please always be exact when reporting.

(In reply to comment #8)
> 1. Play a video file
What video file exactly? Format etc...

> 2. Get an incoming call while playing
GSM? Skype?

> 3. When call is finished, go back to media player, no file whatsoever can be
> played
Please post exact error messages, if available.
Comment 10 Marc 2009-12-20 19:38:24 UTC
I too have the bug, with DIVX encoded video files.

The bug is related to the RESUME functionality.  To trigger it, it's necessary
to pause a video and put the media player into background (e.g. return to the
video files browser, or go the task switcher and select a different
application).  Then you return to the video player and resume playing the
video.  Sometimes it resumes fine, but occasionally it fails with the error
message "VIDEO FORMAT NOT SUPPORTED".  From this point on, it will repeatedly
fail to play this particular video (but will happily play other videos until
you trigger the bug on them, too).

My personal suspicion is that the bug is about the resume file offset pointer,
or something very similar. Once it points to an invalid position, the media
format appears undecodeable and thus the video is unplayable.

The video player does not have an option to reset it (other than successfully
playing the file and seeking to start), so there's no easy way to verify this
theory of mine. Only strong events like rebooting the device reset the
condition for the affected files.  There seem to be more such events, but I
don't know exactly which.

Changing the video file name could be a promising path to further explore the
bug, as it would probably unlink the resume offset as well.  I don't use video
often, so all readers are invited to try this and report back here.
Comment 11 Andre Klapper maemo.org 2009-12-22 19:13:54 UTC
I can imagine that bug 7211 has the same underlying weird issue.
Bug 7211 had good instructions to reproduce the issue, but of course I
understand that these are sometimes quite hard to find...
Comment 12 Ndi 2010-01-02 22:05:31 UTC
I've had this happen with USB.

Played a video or two. Decided to add a few, transcoded a video, connected N900
to laptop (Mass storage). Copied over, removed USB. Format not supported.

Converted a second video, different container (MP4, first was AVI). Connected
USB, copied, removed USB, Nothing. Noticed that thumbnails were
white-half-a-film. Odd. Other videos played fine.

Third video, then fourth. Same issue. By now I had reverted to standard 3GP,
thinking I had some issue with the converter. They played on the laptop,
however.

Rebooted device (button power off, button power on). All 4 videos were
thumbnailed correctly and played.

I didn't notice if any video were paused by the USB connection, (no calls), but
I did play videos not-until-the-end so there was some sort of resuming going
on. The multimedia UI (video, audio, internet, etc) was still running.

One of the videos did not issue a "format not supported", but did the
five-dot-animation forever. Device went warm when playing animation, indicating
CPU was used to a decent degree.
Comment 13 Eugene 2010-01-18 00:59:52 UTC
The bug is still present in the latest 51-1. Reproducibilty 100%
Comment 14 Konstantin Starodubtsev 2010-01-18 05:56:27 UTC
This bug can be reproduced even more easily:

1. Get killer mp4 file (10mb):
http://share.ovi.com/download.aspx?media=irmin2.10018 file
2. Try to play it from media player, get a failure.
3. After it all other media files (including nokia's default 9.mp4 and
n900.mp4) will not play until reboot. Media player shows playback button, on
click nothing happens.

Playing this "broken" mp4 files with mplayer works perfectly. As it doesn't use
built-in DSP for decoding may be this problem related to standard mplayer's mp4
codec DSP optimizations.
Comment 15 Konstantin Starodubtsev 2010-01-18 06:00:11 UTC
(In reply to comment #14)
> Playing this "broken" mp4 files with mplayer works perfectly. As it doesn't use
> built-in DSP for decoding may be this problem related to standard mplayer's mp4
> codec DSP optimizations.
> 

Sorry. Typo. "standard mplayer" must be read "standard n900 media player" to
avoid confusion with mentioned first correctly working mplayer
(www.mplayerhq.hu).
Comment 16 Andre Klapper maemo.org 2010-01-18 18:35:46 UTC
Thanks for providing the testcase and in general for the investigations here!

(In reply to comment #14)
> 1. Get killer mp4 file (10mb):
> http://share.ovi.com/download.aspx?media=irmin2.10018 file
> 2. Try to play it from media player, get a failure.

Same here in internal version 2010.03-1: I've downloaded the movie ("Save to
device"), went to File Manager, clicked it, Media Player was opened, and:
        Unable to play media.
        Media format not supported.

> 3. After it all other media files (including nokia's default 9.mp4 and
> n900.mp4) will not play until reboot. Media player shows playback button, on
> click nothing happens.

I can partially confirm this. Opening the default "9" video, I see the
pulsating five dots for a minute and nothing happens. Going back to the
"Videos" view in Media Player it is even missing the preview thumbnail.
Trying this also with the N900 video, after ~1minute the screen shows the [Back
Play Forward] icons etc, the video itself is black, and the progress bar at the
bottom shows 00:37 out of 01:15 constantly.
And trying to play videos I've taken myself before I get
        Unable to play media.
        Media format not supported.
Comment 17 Butterfly 2010-01-19 00:05:45 UTC
I am having the same problem.  I can't get any of my videos to play or any of
my mp3s.  All I get is media format not supported (with the mp3's) and for the
videos, it either says the same thing or I just get the screen of dots.  It
doesn't matter whether I reboot my phone, go into file manager.  These files
WILL NOT PLAY.  I hope this problem is fixed soon, as I am only on a 12 mth
contract and I don't want to spend most of it waiting for a fix!!
Comment 18 Taomyn 2010-01-19 06:53:23 UTC
(In reply to comment #17)
> I am having the same problem.  I can't get any of my videos to play or any of
> my mp3s.  All I get is media format not supported (with the mp3's) and for the
> videos, it either says the same thing or I just get the screen of dots.  It
> doesn't matter whether I reboot my phone, go into file manager.  These files
> WILL NOT PLAY.  I hope this problem is fixed soon, as I am only on a 12 mth
> contract and I don't want to spend most of it waiting for a fix!!
> 

I had the same issue so this may help you as I discovered on my N900 that
removing the videos that were causing the player to hang up meant it would play
the others. I think it's also being triggered by the file scan of your media.
Comment 19 seignon 2010-01-24 08:58:04 UTC
After update Dvix play only sound while picture are paused
Comment 20 Andre Klapper maemo.org 2010-01-29 14:48:37 UTC
*** Bug 8643 has been marked as a duplicate of this bug. ***
Comment 21 Martin Grimme 2010-01-29 20:13:06 UTC
Just adding to comment #14:

It may not be DSP-related because the same videos play well using plain
GStreamer (which is supposed to utilize the DSP, too) with 3rd party media
players, while the Maemo Media Player refuses to play any video file until
reboot.
Manually killing the process mafw-gst-renderer appears to solve the problem
without reboot.
Comment 22 gauthamn 2010-02-01 18:06:07 UTC
Hi

I have the same problem for downloaded .flv files also. Out of the 10 flv files
I have, it plays 2 files and does not play the rest.
Is it normal for the standard player to not play .flv files. Yes I have added
extra-decoder support also. 

Cheers
Comment 23 mb 2010-02-02 14:55:14 UTC
I wondered if the behavoir on my N900 is related to this bug.

When I choose any song or video it will not play.

In songs if I click play it stays at 0:00. I see everything (Coverart Duration
and so on) If I go one step up (right top corner) to my albums I see the bars
of the "equalizer" move as if the song was playing.

Same on widget. If I click on start, the name of the song start to scroll from
right to left as if the song was playing. But no sound at all.

As for video if I start any it will show the 6 circles but then goes back to
where I can start. No video at all.

Is this conected to this bug or something else for which there would be a fix.
(At the moment I cant listen to music or watch any videos which is very
frustrating)

-----------

For me it seemed somehow to have happend when I was showing a video to a frind
and switch to mutlti task background. But i can not 100% confirm this.

------------
Regards markus
Comment 24 Marc Deop 2010-02-04 20:13:07 UTC
Following Konstantin Starodubtsev's instructions I get the same bug. Confirmed.

I can also confirm that manually killing the prosess mafw-gst-render seems to
get the player working again.
Comment 25 Paulo Sousa 2010-02-09 19:21:12 UTC
Created an attachment (id=2251) [details]
Screenshot of process "bridge-work-que" taking up 100% of CPU

I am experiencing a similar issue. After it has happened a few times, I noticed
it is related to video playing (the video player can no longer play video
files).

After a couple of hours of typical use, I notice the battery draining quickly.
I always notice the process "bridge-work-que" taking up 100% of the processor.

This has happen to me on 2 separate N900 devices.

I also do not know if "dsp-recover", which seems to be waiting for the
bridgedriver module to be become free, in order to restart the DSP is a normal
event.

These entries from "dmesg" also seems strange:
[21367.718597] ***** DSPMMU FAULT ***** IRQStatus 0x2
[21367.718627] ***** DSPMMU FAULT ***** faultAddr 0x22b9e000
[20146.329925] WMD_DEH_Notify: ********** DEVICE EXCEPTION **********
[20146.329956] WMD_DEH_Notify: DSP_MMUFAULT,errInfo = 0x0
[20146.329956] WMD_DEH_Notify: DSP_MMUFAULT, High Address = 0x2097
[20146.329986] WMD_DEH_Notify: DSP_MMUFAULT, Low Address = 0xb000
[20146.329986] WMD_DEH_Notify: DSP_MMUFAULT, fault address = 0x2097b000

Again, I am not fully sure if it is related to this issue, but it drains
the battery noticeable quickly.
Comment 26 Paulo Sousa 2010-02-09 19:22:02 UTC
Created an attachment (id=2252) [details]
Output of "ps" and "dmesg" while the issue is occurring
Comment 27 Andre Klapper maemo.org 2010-02-18 17:34:30 UTC
This has been fixed in package
openmax-omap3430-ti 0.201007-1+0m5
which is part of the internal build version
10.2010.07-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 28 Andre Klapper maemo.org 2010-02-23 23:57:55 UTC
*** Bug 9245 has been marked as a duplicate of this bug. ***
Comment 29 Andre Klapper maemo.org 2010-03-03 16:55:30 UTC
*** Bug 9345 has been marked as a duplicate of this bug. ***
Comment 30 Andre Klapper maemo.org 2010-03-05 12:36:29 UTC
*** Bug 8165 has been marked as a duplicate of this bug. ***
Comment 31 Eero Tamminen nokia 2010-03-15 12:18:43 UTC
(In reply to comment #25)
> Created an attachment (id=2251) [details] [details]
> Screenshot of process "bridge-work-que" taking up 100% of CPU
> 
> I am experiencing a similar issue. After it has happened a few times,
> I noticed it is related to video playing (the video player can no longer
> play video files).
> 
> After a couple of hours of typical use, I notice the battery draining quickly.
> I always notice the process "bridge-work-que" taking up 100% of the processor.

This is mentioned in bug 9084.  If you could find out which video triggers it
and could provide the video, or at least as much information on it as you can,
it could help checking whether that issue is the same as the one in this bug.
Comment 32 Andre Klapper maemo.org 2010-03-15 20:54:47 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 33 Karsten Br├Ąckelmann 2010-03-25 20:07:08 UTC
*** Bug 9637 has been marked as a duplicate of this bug. ***
Comment 34 Andre Klapper maemo.org 2010-04-19 12:36:13 UTC
*** Bug 9956 has been marked as a duplicate of this bug. ***
Comment 35 Eugene 2010-05-26 22:59:23 UTC
The bugs is not fixed in PR 1.2!

I just upgraded my 2 N900 and the one that had this error before still has it.
This is just bad. Should I provide anything or it's clear even without logs?
Comment 36 Jeff Moe 2010-05-27 00:54:32 UTC
I tested PR1.2 with the steps in comment #10 and in comment #14 and was not
able to get the bug to appear. The file in comment #14 doesn't play, but
subsequent files play fine.
Comment 37 Eero Tamminen nokia 2010-05-27 19:35:20 UTC
(In reply to comment #35)
> The bugs is not fixed in PR 1.2!
> 
> I just upgraded my 2 N900 and the one that had this error before still has it.
> This is just bad. Should I provide anything or it's clear even without logs?

This bug is about files that could be played earlier not being anymore playable
after trying to play a bad video file.
Comment 38 Eugene 2010-05-28 07:20:25 UTC
> This bug is about files that could be played earlier not being anymore playable
> after trying to play a bad video file.

OK, switching to 7211 only.