Bug 6811 (int-136484)

Summary: Incorrect entries in the Birthday Smart Calendar
Product: [Maemo Official Applications] Calendar Reporter: stobbsc
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: calendar-general-bugs
Severity: normal    
Priority: Low CC: adlorenz, andrea, andrew, andre_klapper, christianrol, fraaaaanka, maemo, stobbsc
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description stobbsc (reporter) 2009-12-10 15:41:26 UTC
SOFTWARE VERSION:1.2009.42-11.203.2

EXACT STEPS LEADING TO PROBLEM: 
1. Created a contact on my device
2. Synced with application called Hermes
3. Viewed Birthday Smart calendar 
4. Deleted various Contacts from my Contacts DB
5. Viewed Birthday Smart calendar 

EXPECTED OUTCOME:
One Event per contact with a birthday tag should appear in the smart calendar
Delete contacts should no longer have event items in the smart calendar

ACTUAL OUTCOME:
Some contacts had duplicate birthday events in the smart calendar.
Some contacts after being deleted still had a birthday even item in the
calendar which I would have expected to be removed.

REPRODUCIBILITY:
Unsure as I can't remove items from the Calendar to start again.

EXTRA SOFTWARE INSTALLED:Hermes

OTHER COMMENTS:
This bug seems to be affect many uses other than myself. It doesn't seem to be
related to the Hermes application. As vCards of contacts so 1 birthday event
but the calendar shows 2.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Comment 1 Andrew Flegg maemo.org 2009-12-10 16:00:06 UTC
I've also seen this. I have a single contact who shows up twice for her
birthday (7th Dec) in the calendar.

Exporting the vCard shows only a single BDAY record.
Comment 2 Chris 2009-12-11 23:05:55 UTC
I had the same problem. Pleas solve this!!!
Comment 3 Chris 2009-12-11 23:22:22 UTC
I noticed that just by removing/reapplyng the birthday calendar from the
calendar, keeps creating duplicate events for birthdays.
Comment 4 Lucas Maneos 2009-12-15 20:54:24 UTC
(In reply to comment #3)
> I noticed that just by removing/reapplyng the birthday calendar from the
> calendar, keeps creating duplicate events for birthdays.

I can confirm this case at least.
Comment 5 Lucas Maneos 2009-12-15 21:04:04 UTC
And after another deletion & creation of the birthdays calendar my asterisk
server now has 3 birthdays.

Exporting the entire addressbook shows no duplicates and only one BDAY field in
the contact's .vcf

Exporting the Birthdays calendar results in this:

BEGIN:VCALENDAR
VERSION:1.0
BEGIN:VEVENT
CREATED:20091215T185014Z
SUMMARY:asterisk
UID:5
DTSTART:19841215T000000
DTEND:19841215T000000
SEQUENCE:0
STATUS:NEEDS-ACTION
LAST-MODIFIED:20091215T185014Z
RRULE:FREQ=YEARLY;UNTIL=20371231T235959
END:VEVENT
END:VCALENDAR

BEGIN:VCALENDAR
VERSION:1.0
BEGIN:VEVENT
CREATED:20091215T185115Z
SUMMARY:asterisk
UID:6
DTSTART:19841215T000000
DTEND:19841215T000000
SEQUENCE:0
STATUS:NEEDS-ACTION
LAST-MODIFIED:20091215T185115Z
RRULE:FREQ=YEARLY;UNTIL=20371231T235959
END:VEVENT
END:VCALENDAR

BEGIN:VCALENDAR
VERSION:1.0
BEGIN:VEVENT
CREATED:20091215T185742Z
SUMMARY:asterisk
UID:7
DTSTART:19841215T000000
DTEND:19841215T000000
SEQUENCE:0
STATUS:NEEDS-ACTION
LAST-MODIFIED:20091215T185742Z
RRULE:FREQ=YEARLY;UNTIL=20371231T235959
END:VEVENT
END:VCALENDAR

Note the different UID and timestamp fields.

This may be significant: the exported contact contains UID:5, while all other
contacts are in the form UID:osso-abook-tmcN.
Comment 6 Lucas Maneos 2009-12-15 21:19:33 UTC
Running sqlite3 on /home/user/.calendar/calendardb shows:

sqlite> SELECT * FROM Components WHERE Summary = "asterisk";
5|3|4|3|471916800|471916800|asterisk|||1984||2145916799|1|1260903014|1260903014|:Europe/London|0
6|3|4|3|471916800|471916800|asterisk|||1984||2145916799|1|1260903075|1260903075|:Europe/London|0
7|3|4|3|471916800|471916800|asterisk|||1984||2145916799|1|1260903462|1260903462|:Europe/London|0
Comment 7 Andre Klapper maemo.org 2009-12-15 22:58:40 UTC
Thanks for reporting this.

This has been fixed in package
calendar-backend 0.5-9.8+0m5
which is part of the internal build version
2.2009.42-7
(Note that 2009 is the year and the number after is the week.)

A future public update released with or after this build version will include
the fix. Note that the fix is NOT included in 1.2009.42-11.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Note that Nokia does not announce release dates of public updates in advance.
Comment 8 Andre Klapper maemo.org 2010-01-14 12:29:55 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 9 Chris 2010-01-14 14:39:59 UTC
Confirming, this has been fixed in update version 2.2009.51-1, no more
duplicates. If you backed up your calendar data before the update and restored
it after, you'll have to create the birthday calendar and delete it the first
time. When you recreate it the second time it show no more duplicates.
Comment 10 Andrew Franklin 2010-01-14 16:08:45 UTC
fixed with update today (
Comment 11 stobbsc (reporter) 2010-01-14 16:55:49 UTC
this is now working.

I created this bug does that mean I need to close it?
Comment 12 Andre Klapper maemo.org 2010-01-14 17:06:04 UTC
See:
Status:       RESOLVED
Resolution:     FIXED
and see comment 7.
Comment 13 Andre Klapper maemo.org 2010-01-14 20:47:01 UTC
*** Bug 7958 has been marked as a duplicate of this bug. ***
Comment 14 Dawid Lorenz 2010-01-19 21:08:37 UTC
(In reply to comment #9)
> Confirming, this has been fixed in update version 2.2009.51-1, no more
> duplicates. If you backed up your calendar data before the update and restored
> it after, you'll have to create the birthday calendar and delete it the first
> time. When you recreate it the second time it show no more duplicates.
> 

I was about to reopen this report but seen your comment and now I can confirm
it is fixed - assuming that user re-created smart calendar, as it seems not
fixed at first.