Bug 6770 (int-139919)

Summary: Can't delete route waypoints in Map application
Product: [Maemo Official Applications] Map Reporter: PeteC <petechap>
Component: GeneralAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: map-bugs
Severity: normal    
Priority: Low CC: andre_klapper, maemo
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description PeteC (reporter) 2009-12-09 18:05:34 UTC
SOFTWARE VERSION:
1.2009.42-11.203.2

EXACT STEPS LEADING TO PROBLEM: 
1. Open Maps
2. Open Routing
3. Choose a destination (from GPS or map, doesn't matter)
4. Go the the Waypoints screen, and "Add another destination" (again, doesn't
matter where from)
5. Go back to the Waypoints screen (there will be 3 points in there now)

EXPECTED OUTCOME:
It should be possible to delete one or more waypoints from the route (forcing
recalculation) - especially when there are 3 or more.

ACTUAL OUTCOME:
There is no interface for deleting a waypoint

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
When you're looking at the map and choose the "---" icon, you get a choice of 3
options: "Waypoints", "Directions" and "Route settings".
The icon for "Waypoints" shows a screen thumbnail where both waypoints have an
'X' to their right, implying that someone has thought about deleting waypoints
in the past.

(It would be nice to re-order the waypoints too, but not such a big deal for
me)


User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1.4)
Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4
Comment 1 Lucas Maneos 2009-12-10 03:32:14 UTC
Confirmed, feel free to add your vote.
Comment 2 Andre Klapper maemo.org 2009-12-16 04:13:09 UTC
Thanks for reporting this.

This has been fixed in package
nokia-maps-ui 0.2.0-1
which is part of the internal build version
2.2009.47-1 or earlier
(Note that 2009 is the year and the number after is the week.)

A future public update released with or after this build version will include
the fix.
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

To cover popular followup questions:
* Nokia does not announce release dates of public updates in advance.
* There is currently no access to these internal, non-public firmware versions.
A Brainstorm proposal exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-01-14 12:27:20 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 PeteC (reporter) 2010-02-04 16:54:00 UTC
much better after 51.1, thanks