Bug 6769 (int-150281)

Summary: Can't answer a phone call with a short caller ID
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: antti.miettinen
Component: Call Application UIAssignee: rtcomm <rtcomm>
Status: RESOLVED FIXED QA Contact: call-ui-bugs
Severity: major    
Priority: Medium CC: andre_klapper, cherfim, ehsan, freecan, joda009, lochan.amatya, maemo, mikhail.zabaluev, ohiivatukka
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description antti.miettinen (reporter) 2009-12-09 17:56:13 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Version number: 1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Aswering phone when it rings.
2.
3. 

EXPECTED OUTCOME:
Aswering phone normally and saw the caller number and call back to the caller.

ACTUAL OUTCOME:
When answering phone and caller use short number example 1234 the phone say
"unknown number". Also if trying to call back to the caller, the phone say
"call not allowed"

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always when using the short numbers.

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
This problem is annoying.

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; MS-RTC LM 8)
Comment 1 Mikhail Zabaluev nokia 2009-12-11 16:30:08 UTC
What's the operator? Could you give some example caller numbers that exhibit
this problem?
Comment 2 antti.miettinen (reporter) 2009-12-11 20:53:21 UTC
Operator is dna finland and we use internal switch.

The problem occured always when using the internal switch numbers. (example
2222 and 89-2222.)

But when using numbers from outside internal switch, callers id is shown
normally.
Comment 3 Mikhail Zabaluev nokia 2009-12-14 13:50:49 UTC
Let's recheck: you are able to answer a call from such a caller (the UI showing
"unknown number"), but you can't dial back? Presumably, this is because caller
ID fails and our software does not have a number to call back.
Can you confirm it works with some other phone, for example Nokia S60 phones?
Comment 4 antti.miettinen (reporter) 2009-12-14 16:06:04 UTC
Yes, you get problem right. 
I can answer the phone but, I'm unable to call back.
Sim card works fine on E90 and other S60 phones. 
(Tested E70, E90, N97)
This problem is tested 4 - different N900 and all of them give same result.
Comment 5 Mikhail Zabaluev nokia 2009-12-16 13:05:33 UTC
(In reply to comment #4)
> I can answer the phone but, I'm unable to call back.
> Sim card works fine on E90 and other S60 phones. 
> (Tested E70, E90, N97)

The real question is, are you able to call back on those phones. Are the short
caller IDs visible there?
Comment 6 antti.miettinen (reporter) 2009-12-16 16:24:23 UTC
The short callers ID is shown as "Unknown number" and I cannot call them back.
Comment 7 Mikhail Zabaluev nokia 2009-12-16 18:35:53 UTC
Well, then I don't know how can we help if there is simply no information about
the caller.
Comment 8 Mehdi CHERFI 2010-01-06 10:17:56 UTC
(In reply to comment #7)
> Well, then I don't know how can we help if there is simply no information about
> the caller.
> 


hi there,

I'm facing the same issue here and it's becoming difficult to use my N900 in
work so I'll try to answer your questions.

the problem occur when we receive a call with short number (ericsson vpn,
alcatel cmm, internal switch ...) the N900 displays unknown number, the fact
that  antti.miettinen is not able to call back is simply because the doesn't
has a number to call back (same as when you receive a call from a hidden
number)

so the real problem here is the N900 inability to display short numbers.

please let me know if you need to know something, I know I'm horrible at
explanations :)
Comment 9 Mikhail Zabaluev nokia 2010-01-18 18:19:23 UTC
Thanks for the provided information. We'll investigate the problem as
explained.
Comment 10 Andre Klapper maemo.org 2010-01-21 00:02:11 UTC
Bug 8081 might be a duplicate.
Comment 11 Mikhail Zabaluev nokia 2010-01-21 14:00:33 UTC
*** Bug 8081 has been marked as a duplicate of this bug. ***
Comment 12 Mikhail Zabaluev nokia 2010-01-21 14:09:34 UTC
It would help to have a syslog (enabled by installing package sysklogd) with a
debugging variable added to the environment, for example by adding the line
below to the file /etc/osso-af-init/af-defines.sh:

export RING_DEBUG=all
Comment 13 Mehdi CHERFI 2010-01-21 20:50:31 UTC
(In reply to comment #12)
> It would help to have a syslog (enabled by installing package sysklogd) with a
> debugging variable added to the environment, for example by adding the line
> below to the file /etc/osso-af-init/af-defines.sh:
> 
> export RING_DEBUG=all
> 

you mean this one ?

Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB MESSAGE Modem-Call
- incoming call from ""
Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_channel_set_property: (0x7c148) with nick 'incoming657314892'
Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_channel_constructed: (0x7c148) with incoming657314892
Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_manager_emit_new_channel:
ring_media_manager_emit_new_channel(0x65018, (nil), 0x7c148, (nil)) called
Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_manager_emit_new_channel: got new channel 0x7c148 nick
incoming657314892 type RingCallChannel
Jan 21 19:47:29 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
update_media_stream: emitting StreamAdded(1, 2, AUDIO)
Jan 21 19:47:30 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
update_media_stream: emitting StreamStateChanged(1, CONNECTING)
Jan 21 19:47:30 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
update_media_stream: emitting StreamDirectionChanged(1, NONE, remote local)
Jan 21 19:47:30 Nokia-N900-42-11 wlancond[1108]: Scan issued
Jan 21 19:47:30 Nokia-N900-42-11 wlancond[1108]: Scan results ready -- scan
active
Jan 21 19:47:31 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
update_media_stream: emitting StreamStateChanged(1, CONNECTED)
Jan 21 19:47:31 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
update_media_stream: emitting StreamDirectionChanged(1, SEND, remote)
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_call_channel_remove_member_with_reason: enter
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB MESSAGE Modem-Call
- mo-released incoming call from '' com.nokia.csd.Call.Error.BusyUserRequest:
Busy User Request Error
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
on_modem_call_status_mo_release: MO_RELEASE: message="" reason=NONE (0)
cause=com.nokia.csd.Call.Error.BusyUserRequest (1.4)
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG
tp-glib/groups - tp_group_mixin_change_flags: No change: 6144 includes all the
bits of 0 and none of 7
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB MESSAGE Modem-Call
- terminated incoming call from '' com.nokia.csd.Call.Error.BusyUserRequest:
Busy User Request Error
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_channel_emit_closed: emit Closed on incoming657314892
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_media_channel_finalize: (0x7c148) on incoming657314892
Jan 21 19:47:33 Nokia-N900-42-11 telepathy-ring[1039]: GLIB DEBUG Ring -
ring_call_channel_finalize: exit
Jan 21 19:47:33 Nokia-N900-42-11 rtcom-call-ui[1455]: GLIB CRITICAL **
libosso-abook - osso_abook_aggregator_find_contacts_for_phone_number: assertion
`!IS_EMPTY (phone_number)' failed
Comment 14 Mikhail Zabaluev nokia 2010-01-22 14:22:46 UTC
(In reply to comment #13)
> you mean this one ?

Yes, great thanks.
Comment 15 Andre Klapper maemo.org 2010-01-22 17:01:23 UTC
*** Bug 7851 has been marked as a duplicate of this bug. ***
Comment 16 Mikhail Zabaluev nokia 2010-02-01 13:06:56 UTC
The fix delivered internally.
Comment 17 Andre Klapper maemo.org 2010-02-03 13:27:33 UTC
This has been fixed in package
libcscall 0.8.3.5+0m5
which is part of the internal build version
2010.05-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 18 Andre Klapper maemo.org 2010-02-28 22:56:55 UTC
*** Bug 9322 has been marked as a duplicate of this bug. ***
Comment 19 Andre Klapper maemo.org 2010-03-03 19:22:48 UTC
*** Bug 9383 has been marked as a duplicate of this bug. ***
Comment 20 Andre Klapper maemo.org 2010-03-15 20:52:07 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 21 Lucas Maneos 2010-04-08 13:24:14 UTC
*** Bug 9868 has been marked as a duplicate of this bug. ***
Comment 22 Andre Klapper maemo.org 2010-04-08 15:40:04 UTC
*** Bug 9870 has been marked as a duplicate of this bug. ***