Bug 6752 (int-134998)

Summary: Low power/battery beep does not sound if you're on a call
Product: [Maemo Official Platform] System software Reporter: David W. Aquilina <maemo-bz>
Component: generalAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: system-software-general-bugs
Severity: normal    
Priority: Low CC: andre_klapper, kaitsu
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description David W. Aquilina (reporter) 2009-12-09 08:01:38 UTC
SOFTWARE VERSION: 1.2009.42-11.002
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Make a phone call while the device is not fully charged 
2. Talk long enough to fully deplete the battery
3. 

EXPECTED OUTCOME: When the phone is low on power it should chime even if you're
on a call. 

ACTUAL OUTCOME: The phone goes dead with no warning, with a potentially
disastrous personal impact if you're on the phone with a romantic interest at
the time! 

REPRODUCIBILITY: happened once, have not attempted to reproduce
Comment 1 kaitsu 2009-12-10 14:52:31 UTC
This behaviour has happened to me aswell. 

SOFTWARE VERSION: 1.2009.42-11
Comment 2 Andre Klapper maemo.org 2009-12-15 16:12:14 UTC
Heja,
Thanks for reporting this.

David, kaitsu:
Does this refer to a regular call (int-110606)? Or a Skype call (int-134998)?
I assume you used no headset? :)
Is the visual notification at least visible on the screen?
Comment 3 kaitsu 2009-12-15 16:41:22 UTC
(In reply to comment #2)
> Heja,
> Thanks for reporting this.
> 
> David, kaitsu:
> Does this refer to a regular call (int-110606)? Or a Skype call (int-134998)?
> I assume you used no headset? :)
> Is the visual notification at least visible on the screen?
> 

In my case this refers to regular call. 
No headset was used. I used the normal microphone & speaker setup as you would
normally talking to cellphone.

Since i had my head to the screen (and the proximity sensor was operating as
should), i can't say about the visual cues.

This could be tested by using the stereo speakers + keeping the screen alive
and then draining the battery while speaking.
Comment 4 Andre Klapper maemo.org 2009-12-15 16:55:51 UTC
Hmm, would probably also be cool to know in which Profile (Silent / General)
this happened, and what the master volume was.
But this is already helpful, thanks!
Comment 5 Andre Klapper maemo.org 2009-12-15 17:48:38 UTC
This has been fixed in package
status-area-applet-battery 0.1.21+0m5
which is part of the internal build version
2.2009.46-5
(Note that 2009 is the year and the number after is the week.)

A future public update released with or after this build version will include
the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Note that Nokia does not announce release dates of public updates in advance.
Comment 6 Andre Klapper maemo.org 2010-01-14 12:25:56 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.