Bug 6671 (int-143907)

Summary: Sometimes the browser window goes black for over a second after clicking the fullscreen/restore button
Product: [Maemo Official Applications] Browser Reporter: Tim Samoff <tim>
Component: User interfaceAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: browser-bugs
Severity: normal    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Tim Samoff (reporter) maemo.org 2009-12-07 18:03:52 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open a web page in Maemo Browser
2. Tap the minimize/maximize button until you see the "bug"
3. If this doesn't work, try opening several (2-4 browser windows)

EXPECTED OUTCOME:
Minimize/maximize buttons cause no ill-effect to content within window.

ACTUAL OUTCOME:
Sometimes, the period of black is unacceptable.

REPRODUCIBILITY:
2.5/10

OTHER COMMENTS:
Sometimes it helps to have a couple of other apps open as well.
Comment 1 Andre Klapper maemo.org 2009-12-07 20:33:59 UTC
I had bug 6427 in mind, but that's probably a different case.
Comment 2 Tim Samoff (reporter) maemo.org 2009-12-07 20:47:06 UTC
Hm, yes, slightly different, although they all might hinge on the same issue.

Sounds like his text input field bug is similar to mine (#6682), though.
Comment 3 Andre Klapper maemo.org 2009-12-16 01:42:42 UTC
I assume that this is represented internally by int-143907, however Browser
bugs are quite a mess. :)
Comment 4 Andre Klapper maemo.org 2010-01-12 13:41:15 UTC
This is fixed in 2.2009.46-9.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:30:10 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 Tim Samoff (reporter) maemo.org 2010-01-14 15:51:39 UTC
(In reply to comment #5)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

Apologies... Is this different than the version 2.2009.51-1 that some of us
already have? I'm asking because this still occurs for me (although it's white
or checkerboard instead of black).
Comment 7 timeless 2010-01-15 00:12:29 UTC
andre has unfortunately picked the wrong bug, this happens.

i think this is actually a bug in the xserver.

I've refiled this bug against the x server as a courtesy as bug 8013.

DO NOT REOPEN THIS BUG AS YOU WILL EARN CONSIDERABLE ENMITY FOR WASTING MY
TIME.