Bug 6669 (int-145537)

Summary: Browser window checkerboards and repaints when navigated to from multi-task view
Product: [Maemo Official Applications] Browser Reporter: Tim Samoff <tim>
Component: User interfaceAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: browser-bugs
Severity: normal    
Priority: Low CC: adancau, andre_klapper, anidel, bugzilla770, donn.morrison
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Tim Samoff (reporter) maemo.org 2009-12-07 17:56:36 UTC
SOFTWARE VERSION:
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open a web page in Maemo Browser
2. Minimize it so that you are in the multi-task view
3. Tap on the browser window to bring it back into focus

EXPECTED OUTCOME:
Browser window returns just like every other app, without a blink/flickr.

ACTUAL OUTCOME:
Browser windows blinks once before web page is viewable.

REPRODUCIBILITY:
always
Comment 1 timeless 2009-12-07 21:22:18 UTC
ok, it's painting a checkboard (roughly "no rendered content") and then we
paint the actual page.

there are internal builds with this fixed. not sure about release plans.
Comment 2 Donn Morrison 2009-12-09 16:23:21 UTC
This could be a more generic version of bug 6215.
Comment 3 Andre Klapper maemo.org 2009-12-14 17:06:31 UTC
*** Bug 6215 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2009-12-16 01:42:24 UTC
Looks like int-145537 to me which is not reproducible in the internal version
2.2009.47-5.
(Which does not mean that it's necessarily fixed, but probably by some side
effects.)
Comment 5 Aniello Del Sorbo 2009-12-26 16:19:29 UTC
Can't reproduce this in 2.2009.51-1. Thus I think we can mark this as fixed and
verified.
Comment 6 Andre Klapper maemo.org 2010-01-14 12:30:09 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 7 Neil MacLeod maemo.org 2010-01-14 14:34:38 UTC
I'm afraid I still get the blink/flicker when maximising browser windows in
2.2009.51-1 (this is the image released on 23 Dec 2009 not 14 Jan 2009).

One web site that blinks almost all the time is http://news.bbc.co.uk.

Sometimes http://news.bbc.co.uk will stop blinking as it is maximised, but
minimising it and maximising another minimised app window (doesn't have to be
another browser window, eg. try Contacts) and then maximising
http://news.bbc.co.uk again will almost always result in the browser window
"blinking".
Comment 8 Andrei Dancau 2010-01-14 14:45:18 UTC
It's still happening in PR1.1, just that the redraw is a bit faster, but still
there.
Comment 9 timeless 2010-01-14 23:47:21 UTC
Tim/Neil/Andrei: we have a problem. I can't allow you guys to resurrect bugs
continuously. Even if the bug isn't really fixed, if you don't do a good job of
filing your bugs, you'll have to accept poor resolutions for them.

Andre: i'm pretty sure you picked the wrong internal bug. this bug clearly
mentions checkerboard, the internal picture (yay!) shows a truncated view in
the dashboard which hopefully you'll accept is a different problem.

Andrei/Neil/Tim: ctrl-shift-p will take a screen shot. And there's an app iirc
which enables you to use the camera button to take screen shots.

I think actually what you'll find is that what we're dealing with is a feature
and not a bug. I've refile this as bug 8010 with complete steps to reproduce
and then resolve it.

DO NOT REOPEN THIS BUG. DOING SO WILL EARN YOU A PERMANENT NAUGHTY BIT.
Comment 10 Neil MacLeod maemo.org 2010-05-26 00:41:18 UTC
Fixed in PR1.2