Bug 6622 (int-138870)

Summary: nokia messaging doesn't synchronize selected imap folders
Product: [Maemo Official Applications] Email Reporter: Kamil Erhard <kadawer>
Component: Nokia Messaging ServiceAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: nokia-messaging-service-bugs
Severity: critical    
Priority: Low CC: andre_klapper, irina.zolotareva, kadawer, lassebugz
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Maemo   

Description Kamil Erhard (reporter) 2009-12-06 10:05:34 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM:
1. create an nokia messaging account through email.nokia.com website
2. enter your email provider details
2. select additional imap subfolders for synchronization (up to 10 selections
are possible) and confirm selection
3. use this account on the n900

EXPECTED OUTCOME:
additional folders are synchronized and accessible

ACTUAL OUTCOME:
no additional folder appears on the n900 account

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
-

OTHER COMMENTS:
nokia messaging is currently the only possibility to use real email push,
because imap idle is not activated in modest, so this bug is really critical.
Comment 1 Irina Zolotareva nokia 2009-12-08 14:12:27 UTC
Fixed in #138870 for PR1.1. 

Br
Comment 2 Andre Klapper maemo.org 2009-12-08 20:25:16 UTC
Ah, thanks, Irina!

This has been fixed in package
nokiamessaging 1.4.2+0m5
which is part of the internal build version
2.2009.45-7 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:28:30 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 lassebugz 2010-01-15 13:34:23 UTC
The fix itself seems to work just fine (in my case using gmail through Nokia
Messaging service), but the new "functionality" seems to have two new bugs:

1) Cannot open messages from other folders by clicking the yellow notification
box (works for messages in Inbox, but not for other folders). Produces an error
that the message does not exist on server.

2) Messages read from other folders are not marked as "read" in the mail
service (gmail in this case). Again, for inbox this works just fine.

Should I submit separate bugs for both of these?