Bug 6612 (int-121760)

Summary: File manager fails to show folder sizes beyond 999,9 MB
Product: [Maemo Official Applications] Utilities Reporter: Henri Björkman <gulassi>
Component: File managerAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: file-manager-bugs
Severity: minor    
Priority: Low CC: andre_klapper, andydunmore, dyerga, tri
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Henri Björkman (reporter) 2009-12-06 00:10:43 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open file manager 
2. Open details of folder that contains more than 999,9 MB of files

EXPECTED OUTCOME:
File manager shows combined size of files in the folder

ACTUAL OUTCOME:
File manager calculates size of files, but when the size field reaches 999,9 MB
it changes to 0,00 GB and stays there

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Openssh client 5.1p1-6.maemo5
ecoach 1.56
Forecaweather widget 0.9.4
load-applet 0.4.6-1
zoutube 0.1-19
account-plugin-butterfly 0.3
rootsh 1.8

Other Comments
Using English as device language but Finland as regional settings
Comment 1 Venomrush 2009-12-06 04:13:54 UTC
Confirm for me too. I was not able to see the total size of my personal music
folder (I know that it's ~1.7GB)

Good find!
Comment 2 Andre Klapper maemo.org 2009-12-06 09:32:43 UTC
Thanks for reporting this!

(In reply to comment #0)
> 1. Open file manager 
> 2. Open details of folder that contains more than 999,9 MB of files

...by tapping on the folder and choosing "Details" from the context menu.

That's why the bug template asks you to provide exact steps - makes it easier
to reproduce. :)


This issue has been fixed in package
libhildonfm 1:2.28.4+0m5
which is part of the internal build version
2.2009.45-14 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 3 Lucas Maneos 2009-12-09 15:10:44 UTC
*** Bug 6756 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Martin Yerga 2009-12-23 17:47:15 UTC
Verified in non-public PR1.1 version (2.2009.51-1).
Comment 5 Andre Klapper maemo.org 2010-01-14 12:25:35 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.