Bug 6544 (int-133672)

Summary: USA localization displays distance in kilometers
Product: [Maemo Official Applications] Map Reporter: Ian Monroe <ian.monroe>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: map-bugs
Severity: normal    
Priority: Medium CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   

Description Ian Monroe (reporter) 2009-12-03 16:21:13 UTC
SOFTWARE VERSION:
1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
1. In initial device setup, I selected my regional setting as English (USA).
2. Create a route in Ovi Maps.

EXPECTED OUTCOME:
The route length should be displayed in miles cause this is 'mercia and that's
how we roll. (Seriously all road signs and speed limits are in miles etc etc). 

ACTUAL OUTCOME:
Displays distance in kilometers.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
This is one of the devices from the Maemo conference. I did flash the update.
But I suppose its possible that I don't have 100% of the localizations that
someone buying a N900 in the US will have?
Comment 1 Andre Klapper maemo.org 2009-12-04 13:59:05 UTC
This has been fixed in package
nokia-maps-ui 0.2.0-6+0m5
which is part of the internal build version
2.2009.49-2
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:27:19 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.