Bug 6487

Summary: Volume buttons should work while playing music and device is locked
Product: [Maemo Official Platform] Multimedia Reporter: Collin Mulliner <collin>
Component: Multimedia frameworkAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: multimedia-framework-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, antonino.digiglio, hikmetcancelik, miniscalope, quim.gil, rkmaemo
Version: 5.0/(1.2009.42-11)   
Target Milestone: ---   
Hardware: N900   
OS: Linux   

Description Collin Mulliner (reporter) 2009-12-01 22:43:29 UTC
feature request: volume buttons should work while playing music and device is
locked.
Comment 1 Quim Gil nokia 2009-12-07 09:16:01 UTC
Playing music with the device speakers? With wired headset? BT headset?

The volume buttons of the device, of the speakers?

Please be precise in your use cases.
Comment 2 H. Can Celik 2009-12-07 11:10:10 UTC
(In reply to comment #1)
> Playing music with the device speakers? With wired headset? BT headset?
> 
> The volume buttons of the device, of the speakers?
> 
> Please be precise in your use cases.
> 

Device speakers.
Comment 3 eppupu 2009-12-07 14:51:23 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 krk969 2009-12-07 16:00:30 UTC
would like to add that it doesnt work with wired headset also.
Comment 5 H. Can Celik 2009-12-07 19:08:09 UTC
(In reply to comment #4)
> would like to add that it doesnt work with wired headset also.
> 

yes it doesn't work with either wired or bluetooth headset.
Comment 6 Andre Klapper maemo.org 2009-12-08 15:24:27 UTC
Currently locked means locked, no matter which sound output is used.
However, the question was about your usecases - why do you want this, in which
situations? Hence Quim's question.

Collin: Also, for future reference, please always use the bug template.
Comment 7 krk969 2009-12-08 16:47:38 UTC
(In reply to comment #6)
> Currently locked means locked, no matter which sound output is used.
> However, the question was about your usecases - why do you want this, in which
> situations? Hence Quim's question.
> 
> Collin: Also, for future reference, please always use the bug template.
> 

The volume controls dont work if the screen is turned off or even if the device
is locked using the power button.
We normally swtich off the screen using the button on the side , next to the
headphone socket or it turns off after a set time, the controls not working
after it means i need to switch screen on again, wastes battery, and also is a
pain especially when you are moving.

I agree this is a must on any device used for music, the last thing you want to
do is fiddle around with the device and making it fall , just to adjust volume,
pause/play. or change tracks.
Comment 8 H. Can Celik 2009-12-08 19:30:26 UTC
(In reply to comment #6)
> Currently locked means locked, no matter which sound output is used.
> However, the question was about your usecases - why do you want this, in which
> situations? Hence Quim's question.
> 
> Collin: Also, for future reference, please always use the bug template.
> 

I think it's same as using the volume keys while you're talking. I bet the
screen gets lock during the phone call to avoid touches from ear but still you
can volume up/down. I also totally agree with krk969.
Comment 9 Quim Gil nokia 2009-12-09 08:19:14 UTC
Discussing this in the Maemo team. Good initial feelings. I will report here as
soon as there is a decision.
Comment 10 Antonino Di Giglio 2009-12-10 12:12:18 UTC
I notice this, too.

@Andre Klapper
Yes, locked means locked, but not turn off! Hardware button should work even if
the device is locked...More if is volume button
I agree with krk969
Comment 11 Andre Klapper maemo.org 2009-12-10 15:07:20 UTC
(In reply to comment #10)
> Yes, locked means locked, but not turn off!

And nobody stated that.

 Hardware button should work even if
> the device is locked...More if is volume button

That has been written before, no need to repeat it in another comment.
Feel free to vote, though.
Comment 12 miniscalope 2009-12-11 00:06:49 UTC
Sony Ericsson Walkman phones do it so N900 should too...
Comment 13 Andre Klapper maemo.org 2009-12-11 11:37:29 UTC
(In reply to comment #12)
> Sony Ericsson Walkman phones do it so N900 should too...

Please avoid unhelpful comments like this as they create bugmail. This is a
bugtracker, not a forum, and just because one single company out there provides
this feature it is NOT that N900 "should" do it too.
Comment 14 Andre Klapper maemo.org 2010-01-21 20:12:13 UTC
Bug 8011 has an internal copy plus more votes than this one. Marking as
duplicate, please transfer your votes as this does not happen automatically.

*** This bug has been marked as a duplicate of bug 8011 ***