Bug 6375

Summary: Provides SMS buttons for "Phone" entries and not only "Mobile" entries
Product: [Maemo Official Applications] Contacts Reporter: clmntch
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: contacts-bugs
Severity: normal    
Priority: Low CC: andre_klapper, astrand, bugzilla770, jorgen.scheibengruber, josh, jrichards, maemo, maemo, maemo, mathias.hasselmann, mikhail.zabaluev, moe, r0polach, vilre
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Linux   

Description clmntch (reporter) 2009-11-27 22:52:13 UTC
SOFTWARE VERSION:
Nokia N900
Maemo5
Version:1.209.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
Basically all contacts will have a send sms option for all phone numbers,\.

EXPECTED OUTCOME:
 I'm not quite sure, but I would assume that only mobile numbers should have a
send SMS button.

ACTUAL OUTCOME:
Every single phone number for a contact will have a send SMS button.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
none

OTHER COMMENTS:
not sure if it is necessary to have sms buttons for all phone numbers. but it
definitely takes up a lot of screen realestate for contacts that have a lot of
phone numbers. 

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5)
Gecko/20091105 Fedora/3.5.5-1.fc11 Firefox/3.5.5
Comment 1 Andre Klapper maemo.org 2009-11-28 02:29:37 UTC
Thanks for reporting this.

Idealistically speaking your totally right.
However after checking here I must say that nearly all of my contacts that I
have important from my SIM card (that was used in another mobile phone before)
have been important as "Phone" and not "Mobile". Actually the numbers are quite
mixed, both landline and mobile numbers.

So it's probably a WONTFIX for convenience reasons - there's no way when
importing those contacts from SIM cards (which is a quite common case I assume)
for the Contacts application to realize whether it's a mobile or a landline
number and hence it's the way it currently is.
That's just my guess though.
Comment 2 Lucas Maneos 2009-11-28 03:17:58 UTC
(In reply to comment #0)
> I'm not quite sure, but I would assume that only mobile numbers should have a
> send SMS button.

In the UK at least landline numbers can also accept SMS.
Comment 3 clmntch (reporter) 2009-11-28 05:33:45 UTC
This doesn't just affect contacts imported from SIM card. they are new contacts
entered manually.  When I create a new contact select "Phone" then enter
number, and then I select "Mobile" and enter a number... They will both have a
"SMS" button... 

This also affects contacts imported from google sync (m.google.com)...

(In reply to comment #1)
> Thanks for reporting this.
> 
> Idealistically speaking your totally right.
> However after checking here I must say that nearly all of my contacts that I
> have important from my SIM card (that was used in another mobile phone before)
> have been important as "Phone" and not "Mobile". Actually the numbers are quite
> mixed, both landline and mobile numbers.
> 
> So it's probably a WONTFIX for convenience reasons - there's no way when
> importing those contacts from SIM cards (which is a quite common case I assume)
> for the Contacts application to realize whether it's a mobile or a landline
> number and hence it's the way it currently is.
> That's just my guess though.
>
Comment 4 clmntch (reporter) 2009-11-28 05:36:59 UTC
You can send a landline a SMS here (US), but I'm not sure what would happen to
it.

(In reply to comment #2)
> (In reply to comment #0)
> > I'm not quite sure, but I would assume that only mobile numbers should have a
> > send SMS button.
> 
> In the UK at least landline numbers can also accept SMS.
>
Comment 5 Lucas Maneos 2009-11-28 06:03:48 UTC
Here they are delivered, see
<http://www.productsandservices.bt.com/consumerProducts/displayTopic.do?topicId=24181>.
 Also according to <http://www.voip-info.org/wiki/view/Asterisk+cmd+Sms>
similar services operate in several other countries.

So, since knowing that a number is "mobile" does not provide sufficient
information to decide whether it can receive SMS, I would say the current
behaviour is not a bug.
Comment 6 clmntch (reporter) 2009-11-28 06:22:26 UTC
I don't want to go back and forth about this... I'm sure somebody somewhere
will send a sms to a landline.  However, I think it would be more common to
send one to a 'mobile' phone. Is it absolutely necessary to have every single
phone number in your contacts have a SMS button... 

(In reply to comment #5)
> Here they are delivered, see
> <http://www.productsandservices.bt.com/consumerProducts/displayTopic.do?topicId=24181>.
>  Also according to <http://www.voip-info.org/wiki/view/Asterisk+cmd+Sms>
> similar services operate in several other countries.
> 
> So, since knowing that a number is "mobile" does not provide sufficient
> information to decide whether it can receive SMS, I would say the current
> behaviour is not a bug.
>
Comment 7 Mikhail Zabaluev nokia 2009-11-30 14:58:19 UTC
I'd rather direct our thought to improving the UI design for contact cards,
rather than disabling features that somebody might find useful.
Comment 8 Jörgen Scheibengruber nokia 2009-11-30 16:29:22 UTC
This one has been discussed quite a bit internally, and there are different
opinions on it.

But basically the sms-button is always there, because we think it would be way
more annoying if it were missing for a wrongly tagged number, then it is, if it
the button present for numbers that cannot receive sms.

Also, if I am not mistaken, in most countries it is quite easy to distinguish
mobile numbers from landline numbers by looking at the number itself.
Comment 9 Andre Klapper maemo.org 2009-11-30 16:35:08 UTC
(In reply to comment #8)
> Also, if I am not mistaken, in most countries it is quite easy to distinguish
> mobile numbers from landline numbers by looking at the number itself.

In most countries it is; in Czech Republic for example it's impossible. :-)
Comment 10 clmntch (reporter) 2009-11-30 17:28:04 UTC
I wouldn't disable it, perhaps have an additional option for each number to
indicate wether it has sms capability...

Or perhaps, By default only display the SMS button for phones tagged with
"Mobile", "Mobile (home/work/foo)"... Then add additional sms buttons for other
numbers that the user explicitly sent an sms message to. 

You can explicity add a number to a sms via:
Conversations -> New SMS -> To
Select the contact(s) and the number....

At that point the any number you sent a sms to will have a button.



(In reply to comment #7)
> I'd rather direct our thought to improving the UI design for contact cards,
> rather than disabling features that somebody might find useful.
Comment 11 clmntch (reporter) 2009-11-30 17:32:25 UTC
Remember, no matter where you import your numbers from, you can still edit the
contact to change the phone number type... when I imported/synced my contacts
with google sync, I had to go and change some numbers that were tagged and
"Mobile (Work)" to "Phone (work)". I'm not sure why that happened, but it was
simple enough to correct it.

(In reply to comment #8)
> This one has been discussed quite a bit internally, and there are different
> opinions on it.
> But basically the sms-button is always there, because we think it would be way
> more annoying if it were missing for a wrongly tagged number, then it is, if it
> the button present for numbers that cannot receive sms.
> Also, if I am not mistaken, in most countries it is quite easy to distinguish
> mobile numbers from landline numbers by looking at the number itself.
Comment 12 Jörgen Scheibengruber nokia 2009-11-30 18:14:22 UTC
(In reply to comment #11)
> Remember, no matter where you import your numbers from, you can still edit the
> contact to change the phone number type... when I imported/synced my contacts
> with google sync, I had to go and change some numbers that were tagged and
> "Mobile (Work)" to "Phone (work)". I'm not sure why that happened, but it was
> simple enough to correct it.

Yes, you can, but nobody wants to do that. Maybe it is acceptable for a one or
two contacts, but not for a large set of contacts. And the risk is that import
from sim, synchronization with other phones or outlook, etc. will result in a
large set of wrongly tagged phone-numbers.

I am reopening this bug, because I agree with you, that the current behavior is
not perfect. But just changing the behavior as suggested here is not an option,
because it will for sure irritate a lot of people.

We will discuss this further internally with our UI experts, and see if we can
come up with a better solution, that will be acceptable by everyone.
Comment 13 clmntch (reporter) 2009-11-30 18:19:04 UTC
What did you think about comment #10?

(In reply to comment #12)
> (In reply to comment #11)
> > Remember, no matter where you import your numbers from, you can still edit the
> > contact to change the phone number type... when I imported/synced my contacts
> > with google sync, I had to go and change some numbers that were tagged and
> > "Mobile (Work)" to "Phone (work)". I'm not sure why that happened, but it was
> > simple enough to correct it.
> Yes, you can, but nobody wants to do that. Maybe it is acceptable for a one or
> two contacts, but not for a large set of contacts. And the risk is that import
> from sim, synchronization with other phones or outlook, etc. will result in a
> large set of wrongly tagged phone-numbers.
> I am reopening this bug, because I agree with you, that the current behavior is
> not perfect. But just changing the behavior as suggested here is not an option,
> because it will for sure irritate a lot of people.
> We will discuss this further internally with our UI experts, and see if we can
> come up with a better solution, that will be acceptable by everyone.
Comment 14 Andre Klapper maemo.org 2009-11-30 18:23:21 UTC
clmntch: Can you please strip unneeded quoting and if you quote comment below
the quoted text? Makes it easier to read. Thanks a lot in advance. :)
Comment 15 clmntch (reporter) 2009-11-30 20:06:51 UTC
(In reply to comment #14)

I'm sorry, I can do that...
Comment 16 Jeff Moe 2009-12-04 00:17:34 UTC
How about just adding a checkbox next to a number whether it is SMS-able or
not? Then just default it to checked and people can uncheck numbers that can't
receive SMSs. Probably half the numbers in my phone can't receive SMS...
Comment 17 Andre Klapper maemo.org 2009-12-08 18:50:13 UTC
*** Bug 6728 has been marked as a duplicate of this bug. ***
Comment 18 thomas 2009-12-09 16:53:31 UTC
another solution could be to make it possible to manually delete the sms field.
Comment 19 thomas 2009-12-09 16:53:59 UTC
*** This bug has been confirmed by popular vote. ***
Comment 20 Neil MacLeod maemo.org 2009-12-09 21:17:42 UTC
(In reply to comment #1)
> So it's probably a WONTFIX for convenience reasons - there's no way when
> importing those contacts from SIM cards (which is a quite common case I assume)
> for the Contacts application to realize whether it's a mobile or a landline
> number and hence it's the way it currently is.
> That's just my guess though.
> 

On Nokia phones it's possible - and has been for some time - to assign multiple
phone numbers to a contact. I've done this in my N85 - contacts have Mobile
numbers, Phone (Home), Phone (Work) etc. and I've just transferred my contacts
to the N900 over Bluetooth, it all worked perfectly.

So now I have my contacts with their various phone numbers, and of course each
phone number has a blasted SMS button even when sending an SMS to the
respective number is completely impossible.

So please, do not show SMS except for mobile phone numbers, or give the user
the option to hide the SMS button for non-mobile phone numbers.

In addition, when starting a new Conversation and selecting the "To" recipient
it shouldn't be necessary to list for me all the phone numbers assigned to a
contact when only one of the available numbers (the mobile phone number) is
capable of receiving SMS (when only one SMS capable number is available use it
by default - don't ask me). I'm having to make this choice every time I want to
send an SMS simply because somewhere in the world a land line can receive an
SMS text, what a pain! :)

These simple changes would make the overall experience that bit slicker.

I can understand that there might be issues when importing numbers from a SIM
card whereby the numbers are not correctly categorised but that should be an
issue for the "import" process or can be overcome with a simple option (treat
all numbers as SMS capable etc.) or even by the user manually re-assigning
their numbers into the correct category (mobile phone, phone work, phone home
etc.). 

And to cater for the rare occasion when a non-mobile phone will be the
recipient of an SMS it should be possible to flag specific numbers as being SMS
capable (the default being "true" for mobile and "false" for non-mobile) and
have this flag honoured by the SMS button (and the Conversation app when
filtering recipients)

(In reply to comment #2)
> 
> In the UK at least landline numbers can also accept SMS.
> 

Yes, and no doubt elsewhere in the world too but I would suggest that this is
the exception rather than the rule. It seems a shame to spam every phone number
with the SMS option when for most non-mobile numbers the SMS option is invalid.
This lack of differentation between SMS-capable and SMS-incapable numbers is
also a problem for other parts of the system, ie. Conversation.

A way to enable SMS for specific numbers would be ideal, as per the above
suggestion.
Comment 21 Josh Triplett 2009-12-10 03:51:26 UTC
I ran into this myself.  It looks rather odd to see an option to send an SMS to
my voicemail number. :)

I do understand the usability concern about not wanting to hide the SMS option
just because a phone number has no specified type.  However, it seems
reasonable to add a new type to explicitly identify POTS phones.  (No idea what
to call it; "landline" doesn't seem very friendly, nor does "non-mobile".)  Or,
alternatively, just offer an "SMS-capable" checkbox for each number, checked by
default.
Comment 22 Jeff Moe 2009-12-10 14:25:21 UTC
Or perhaps click and hold the SMS button for a couple seconds and put up a
"non-SMS number" dialog which allows you to remove SMS button.
Comment 23 Neil MacLeod maemo.org 2009-12-15 14:20:56 UTC
The thing is I have hundreds of numbers in my contacts list, all carefully
categorised Mobile/Phone(Work)/Phone(Home) etc. Assuming something to
distinguish between SMS capable and SMS incapable is ever implemented there
must be a way to quickly and efficiently apply the flag retrospectively so that
I don't have to go through two thirds of my phone numbers removing the SMS
option!

Perhaps PC Suite (once it is supported) could be used for these mass updates
assuming the SMS-capable flag can be exported and re-imported.

Alternatively, a simple "global" contacts option of "SMS-Capable -> [ Only
Mobile numbers ] / [ All numbers ]" would work, with individual overrides on a
per number basis - this would be my preference.
Comment 24 Jörgen Scheibengruber nokia 2009-12-15 14:37:41 UTC
This option is currently under discussion internally. I.e. add a option whether
or not to show a sms-option for anything but "mobile" numers. So that users can
activate that option if they they have correctly tagged set up numbers, or dont
bother to "fix" the tagging.

Not promissing that it gets implemented, just wanted to give you some feedback.
(i.e. there is *a lot of* user feedback on the N900, and we of course need to
make sure we prioritize the most critcial issues)
Comment 25 Javier S. Pedro 2009-12-18 20:06:58 UTC
Nearly _all_ landlines in Spain can receive and send short messages (at least
city ones), and 40% of my POTS contacts have the hardware to do so. Up so far
I've sent more short messages to "Phone" entries than anything else (including
Mobile).

So please offer a global or per contact checkbox, but don't try to guess
anything automatically.
Comment 26 Mathias Hasselmann maemo.org 2009-12-19 02:05:46 UTC
(In reply to comment #25)
> Nearly _all_ landlines in Spain can receive and send short messages (at least
> city ones), and 40% of my POTS contacts have the hardware to do so. Up so far
> I've sent more short messages to "Phone" entries than anything else (including
> Mobile).
> 
> So please offer a global or per contact checkbox, but don't try to guess
> anything automatically.
> 
This issue has been discussed and IF we find time to address this issue, most
likely we will offer a gobal checkbox. Everything else is too error prone, or
too risky in terms of regressions.
Comment 27 Joshua 2010-01-07 19:30:50 UTC
(In reply to comment #16)
> How about just adding a checkbox next to a number whether it is SMS-able or
> not? Then just default it to checked and people can uncheck numbers that can't
> receive SMSs. Probably half the numbers in my phone can't receive SMS...
> 

(In reply to comment #22)
> Or perhaps click and hold the SMS button for a couple seconds and put up a
> "non-SMS number" dialog which allows you to remove SMS button.
> 

This is a good idea, how do we go about getting this functionality included. A
check box or a long press to open an option would be great, do we take this
over to brainstorm now?
Comment 28 astrand 2010-01-13 12:04:36 UTC
Why not make it just one button that defaults to the current mobile number
entered, and it could have a small down-pointing arrow on the right side, and
when you press it, it acts like a drop down menu where you can select which
number to send to. Once this is done, that could be the default number to show
in the box. This way its super easy to send to somebodys default sms-number,
and still very easy to send to the same persons landline phone if you want.
Comment 29 Quim Gil nokia 2010-01-29 14:14:10 UTC
(In reply to comment #26)
> This issue has been discussed and IF we find time to address this issue, most
> likely we will offer a gobal checkbox. Everything else is too error prone, or
> too risky in terms of regressions.

This implementation is coming. Setting target milestone to 5.0+
Comment 30 Andre Klapper maemo.org 2010-03-14 20:03:17 UTC
*** Bug 9536 has been marked as a duplicate of this bug. ***
Comment 31 Andre Klapper maemo.org 2010-04-27 20:26:55 UTC
The next public update ("PR1.2") will provide a checkbox in Contacts >
Settings:
 [ ] Display SMS only for Mobile numbers

Hence closing as FIXED for PR1.2.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/