Bug 6270 (int-148002)

Summary: OK button remains disabled in dialog for Integer settings in about:config
Product: [Maemo Official Applications] Browser Reporter: Alberto Garcia Gonzalez <agarcia>
Component: User interfaceAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: browser-bugs
Severity: normal    
Priority: Low CC: andre_klapper, vdv100
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   

Description Alberto Garcia Gonzalez (reporter) 2009-11-21 17:48:43 UTC
SOFTWARE VERSION:
42-11

EXACT STEPS LEADING TO PROBLEM:
1. Open about:config in the browser
2. Find a setting with a numeric value (e.g. browser.history_expire_days)
3. Try to change it

EXPECTED OUTCOME:
The value can be changed

ACTUAL OUTCOME:
A dialog appears with a text entry, but there's no way to
alter its contents.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Other types of settigs (boolean, string) work fine.

The dialog for changing an integer is not even hildonized (as opposed
to the dialog for changing a string).
Comment 1 Andre Klapper maemo.org 2009-11-23 22:48:22 UTC
I assume we talk about settings with Type == integer here when you say
"Numeric".

I cannot reproduce this in internal 2.2009.47-18 as I can change the value
after clicking into the field, but there's definitely a bug around.

Removing the value in the "Enter integer value" dialog by using backspace makes
the OK button greyed out. Entering a new value does not enable it again.

OK button works for me when changing e.g. "0" to "02" and then removing the
"0".
This change also survives restarting the browser (have not tested rebooting the
device).

For future reference, exact titles of dialogs are welcome for searchability.
:-)
Comment 2 Alberto Garcia Gonzalez (reporter) 2009-11-24 01:31:56 UTC
(In reply to comment #1)
> I assume we talk about settings with Type == integer here when you
> say "Numeric".

Yes, of course :-)

> I cannot reproduce this in internal 2.2009.47-18 as I can change the
> value after clicking into the field, but there's definitely a bug
> around.

Good to know! With 42-11 the problem definitely happens, Valério
confirmed it too on IRC.

> For future reference, exact titles of dialogs are welcome for
> searchability.  :-)

I thought it was obvious in this case, but I'll try to give more
details in the future :)
Comment 3 Valério Valério maemo.org 2010-01-07 20:41:18 UTC
Works in 51.1.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:30:07 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.