Bug 626 (int-121102)

Summary: streaming AVI and MPG files fails over HTTPS
Product: [Maemo Official Platform] Multimedia Reporter: Ted Zlatanov <tzz>
Component: Multimedia frameworkAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: multimedia-framework-bugs
Severity: normal    
Priority: Low CC: andre_klapper, maemo, quim.gil
Version: 5.0-betaKeywords: enhancement-it2006, ITOS2007HE-garage
Target Milestone: ---   
Hardware: All   
OS: Maemo   

Description Ted Zlatanov (reporter) 2006-06-23 17:10:09 UTC
With HTTP, I can stream AVI and MPG files as usual.

With HTTPS, the streaming doesn't work.  All settings except port (443 for
HTTPS) and the protocol were the same.  The certificate has expired but
"continue" works in every other way.

I use Apache2 with a very basic configuration.
Comment 1 Maemo QA (deprecated) 2006-08-03 18:35:33 UTC
Adding streaming support over HTTPS will be handled as a feature request.
Comment 2 timeless 2007-08-27 23:45:37 UTC
reporter: a url for testing would be appreciated
Comment 4 Stefan Kost 2008-07-29 17:40:04 UTC
Ted, are you still experiencing this with OS2008? If so, do you have a url?
Comment 5 Quim Gil nokia 2008-12-08 12:01:27 UTC
Stefan's answer suggests that (if still applicable) this is more a bug than an
enhancement request.
Comment 6 Andre Klapper maemo.org 2008-12-09 18:52:41 UTC
I still need an URL for testing here -> moreinfo
Comment 7 Quim Gil nokia 2009-01-17 01:28:55 UTC
Setting HIGH visibility to see if we get a URL to test.
Comment 8 Quim Gil nokia 2009-01-21 13:17:45 UTC
(In reply to comment #0)
> The certificate has expired but "continue" works in every other way.

Maybe that was the reason of the problem.

> reporter: a url for testing would be appreciated

Requested in 2007-08-27 and yet not here. Resolving as WORKSFORME.
Comment 9 Lucas Maneos 2009-07-07 19:27:08 UTC
Reopening as it seems related to bug 3855.

Steps to reproduce:
1. Start browser.
2. Type https://home.maneos.org/maemo-bug-626/sample-hold.mp3 in the URL entry
field.
3. If you get an SSL certificate warning, accept it.
4. Select open in the file download dialog.

Expected outcome:
Playback of the audio file via HTTPS streaming.  This works as expected using
the same URL but with an http: scheme.

Actual outcome:
"File format not supported".
Comment 10 Andre Klapper maemo.org 2009-07-13 15:59:39 UTC
Confirming in latest Fremantle.
Comment 11 Andre Klapper maemo.org 2009-10-13 12:41:20 UTC
WONTFIX internally for Maemo5:

"Fixing this would break some things around (streaming at least) or requires
lots of work in Browser, browser-plugin, media player, MAFW and MMF
(authentication info need to be delivered to MMF and handled there)."
Comment 12 Lucas Maneos 2009-10-13 13:09:48 UTC
Encryption and authentication are orthogonal, and the above comment seems to
apply to bug 723 rather than this one.