Bug 6138 (int-146594)

Summary: Skype Support>Report problem leads to an error page
Product: [Maemo Official Applications] Contacts Reporter: timeless
Component: GeneralAssignee: Artem Garmash <artem.garmash>
Status: VERIFIED FIXED QA Contact: contacts-bugs
Severity: normal    
Priority: Low CC: andre_klapper, artem.garmash
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Maemo   
URL: http://support.skype.com/supportSelection

Description timeless (reporter) 2009-11-12 16:52:22 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
0. language: enus1
1. get a Skype account
2. get wifi working on your n900
3. setup your Skype account on your n900
4. connect to wifi
5. go online with presence and your Skype account
6. open Address Book (Contacts) from the application launcher
7. tap the title area
8. tap Groups
9. tap Skype
10. tap the title area
11. tap Skype support*
12. tap Report problem*

* some strings will change with the next enus1 update

EXPECTED OUTCOME:
a problem reporting page should open in the web browser

ACTUAL OUTCOME:
Browser opens and loads: http://support.skype.com/supportSelection

The main portion of that page says:
An error occurred
The application is not available at the moment, please try again later

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
enus1

NOTES: reproducible without enus1, but i'm freely writing text based on a mix
of enus/enus1.
Comment 1 Andre Klapper maemo.org 2009-11-12 17:40:26 UTC
"The application is not available at the moment, please try again later"

Why is that our problem if their webapp is not available?
It's not a 404, it's "unavailable at the moment".
Comment 2 Andre Klapper maemo.org 2009-11-12 17:54:43 UTC
https://developer.skype.com/jira/browse/MID sounds like where it should go.
Not sure though.
Comment 3 timeless (reporter) 2009-11-12 19:51:12 UTC
"Our"? It's Nokia's problem. Either they're using the wrong link, or they
forgot to remind Skype that the link needs to work because the product is live.

As a customer, I can't report a problem to Skype because the UI given by my
n900 doesn't work.

It's clear that Skype wanted this UI to exist and go somewhere useful, it's
unfortunate that it doesn't.
Comment 4 Andre Klapper maemo.org 2009-11-12 22:10:43 UTC
1. Go to http://support.skype.com/supportSednsmdvnxcvmxc
RESULT: Hi, we couldn't find this page
--> 404, link must be either fixed by Skype (redirect)
    or Nokia (change code).

2. Go to http://support.skype.com/supportSelection
RESULT: The application is not available at the moment
--> no 404. Service must be fixed by Skype (repair).
    URL in Nokia code still valid and needs no change.

(In reply to comment #3)
> "Our"? It's Nokia's problem. Either they're using the wrong link

obviously not, as explained above.

> or they forgot to remind Skype that the link needs to work because the product is live.

That's not Nokia's task, and the URL is not Nokia-specific.

This is not a bug in the Nokia code or a Nokia product by definition.
Reminds me a lot of the day when scratchbox.org was down.
Comment 5 Andre Klapper maemo.org 2009-11-12 22:16:07 UTC
CC'ing Artem.
Artem: Can you contact Skype about this to make sure that this is just a
temporary issue?
Comment 6 Artem Garmash nokia 2009-11-13 12:22:01 UTC
Thanks for the report. Looks like the link was changed and we need to update
it. The bug is valid.
Comment 7 timeless (reporter) 2009-11-13 15:25:32 UTC
Artm, it's appreciated if you update public bugs (e.g. if this is fixed, it'd
be great if you could follow andre's template for indicating to reporters
roughly when they could expect to see a fix).

It seems that the expected page is:
https://support.skype.com/support_selection
Comment 8 Andre Klapper maemo.org 2009-11-20 13:53:52 UTC
This has been fixed in package
rtcom-abook-skype-plugin 0.0.15+0m5
which is part of the internal build version
2.2009.47-17
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 9 timeless (reporter) 2010-01-14 11:47:43 UTC
51-1 it takes me to a login page, which i guess is good enough, thanks :)
Comment 10 Andre Klapper maemo.org 2010-01-14 12:28:08 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.