Bug 6107 (int-110504)

Summary: Background image settings not restored
Product: [Maemo Official Applications] Settings and Maintenance Reporter: Lucas Maneos <maemo>
Component: Backup/RestoreAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: backup-restore-bugs
Severity: minor    
Priority: Low CC: andre_klapper, anidel
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Lucas Maneos (reporter) 2009-11-10 21:13:31 UTC
SOFTWARE VERSION:
1.2009.42-11 (backup made with 1.2009.41-10)

STEPS TO REPRODUCE THE PROBLEM:
1. Use the Digital Nature theme and a custom image set as the desktop
background.
2. Make a full backup.
3. Flash updated firmware.
4. Restore backup.

EXPECTED OUTCOME:
Theme and background image settings restored.

ACTUAL OUTCOME:
Theme restored, background image set was set to the default Nokia Nseries one
(not even the restored theme's default).

REPRODUCIBILITY:
1 out of 1 attempts.

EXTRA SOFTWARE INSTALLED:
Lots before the reflash, obviously nothing after.

OTHER COMMENTS:
The background image files themselves and the corresponding .desktop file were
still intact in /home/user/MyDocs/.images, and restoring the previous
background was just a few taps away.

I'm not sure if this should be filed against home or backup, please redirect if
appropriate.
Comment 1 Andre Klapper maemo.org 2009-11-11 15:31:28 UTC
This has been fixed in package
hildon-desktop 1:2.2.104-1+0m5
which is part of the internal build version
2009.43-9
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Aniello Del Sorbo 2009-12-26 16:36:47 UTC
Sorry for the spam reopened the wrong bug. Re-closing fixed.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:26:50 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.