Bug 5993 (int-138307)

Summary: Home view blurs on triple-tapping the launcher grid icon
Product: [Maemo Official Platform] Desktop platform Reporter: mike morrison <mike_morrison>
Component: Application SwitcherAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: dashboard-bugs
Severity: normal    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description mike morrison (reporter) 2009-11-02 05:25:50 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Issue 1:
1. go to the desktop view
2. triple click the dashboard button or application menu button (whichever is
visible)


Issue 2:
1. have at least one application running
2. click on the dashboard button
3. triple click on the application menu button


EXPECTED OUTCOME:
something other than the actual outcome

ACTUAL OUTCOME:
Issue 1:
web browser is opened

Issue 2:
the screen only shows a blurred desktop background image. it appears to be at
the same blur level as seen when the application menu is shown but without any
icons visible. clicking this "blank" screen returns you to the desktop.

REPRODUCIBILITY:
always
Comment 1 Ryan Abel maemo.org 2009-11-02 06:18:43 UTC
Ha! They managed to port the Diablo application menu race bug to Fremantle.
Comment 2 Andre Klapper maemo.org 2009-11-02 14:26:17 UTC
Cannot reproduce issue 1 in 44-5.
I can reproduce issue 2. Evil. Especially to get out of that again as the only
way here seems to be Control+Backspace.
Comment 3 Andre Klapper maemo.org 2009-11-03 14:05:34 UTC
So, issue one is int-130962.
Issue two is int-138307.

As always: Please file only one issue per bug, otherwise it's impossible to
properly handle...

Thinking that issue two is more evil I'm going to handle only that one here.
Comment 4 Andre Klapper maemo.org 2009-11-19 14:03:38 UTC
This has been fixed in package
hildon-desktop 1:2.2.120-1+0m5
which is part of the internal build version
2.2009.47-17
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:57 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.