Bug 5948 (int-143314)

Summary: N900 needs to be rebooted if media player fails to play video (h264dec)
Product: [Maemo Official Platform] Multimedia Reporter: kevin van <kevin>
Component: Multimedia frameworkAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: multimedia-framework-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, archebyte, eero.tamminen, felipe.contreras, ferd352+maemo.org, lucasara, martin, musoutensei, nils.faerber
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   
Attachments: error
6 sec video from the N900

Description kevin van (reporter) 2009-10-30 23:08:56 UTC
SOFTWARE VERSION:  2.2009.42-9


If video playback fails, the N900 needs to be rebooted to restore maemo media
player video playback functionality.


STEPS TO REPRODUCE THE PROBLEM:



1. Take an iphone spec sized video file and copy the video to the N900 video
folder (480 x 270 H264 video file).  [I would attach such a video file here but
you have no attachments for your bug database - please contact:
kevin@elgato.com for such a video - or you can easily create one by using
QuickTime export to iPhone format)


2. On the N900, go to Media player -> Video.  Locate video file and try to
playback.


3. Playback fails... you get the message "Unsupported file format". Cancel
error message.

4. Go back to the video file list and attempt to playback a file that you know
works, say the video that is pre-installed on the N900, the video called "Nokia
N900" or the "9" video.


EXPECTED OUTCOME:

Plays back video.  The maemo player should gracefully handle video file it can
not playback.  It should give a warning, and then you should be able to
playback a video that is know to work.  You should not have to reboot the Nokia
N900 to restore maemo video playback functionality.

ACTUAL OUTCOME:

Player comes up, but all you see is a black screen with the video controls.  If
you try to press the "Play" button, nothing happens.  If you try to hit the
arrow keys or seek in the video, nothing happens.  The workaround is to reboot
the N900 phone.  Then upon reboot, go to Videos section and playback the video
that you know works on the phone, namely the "9" or ""Nokia N900" video.

REPRODUCIBILITY:
(always)


----------------------we submitted this bug in the Nokia bug database with this
response:



-------- 2009-10-30 06:17:00.0 GMT Balakrishna -------- 
Dear Developer,
   Thank you for submitting this issue, it has been placed in a queue for
further investigations. Please be aware that this is a channel solely for the
purpose of reporting S60 software issues and requesting technical feedback for
the issues is not recommended. Any solutions or workarounds identified will be
published  in Forum Nokia’s Technical Library without prior notification.

Kind Regards,
Forum Nokia – Professional Support

-------- 2009-10-30 08:44:00.0 GMT Balakrishna -------- 
Hi Adam,

Unfortunately, we cannot process this entry any further as we currently accept
only Symbian related bugs on this channel. We suggest you to report this bug at
Maemo Bugzilla(https://bugs.maemo.org/).

As there is nothing more that can be done from our side, this bug report will
be closed shortly.

Best regards,
Forum Nokia Professional Support.


-------------------------------------------------------------------------------
Comment 1 Andre Klapper maemo.org 2009-10-31 16:40:51 UTC
Hi & thanks for reporting!
You can create attachments here (see "Create a New Attachment" link), but only
up to 2500KB. So either feel free to attach a small example video here, or to
send it to my email address. :-)
Comment 2 mustali 2009-11-10 02:16:12 UTC
having the same problem here. can't play the videos taken from the N900 camera.

get the following error (screenshot attached):
Unable to play media. 
Media format not supported.

I am attaching the 10sec video that I took with the N900 just before writing
this. the media player gives the same error when trying to play the video.
thumbnail is not displayed either.
Comment 3 mustali 2009-11-10 02:16:40 UTC
Created an attachment (id=1570) [details]
error
Comment 4 mustali 2009-11-10 02:20:01 UTC
Created an attachment (id=1571) [details]
6 sec video from the N900
Comment 5 mustali 2009-11-10 02:26:01 UTC
rebooting fixed the problem. thumbnails are displayed in the media-player too.
Comment 6 Andre Klapper maemo.org 2009-11-11 21:11:47 UTC
Thanks for reporting this.

Confirming. This is an issue with h264dec encoded videos.

This has been fixed in the internal build version
2009.45-7 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:26:52 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 lucasara 2010-01-14 14:39:10 UTC
I still get this in 2.2009.51-1.

I have a mp4 file that won't play (avc + aac), if I try to play it I get "media
format not supported".

If I try to open any other compatible video file after that one, the controls
open but nothing is played and play button is unresponsive. If I try to play an
internet radio station or any mp3, a message saying "media format not
supported" appears.

Reboot fixes it until I try to open the unsupported video...
Comment 9 Taomyn 2010-01-15 12:47:03 UTC
I'm also experiencing this with the latest update - I had some video clips from
my old Samsung i8190 many of which would not play, although one of them would
strangely. Attempting to playing them would cause any other video to either
fail with "Unknown format" (even video recorded on the phone) or sit in a blank
screen loop. Reboot required to fix.
Comment 10 Alex 2010-01-15 17:22:26 UTC
I've run into this on PR1.1 in trying to do some troubleshooting for this TMO
thread: http://talk.maemo.org/showthread.php?p=474257

Possibly related/bigger issue?
Comment 11 Andre Klapper maemo.org 2010-01-18 20:13:27 UTC
(In reply to comment #10)
> I've run into this on PR1.1

I think that's bug 6823 which is still valid in 2.2009.51-1.
Comment 12 darkjoker 2010-02-08 03:04:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Eero Tamminen nokia 2010-02-22 12:48:07 UTC
(In reply to comment #11)
> > I've run into this on PR1.1
> 
> I think that's bug 6823 which is still valid in 2.2009.51-1.

Hm.  Maybe this bug should depend from that?
Comment 14 Nils Faerber 2010-03-15 00:18:06 UTC
I can confirm this bug, still valid in 2.2009.51-1 and also happens sometimes
when playing DivX or XVID in formats that the N900 does not 100% support.
Sometimes stopping playback soon enough helps to keep the subsystem playing,
sometimes a reboot is necessary.