Bug 5917 (int-138218)

Summary: Not possible to answer incoming call with wired headset buttons.
Product: [Maemo Official Platform] Core Reporter: Lucas Maneos <maemo>
Component: generalAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: core-general-bugs
Severity: major    
Priority: Medium CC: andre_klapper, guillaume.desmottes, lassi.syrjala, mikhail.zabaluev, vkboard
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Lucas Maneos (reporter) 2009-10-30 11:28:36 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Plug WH-205 headset into N900.
2. Receive incoming call.
3. Try pressing any of the headset's buttons to accept the call.

EXPECTED OUTCOME:
Call answered.

ACTUAL OUTCOME:
Nothing, the call keeps ringing until answered/rejected via the touchscreen or
the caller hangs up.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Bug 1553 is somewhat related, but not a duplicate.  See bug 1553 comment 17 in
particular about the WH-205 being shown as a headphone instead of a headset.

The same steps with an N810 and the same headset work as expected.
Comment 1 Mikhail Zabaluev nokia 2009-10-30 11:37:34 UTC
This is basically a feature gap. Vote for it.
Comment 2 Lassi Syrjälä nokia 2009-10-30 11:49:17 UTC
(In reply to comment #1)
> This is basically a feature gap. Vote for it.

It's actually a bug affecting VoIP (but not cellular) calls. We are saving
power when we shouldn't be.
Comment 3 Lucas Maneos (reporter) 2010-01-07 05:11:32 UTC
*** Bug 7725 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-01-07 12:39:17 UTC
(Updating severity & priority as this is considered a bug.)
Comment 5 vkboard 2010-02-19 20:00:02 UTC
not sure if I should add a new bug report or if this is related?
volume control with a wired headset is also not possilbe:
http://talk.maemo.org/showthread.php?t=45026

and for me not being able to take calls affects both internet and regular calls
Comment 6 Andre Klapper maemo.org 2010-03-26 14:25:05 UTC
This has been fixed in the internal build version
10.2010.08-5
(Note: 2009/2010 is the year, and the number after is the week.)

The next public update will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/