Bug 5894 (int-145904)

Summary: Play track button doesn't work
Product: [Maemo Official Applications] Desktop Widgets Reporter: Uwe Kaminski <jukey>
Component: Media playerAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: mediaplayer-applet-bugs
Severity: normal    
Priority: Low CC: aaron_baker65, adlorenz, ajamils, andre_klapper, anidel, cjokoye, cstraetz, dominikowski, emanuele.cassioli, felbutss, jukey, loufoque, maemo, mece, musoutensei, n900nseries, pierre.abadie, radusebastian_capitanu, svisvanatha, thezogg, tim, trippin1, twaelti, vadimpelau
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Uwe Kaminski (reporter) 2009-10-29 14:06:04 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. Place the media player widget on a desktop using the "add widget" function
which is available if you tap to the gearwheel in the upper right corner of the
bar on top of the desktop(s).
2. start the media player
3. start to play a song
4. switch back to desktop -> you will see the title of the song in the desktop
widget and you also can see a little "equalizer"-icon
5. press the pause button in the widget. -> sound is stopping
6. press the play or next track or previous track button

EXPECTED OUTCOME:
music will play or next track will be played or previous track will be played

ACTUAL OUTCOME:
nothing happens. The same happens if the media player is not already running.

REPRODUCIBILITY:
always
Comment 1 Tim Samoff maemo.org 2009-10-29 19:31:30 UTC
This WORKSFORME, although it appears that the "back" and "forward" buttons only
work for songs within a single playlist of music (i.e., if a playlist only has
one song, pressing the buttons will only restart the same song). Imho, these
buttons should advance music through the entire library and not just single
playlists.

On a slightly unrelated note: The buttons on the widget are VERY hard to press
and sometimes need multiple presses to work.
Comment 2 Andre Klapper maemo.org 2009-10-30 18:52:06 UTC
This also works fine for me here in 44-5.
Comment 3 Tim Samoff maemo.org 2009-10-30 19:01:48 UTC
Well "works fine" is subjective in this case. While you can navigate through
tracks within a single playlist, you cannot navigate from playlist to playlist.
There may be a bug in that.
Comment 4 Andre Klapper maemo.org 2009-10-30 19:07:23 UTC
Uhm, this was about ignoring the playlist you're in?
If so, please feel free to rephrase the summary and reopen.
Comment 5 Uwe Kaminski (reporter) 2009-10-30 19:30:34 UTC
Thanks for your comments. After trying again I was able to jump to the
next/previous song in the playlist. Good. I think this:
> Well "works fine" is subjective in this case. While you can navigate through
> tracks within a single playlist, you cannot navigate from playlist to playlist.
> There may be a bug in that.
should be a separate bug report because there is still one issue left:

I am not able to use the Play button of the widget. Never. Again: The pause
button works fine and the next button let me jump to the next song but I'm
unable to make it play using the widget button.
Comment 6 Tim Samoff maemo.org 2009-10-30 19:37:43 UTC
This WORKSFORME. Are you sure a valid, playable file is selected in the Widget?

Actually, my comments seem like they ARE valid. How is a person to switch to a
new song using the widget if there is only one song available in the playlist.
They have to open the Media player, select a new song in a new playlist, close
the Media player and then what? The widget is still unusable.

Maybe a "different" bug, but definitely highly related.
Comment 7 Uwe Kaminski (reporter) 2009-10-30 19:42:32 UTC
(In reply to comment #6)
> This WORKSFORME. Are you sure a valid, playable file is selected in the Widget?

Yes. And I'm also able to play it in the mediaplayer if I use the play Button
inside the media player. But not via the widget. :-/

Do you have an idea what kind of information I should provide to solve this
issue?
Comment 8 Tim Samoff maemo.org 2009-10-30 19:49:29 UTC
Not sure, but... Have you tried removing the widget from your desktop and
re-adding it? Simple -- and shouldn't make a difference -- but worth a try.
Comment 9 Uwe Kaminski (reporter) 2009-10-31 18:42:52 UTC
(In reply to comment #8)
> Not sure, but... Have you tried removing the widget from your desktop and
> re-adding it? Simple -- and shouldn't make a difference -- but worth a try.

Thanks for this idea! In this way it worked for me. After removing and re-addng
the widget I am able to use the play button in it's intended way. :)
Comment 10 Tim Samoff maemo.org 2009-10-31 20:17:09 UTC
Hmmm... There's definitely a bug in this, though. Lets see if we can recreate
it somehow.
Comment 11 Uwe Kaminski (reporter) 2009-11-07 10:54:05 UTC
This happens again for me but still not everytime. At the moment I can't findc
out was is the real reason for the applet to stop it's work.

The workaround: remove applet from desktop and enable it again works fine.
Comment 12 Andre Klapper maemo.org 2009-11-10 15:29:36 UTC
As neither Nokians nor me are able to see this problem in current internal
builds (that you unfortunately cannot access, sigh), this definitely needs
retesting when the final version is out, otherwise this ends up as
"nonreproducible WORKSFORME", which would be a pity...
Comment 13 Uwe Kaminski (reporter) 2009-11-10 17:14:09 UTC
I think now I can reproduce this bug:
0. remove the media player widget from desktop and place it again onto the
desktop (so it's reset)
1. start the media player
2. start to play an audio file in the player
3. go back to the media players home screen (4 icons: audio, video,
internetradio, shuffle)
4. go to video section
5. start to play a video
6. pause the video
7. close the media player
8. go to the media player desktop widget and press play

EXPECTED OUTCOME:
music will play

ACTUAL OUTCOME:
nothing happens.

What is possible: Tip onto the cover art opens the media player.
Comment 14 Andre Klapper maemo.org 2009-11-10 22:50:10 UTC
(In reply to comment #13)
> 7. close the media player

I tried this in 46-5 both by using Control+Backspace to go to the application
switcher and clicking the X in the small "screenshot" of the application, and
by using the "back" icon in the right upper corner twice to be able to close
the video player.

In both cases the music started to play when using the Desktop widget.
I tend to believe that this issue has been fixed in the meantime.
Comment 15 Sanjeev Visvanatha 2009-11-12 14:57:17 UTC
I am using 1.2009.41-10, and can confirm Uwe's problem (comment #13 to be
specific).  removing the desktop widget and re-adding it solves the problem. 
The pause button works, but not the play button.
Comment 16 Uwe Kaminski (reporter) 2009-11-17 12:58:29 UTC
Can't reproduce this bug in 1.2009.42-11 so I assume it's fixed. :-)
Comment 17 Alex 2009-11-24 20:54:45 UTC
This issue is still present in 1.2009.42-11. I removed/re-added the widget,
seemed to fix the problem. Issue came back later after these steps:

- Paused music (from the music player)
- Went to Youtube and played a video
- Closed out the youtube window and went back to desktop
- Pressed play on the widget, nothing happened (skip forwards backwards still
work)

In this case when the issue came back I experienced the same issue in the media
player itself (all controls seemed responsive except play). After a few moments
the track began playing. I then tried pause/play from the widget and it is
still working (without removing/re-adding again).
Comment 18 pierre.abadie 2009-11-30 12:33:40 UTC
Samr bug here, only previous, next and pause work. "play" works sometimes but
not always
Comment 19 Andre Klapper maemo.org 2009-11-30 13:45:06 UTC
As written, I think that this has been fixed in the meantime internally.
--> moreinfo in order to test this again after a public update has been made
available.
Comment 20 Andre Klapper maemo.org 2009-12-07 12:12:38 UTC
*** Bug 6653 has been marked as a duplicate of this bug. ***
Comment 21 Andre Klapper maemo.org 2009-12-08 19:42:02 UTC
*** Bug 6690 has been marked as a duplicate of this bug. ***
Comment 22 Tom Waelti 2009-12-10 09:52:47 UTC
I'v encountered the bug at least twice, too. However, I can not reproduce it as
"always". But it's there.
Comment 23 EC 2009-12-20 15:27:22 UTC
I cannot understand how to reproduce this, but i've encountered it three times
and i just don't want to close and reopen the widget every time, it's so
frustrating and annoying! I've a 42-11, i hope it will be fixed soon
Comment 24 Aniello Del Sorbo 2009-12-24 11:46:40 UTC
I tried to reproduce this in the community-testing firmware release 2.2009.51-1
and I could not reproduce it.

I have tried several time this morning with several combinations of
adding/removing and pausing/playing from the media player or the widget and it
always worked fine

Only thing I noticed is that is I add the widget while playing a song that has
a cover in the media player, this cover does not appear in the newly added
widget until you go to next song and back.

I will keep an eye on this, though.
Andre I will leave to you the call to close or leave it open :)
Comment 25 Aaron B 2009-12-26 13:01:41 UTC
I have this problem also. Just an end user here without any of your builds.
Media player widget play button does not work. I'm trying your remove and then
re add widget to desktop right now and what happens is after re-adding the
widget and pressing play button on widget i see it flicking through the title
of every song i have on the phone appearing on the widget as though it is
re-indexing. Now it stopped and i tried pressing play and it did the same thing
again. Pause button does not appear. Removing widget again and readding it. Now
when i go to media player app it says i have no songs on the phone whether i
press music button or shuffle all songs. Exiting app and trying widget. Widget
is doing same odd behavior flicking the title of every track i have. Removing
widget again. Going to media app, app says i have no songs. oops plugged into
usb cable to computer maybe that's the problem. Ok app sees my music now.
Re-adding widget, widget is working now. Thanks
Comment 26 Tim Samoff maemo.org 2009-12-26 16:32:10 UTC
(In reply to comment #25)
> I have this problem also. Just an end user here without any of your builds.
> 

Thanks, Aaron. Please always provide the OS version from Settings -> About
product, as well as the exact steps that produced what you are experiencing.
Comment 27 Andre Klapper maemo.org 2009-12-30 14:28:54 UTC
*** Bug 7479 has been marked as a duplicate of this bug. ***
Comment 28 Andre Klapper maemo.org 2009-12-30 20:41:21 UTC
Internal comment: "There's been made several fixes to home applet for
concerning this kind of problems for PR1.1."

Those community testers that have access to PR1.1: Have you seen this issue
again?
Comment 29 Aniello Del Sorbo 2009-12-31 15:53:41 UTC
Andre, yesterday I was using my N900 in the car , I didn't reproduce it yet as
I don't remember exactly the steps I took, but for sure I did this:
. paired the n900 with the car's bluetooth system
. launched Media Player and played some tracks
. every now and then I used the prev/next/volume buttons of the bluetooth
system to skip tracks/adjust volume
. twice I went out of the car
. last time I entered the car Media Player was not running (I closed it during
a dinner) and I tried using the widget

Outcome: next/prev worked fine, but play didn't play and I had to run Media
Player to be able to play musinc
Comment 30 Andre Klapper maemo.org 2010-01-04 12:59:13 UTC
I think the main issue is fixed in 2.2009.51-1 (PR1.1) here, but looks like
there is another way to trigger this.
Anidel, if you find time it would be cool to investigate...
Comment 31 Tomasz Dominikowski 2010-01-11 13:27:29 UTC
The Media Player widget Play button didn't work for me at all in PR1.1. Don't
know what triggers it. I removed the widget, added it back, rebooted, it works
now.
Comment 32 Uwe Kaminski (reporter) 2010-01-11 14:08:28 UTC
We need a better way to get a reason if this does not work.

One problem could be a database rebuild of tracker. An other reason could be a
mevoed or deleted file. 

The applet _should_ return an error message like the media player itself does.
Comment 33 Marcus Wikström 2010-01-11 16:18:39 UTC
I can confirm this bug, with 1.2009.44-1, but I can't reproduce it with the
methods listed. This bug seems to appear "every now and then". When it has
happened. everything works on the widget except the play button. you can pause
music you've started with the media player, but once you've paused it, you
can't start it again with the widget.
Comment 34 Pelau Vadim 2010-01-11 16:23:31 UTC
(In reply to comment #33)

Same here, I have to reset the widget at least once a day.
So far I haven't been able yo reproduce the exact cause.

Maybe an automatic reset/"refresh", that occurs each time that particular
desktop is accessed, could be a temporary fix?
Comment 35 Andre Klapper maemo.org 2010-01-11 17:35:39 UTC
------- Comment #31 from trippin1  2010-01-09 13:10 GMT+3 -------
I am seeing this issue in PR 1.1, yes.
Comment 36 Andre Klapper maemo.org 2010-01-11 18:20:34 UTC
According to internal comments several fixes have gone into the applet for
PR1.2 (to avoid confusion: Today's PR1.0.1 release is 1.2009.44-1, the next
release will be PR1.1 and probably 1.2009.51, the release after is PR1.2).
Comment 37 Andre Klapper maemo.org 2010-01-14 12:32:45 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 38 EC 2010-01-14 12:58:40 UTC
It seems it has been fixed with PR1.1, I can't reproduce this bug anymore.
Maybe it will come with time, or maybe it has been really fixed, I think we
have to wait some days.
Comment 39 taril 2010-01-14 14:18:24 UTC
It does not work with PR1.1 too.
Comment 40 EC 2010-01-14 15:33:50 UTC
(In reply to comment #39)
> It does not work with PR1.1 too.
> 

How did you manage to reproduce it? I've been using the widget for hours and it
has been working well until now.
Comment 41 taril 2010-01-14 15:42:26 UTC
(In reply to comment #40)
> (In reply to comment #39)
> > It does not work with PR1.1 too.
> > 
> 
> How did you manage to reproduce it? I've been using the widget for hours and it
> has been working well until now. 
> 

Ive updated my N900, restored everything with BACKUP application, and does not
work simply like before. The PLAY button does not work. I can step tracks, but
cant play them with this widget.

Where can I find the Media Player's music/video database file?
Comment 42 EC 2010-01-14 16:35:55 UTC
Have you already tried to remove the widget from your desktop and re-add it? I
have done my firmware upgrade OTA, so I haven't used any Backup Restore, but I
don't think it actually influence the widget.
Comment 43 Pelau Vadim 2010-01-14 16:41:37 UTC
PR 1.1 Managed to reproduce the bug - ONLY ONCE.

-started music player, clicked shuffle all tracks, created playlist.
-returned to desktop with the player in the background and paused the play in
the widget.
-the play button wouldn't work.

Now the interesting part comes in:
- I removed the mediaplayer widget to reset it,
- all the desktops got reset, the icons and bookmarks came back by themselves
but the widgets had to be placed again - each returned to it's previous
position.

And now the nice part:
- I can't reproduce any of the the issues at all
- I think it might have been caused by stressing the widget while the
mediaplayer was still indexing the tracks.

Apparently reseting the widget when a large amount of tracks are added could be
necessary.
Comment 44 taril 2010-01-14 16:58:09 UTC
(In reply to comment #42)
> Have you already tried to remove the widget from your desktop and re-add it? I
> have done my firmware upgrade OTA, so I haven't used any Backup Restore, but I
> don't think it actually influence the widget.
> 

I removed it, readd it, it worked, but lost all the other things on desktop.  I
readd the items again to the desktop. Play button does not work like before.
Comment 45 Sanjeev Visvanatha 2010-01-15 03:15:47 UTC
I updated via OTA to 2.2009.51-1.
This problem still persists.
Removing and reinstalling widget on desktop has fixed the problem (for now).
Is there any troubleshooting steps that I could perform to narrow the problem
down?
Comment 46 Andre Klapper maemo.org 2010-01-15 14:11:15 UTC
Okay, as it's not working in 2.2009.51-1, this will be in a future update then.
Comment 47 Pelau Vadim 2010-01-15 14:24:23 UTC
(In reply to comment #43)
> PR 1.1 Managed to reproduce the bug - ONLY ONCE.
> 
> -started music player, clicked shuffle all tracks, created playlist.
> -returned to desktop with the player in the background and paused the play in
> the widget.
> -the play button wouldn't work.
> 
> Now the interesting part comes in:
> - I removed the mediaplayer widget to reset it,
> - all the desktops got reset, the icons and bookmarks came back by themselves
> but the widgets had to be placed again - each returned to it's previous
> position.
> 
> And now the nice part:
> - I can't reproduce any of the the issues at all
> - I think it might have been caused by stressing the widget while the
> mediaplayer was still indexing the tracks.
> 
> Apparently reseting the widget when a large amount of tracks are added could be
> necessary.
> 

It does work, the widget simply needs to be "reset" once, this being a worst
case scenario.

I reflashed last night and it was impossible to reproduce the issue.
If you have a large number of tracks just be sure they're indexed righ - the
widget works fine.
Comment 48 taril 2010-01-17 11:49:09 UTC
(In reply to comment #47)
> (In reply to comment #43)
> > PR 1.1 Managed to reproduce the bug - ONLY ONCE.
> > 
> > -started music player, clicked shuffle all tracks, created playlist.
> > -returned to desktop with the player in the background and paused the play in
> > the widget.
> > -the play button wouldn't work.
> > 
> > Now the interesting part comes in:
> > - I removed the mediaplayer widget to reset it,
> > - all the desktops got reset, the icons and bookmarks came back by themselves
> > but the widgets had to be placed again - each returned to it's previous
> > position.
> > 
> > And now the nice part:
> > - I can't reproduce any of the the issues at all
> > - I think it might have been caused by stressing the widget while the
> > mediaplayer was still indexing the tracks.
> > 
> > Apparently reseting the widget when a large amount of tracks are added could be
> > necessary.
> > 
> 
> It does work, the widget simply needs to be "reset" once, this being a worst
> case scenario.
> 
> I reflashed last night and it was impossible to reproduce the issue.
> If you have a large number of tracks just be sure they're indexed righ - the
> widget works fine.
> 

It does not work after simply reset. Not the user has to be sure about
indexing, so youre totally wrong.
Comment 49 Pelau Vadim 2010-01-18 13:31:18 UTC
> 
> It does not work after simply reset. Not the user has to be sure about
> indexing, so youre totally wrong.
> 

Ok, tried it right now and it doesn't work. However reproducing the bug is much
more difficult and random than the previous firmware...

This bug should be reopened.
Comment 50 Andre Klapper maemo.org 2010-01-18 13:52:40 UTC
(In reply to comment #49)
> This bug should be reopened.

No, it should not. Read
https://bugs.maemo.org/page.cgi?id=fields.html#resolution first.
Comment 51 Andre Klapper maemo.org 2010-01-25 13:15:33 UTC
Reopening.
Comment 52 Pelau Vadim 2010-01-25 13:23:25 UTC
But shouldn't the fix already be scheduled for the next fw?

Or was it fixed in PR 1.1 and it reoccurs due to another etiology?
Comment 53 Andre Klapper maemo.org 2010-01-25 15:29:37 UTC
(In reply to comment #52)
> But shouldn't the fix already be scheduled for the next fw?
> 
> Or was it fixed in PR 1.1 and it reoccurs due to another etiology?

As I reopened it, it is not fixed at all.
Also see https://bugs.maemo.org/page.cgi?id=fields.html#resolution
Comment 54 Andre Klapper maemo.org 2010-01-28 04:16:36 UTC
This works fine now in version 2010.02-5, however it's seen that when "Touch
search" desktop widget (3rd party software) is in the desktop, the Play button
does not work after startup.
I've asked the Nokians to file a report here against TouchSearch.
Comment 55 Radu Capitanu 2010-02-06 18:28:18 UTC
(In reply to comment #54)
Version 2010.02-5?! Lucky you! And when we can test this?
Comment 56 Dave Holden 2010-02-09 15:09:45 UTC
(In reply to comment #54)
> This works fine now in version 2010.02-5, however it's seen that when "Touch
> search" desktop widget (3rd party software) is in the desktop, the Play button
> does not work after startup.
> I've asked the Nokians to file a report here against TouchSearch.
> 

I'm using version 2.2009.51-1.203.2 and have been having this same issue with
the play button on the widget.

Removing TouchSearch (v2.1) from the desktop appears to solve the problem. I'll
create a bug report with TouchSearch.
Comment 57 Arsalan 2010-02-10 21:19:31 UTC
This bug is not fixed and it should be reopened because I encounter the same
issue every other day. The only way to fix it is to remove the widget and add i
back and then everything works. I do not have TouchSearch installed so I'm sure
is something else that is causing that issue.
Comment 58 jason chahine 2010-02-11 01:54:34 UTC
i can confirm. this bug is not fixed. after removing touch search i did a week
of use from the widget but now its stopped again. ddaammm it
Comment 59 Andre Klapper maemo.org 2010-02-11 12:12:39 UTC
Arsalan, jason chahine: Please read bug reports before commenting, in this case
comment 46, comment 50, comment 53, plus avoid "me too" comments. Thanks.
Comment 60 Andre Klapper maemo.org 2010-02-11 16:53:34 UTC
*** Bug 8881 has been marked as a duplicate of this bug. ***
Comment 61 taril 2010-02-16 23:33:11 UTC
I have ***3.2010.02-08***, this bug is still existed.
Comment 62 Aniello Del Sorbo 2010-02-17 00:30:41 UTC
I also can confirm this bug still exists in latest release of firmware
(3.2010.02-8).
Reopening.
Comment 63 Pelau Vadim 2010-02-17 00:34:36 UTC
Confirmed, it's worse than before, this time it did't work out of the box!

Tested on a freshly emmc vanilla + PR 1.1.1 3.2010.02.08. Started music player,
went to desktop, paused via the widget => plyback wouldn't start.

I don't understand why you guys report fixes in firmwares not available to the
wide audience? This bug used to have 40-50 votes if my memory serves me well
and now it only has 14.

Just let the fix be reported by users and stop marking bugs as resolved before
the actual firmware comes out, this is an outrage!
Comment 64 Andre Klapper maemo.org 2010-02-17 01:11:57 UTC
Guys, please stop reopening reports and read
https://bugs.maemo.org/page.cgi?id=fields.html#resolution .
Nobody has ever stated that this is fixed in 3.2010.02-8 (PR1.1.1).
It will be fixed in PR1.2.
Comment 65 Andre Klapper maemo.org 2010-02-17 01:34:06 UTC
(In reply to comment #63)
> stop marking bugs as resolved before the actual firmware comes out

I've filed bug 9090 about this.
Constructive proposals are welcome in that report.
Comment 66 Andre Klapper maemo.org 2010-03-15 20:53:57 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 67 Misha K. 2010-05-26 09:22:51 UTC
not fixed in PR1.2 Middle East version. still not working
Comment 68 Arsalan 2010-05-26 15:47:36 UTC
This is total BS. This issue is not fixed in US version of PR1.2 either. I just
updated my N900 and the media widget still doesn't work and when I removed it
and added it again.. my widgets for OMWeather, Recaller, Bluzwitch and
SimpleFMTx disappeared and I had to add them back again as well.
Comment 69 Misha K. 2010-05-26 15:54:11 UTC
(In reply to comment #68)
> This is total BS. This issue is not fixed in US version of PR1.2 either. I just
> updated my N900 and the media widget still doesn't work and when I removed it
> and added it again.. my widgets for OMWeather, Recaller, Bluzwitch and
> SimpleFMTx disappeared and I had to add them back again as well. 
> 
Try to delete recall widget, it helped me, but still it's not a solution, the
bug still exists
Comment 70 taril 2010-05-26 20:07:50 UTC
Of course this bug exists in PR 1.2. What a surprise.
Comment 71 Pelau Vadim 2010-05-26 22:02:38 UTC
Not in the US version. I flashed PR1.2 then eMMC and then PR1.2 again(had a
feeling the phone started to boot after the first flash).

 I'm yet unable to replicate the bug.

Tried:
start player, background. Pause play worked with no issues.
start music from widget. Pause play worked with no issues.
Rebooted and repeated the above.
Repeated the process after fiddling around with touch search.

The only widgets on the desktop with the music player widget are the lyrics one
and FM transmitter since that's my multimedia desktop.

If you guys still have the bug please describe the steps to get it.
Comment 72 Dawid Lorenz 2010-05-26 22:36:57 UTC
In my case, after upgrading to PR1.2 media player widget initially didn't work
(ie. play button didn't respond). To make it work I've had to remove and add to
desktop again.

This widget has pretty dodgy behaviour ever since N900 has hit the shelves...
Comment 73 Andre Klapper maemo.org 2010-05-27 00:04:28 UTC
(In reply to comment #68)
> This is total BS.

(In reply to comment #70)
> Of course this bug exists in PR 1.2. What a surprise.

Please check your tone or go to talk.maemo.org otherwise in case of frustration
as it does not add any technical value to this report.
Yes, software development is sometimes a bit complicated, especially when there
might be 3rd party apps involved that *might* trigger this bug, outside of
Nokia's area where another issue with similar outcome *might* be fixed.
I like to keep the tone in Bugzilla respectful.
Thanks.
Comment 74 Faheem Pervez maemo.org 2010-05-27 01:03:59 UTC
Anyone happen to know how to mount an UBIFS image under Linux? With the media
player applet included in the leaked image, I only saw this problem three times
max and it always fixed itself. In the final update? Well...
Comment 75 Misha K. 2010-05-27 06:53:19 UTC
(In reply to comment #71)
> Not in the US version. I flashed PR1.2 then eMMC and then PR1.2 again(had a
> feeling the phone started to boot after the first flash).
> 
>  I'm yet unable to replicate the bug.
> 
> Tried:
> start player, background. Pause play worked with no issues.
> start music from widget. Pause play worked with no issues.
> Rebooted and repeated the above.
> Repeated the process after fiddling around with touch search.
> 
> The only widgets on the desktop with the music player widget are the lyrics one
> and FM transmitter since that's my multimedia desktop.
> 
> If you guys still have the bug please describe the steps to get it.
> 


Add Conversation widget and recall widget, set default theme and reboot after
that. try it.
Comment 76 Pelau Vadim 2010-05-27 08:16:27 UTC
(In reply to comment #75)
> (In reply to comment #71)
> > Not in the US version. I flashed PR1.2 then eMMC and then PR1.2 again(had a
> > feeling the phone started to boot after the first flash).
> > 
> >  I'm yet unable to replicate the bug.
> > 
> > Tried:
> > start player, background. Pause play worked with no issues.
> > start music from widget. Pause play worked with no issues.
> > Rebooted and repeated the above.
> > Repeated the process after fiddling around with touch search.
> > 
> > The only widgets on the desktop with the music player widget are the lyrics one
> > and FM transmitter since that's my multimedia desktop.
> > 
> > If you guys still have the bug please describe the steps to get it.
> > 
> 
> 
> Add Conversation widget and recall widget, set default theme and reboot after
> that. try it.
> 

Ok, added it and repeated the tests and it still works. I will keep the widgets
for today and see what happens.
Comment 77 Dawid Lorenz 2010-05-27 10:49:47 UTC
Today in the morning, without doing anything in particular before, Play button
on widget stopped responding. This time I've had to launch "big" media player,
start playback, close it and then I could use widget properly. 

Note that yesterday I was listening music using that widget with no problem. It
stopped responding with no apparent reason.
Comment 78 Dawid Lorenz 2010-05-27 11:04:49 UTC
(In reply to comment #77)
> Note that yesterday I was listening music using that widget with no problem. It
> stopped responding with no apparent reason.

OK, my bad. There was something possibly related happening yesterday - few
desktop widgets got upgraded from app manager, these were conversations inbox
widget, personal ip address and personal data monitor.
Comment 79 Misha K. 2010-05-27 11:57:21 UTC
(In reply to comment #76)
> (In reply to comment #75)
> > (In reply to comment #71)
> > > Not in the US version. I flashed PR1.2 then eMMC and then PR1.2 again(had a
> > > feeling the phone started to boot after the first flash).
> > > 
> > >  I'm yet unable to replicate the bug.
> > > 
> > > Tried:
> > > start player, background. Pause play worked with no issues.
> > > start music from widget. Pause play worked with no issues.
> > > Rebooted and repeated the above.
> > > Repeated the process after fiddling around with touch search.
> > > 
> > > The only widgets on the desktop with the music player widget are the lyrics one
> > > and FM transmitter since that's my multimedia desktop.
> > > 
> > > If you guys still have the bug please describe the steps to get it.
> > > 
> > 
> > 
> > Add Conversation widget and recall widget, set default theme and reboot after
> > that. try it.
> > 
> 
> Ok, added it and repeated the tests and it still works. I will keep the widgets
> for today and see what happens.
> 

you don't believe me, i'll videotape it. would try to to do it today
Comment 80 Tomasz Dominikowski 2010-05-27 12:11:11 UTC
Let me just state here that my decoders-support package has definitely nothing
to do with this, someone alleged earlier that it might have. I didn't install
it yet (I'm in the middle of preparing a new version) and lo and behold, the
play track button doesn't work here as well (clean fiasco+emmc flash, then
added some widgets).
Comment 81 Pelau Vadim 2010-05-27 12:13:25 UTC
It's not that I don't believe you, it's that it still works for me. I'll try
moving touch search on the same screen and wait. In pr 1.1 it also took quite a
while to stop.

I'll have to wait a few days to say it works!

What PR1.2 do you have. Did you flash the pr and then emmc or simple ota
ugrade?

Also are your widgets updated from extras devel to the latest version?
Comment 82 Andre Klapper maemo.org 2010-05-28 19:33:11 UTC
*** Bug 10291 has been marked as a duplicate of this bug. ***
Comment 83 Pelau Vadim 2010-05-29 00:33:28 UTC
Still working over here with abs. no issues since the day PR 1.2 was released
and on the screen with these widgets (added since I last posted):

Inbox widget
TouchSearch
ReCaller
FmTransmitter
Tune Wiki

I did a clean reflash (not because I needed but because I wanted to) in the
following order: PR 1.2 - eMMC - PR 1.2.
Comment 84 taril 2010-05-29 08:46:51 UTC
!radio station streaming does not work either!

after i restored my backup the widget worked for 3 days only.
Comment 85 taril 2010-05-29 10:39:52 UTC
tmp solution for working mp widget:

remove it
click done
add it

you have to do this after each system startup
Comment 86 Pelau Vadim 2010-05-29 10:51:44 UTC
Backup and reflash, the widget is working. Are you sure you updated 100%
correctly and to PR 1.2?

There really must be something wrong for you since no one else seems to
complain :/
Comment 87 taril 2010-05-29 11:11:25 UTC
i guess this bug is come from backup.

i mean i use backup since the first public release of maemo 5, maybe some
settings are changed around hildon-desktop.
i try to restore manually the default hildon-desktop setting by deleting all
the correspond dirs that the backup restore modified.

i really can not reproduce this.
after clean update i restored my backup, mp widget wored for a while after it
stopped working.

before pr 1.2 i removed it readded it, but this method did not help. now it
helps!
Comment 88 taril 2010-05-29 12:06:35 UTC
SOLUTION:

1. delete /home/user/.config/hildon-desktop directory
2. delete /etc/osso-af-init/gconf-dir/apps/osso/hildon-desktop directory
3. delete /etc/osso-af-init/gconf-dir/apps/osso/hildon-home directory
4. reboot your device
5. rebuild your desktop manually without backup-restore!

after each system startup mp widget is working finally! :-)
Comment 89 Misha K. 2010-05-29 15:32:54 UTC
(In reply to comment #86)
> Backup and reflash, the widget is working. Are you sure you updated 100%
> correctly and to PR 1.2?
> 
> There really must be something wrong for you since no one else seems to
> complain :/
> 

I complained and several other people as well. And there are some other on
TMO(talks.maemo.org) complaining. I reflashed, and had no problem before pr1.2,
so it's not from backup
Comment 90 Mathias Gaunard 2010-06-04 03:48:01 UTC
I can confirm this bug. Just flashed to PR1.2 and didn't backup anything.
Everytime I reboot, the widget ceases to work until I remove it and add it
again. Doing so also removes all widgets on the desktop for some unknown
reason.

The fix from comment #88 didn't help.
Comment 91 Pelau Vadim 2010-06-04 08:08:02 UTC
(In reply to comment #90)
> I can confirm this bug. Just flashed to PR1.2 and didn't backup anything.
> Everytime I reboot, the widget ceases to work until I remove it and add it
> again. Doing so also removes all widgets on the desktop for some unknown
> reason.
> 
> The fix from comment #88 didn't help.
> 

Did you also flash the emmc after the PR without rebooting? what PR1.2 did you
use?
Comment 92 Mathias Gaunard 2010-06-04 15:11:31 UTC
UK firmware, didn't flash the emmc.
Also, my previous comment that all widgets on the current desktop disappear is
inaccurate. Only certain widgets disappear, some on the same desktop (recaller,
simple FM transmitter, tune wiki), some on another desktop (email).
Comment 93 taril 2010-06-04 15:19:57 UTC
I fixed this bug. I (maybe) will upload a tiny application for it as soon as I
get home.

I've also noticed that play button becomes impotent when you use the usb data
cable ot the usb charger cable. 

******************************************************************************
TEMPORARY FIX (MANUALLY):
1. open terminal
2. type "root"
3. type "killall hildon-home"

This will restart the entire desktop that forces the play button workable.
******************************************************************************
Comment 94 Dawid Lorenz 2010-06-04 21:32:10 UTC
(In reply to comment #93)
> TEMPORARY FIX (MANUALLY):
> 1. open terminal
> 2. type "root"
> 3. type "killall hildon-home"

I would rather suggest:
1. sudo gainroot
2. su user
3. dsmetool -k /usr/bin/hildon-home
4. dsmetool -t /usr/bin/hildon-home

This way you won't get 3rd party widgets wiped from the desktop.
Comment 95 Matthew Wronka 2010-11-08 15:06:38 UTC
Reading through the comments, I'm not sure why this is marked as "resolved". 
There are a handful of work-arounds that can resolve the issue, but the issue
seems to still be there (I have a recently flashed, non-back-up-restored
instance of PR1.3).  FWIW, I had not experienced this issue in older versions
of the software.

Comment #94 did resolve the issue for me, but it shouldn't be expected that a
new user will come here to look for a bug; if I hadn't had a vague recollection
of seeing this bug filed earlier I wouldn't have even expected it'd have been a
known issue since this bug wouldn't have turned-up in the default search of
open bugs.
Comment 96 Andre Klapper maemo.org 2010-11-08 15:15:02 UTC
(In reply to comment #95)
> Reading through the comments, I'm not sure why this is marked as "resolved".

Because you are now facing bug 7909 which has the same outcome but a different
reason...