Bug 5857 (int-133614)

Summary: Inconsistent keyboard behaviour when configuring a static ip address
Product: [Maemo Official Platform] Connectivity Reporter: Theo Kromhout van der Meer <developer>
Component: WiFiAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: wifi-bugs
Severity: normal    
Priority: Low CC: andrea, andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Theo Kromhout van der Meer (reporter) 2009-10-27 23:05:25 UTC
1.2.009.41-10

Go to the control panel.
Make a new internet connection to a wlan.
Give it a name (not important) pick a wlan from the list
to configure. In the next screen you see an advanced button.
Click it. The layout of this screen is not maemo style but that isn't the bug.
Click the IP-address tab an try to type in TCP/IP address with the use of the
blue FN key. You can't type in numbers.
You can, while holding down the caps key. This is inconsistent hardware
behavior.

Tried it several times, this is reproducible.

EXTRA SOFTWARE INSTALLED:
None
OTHER COMMENTS:
Can put off customers because behaviour is inconsistent.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14)
Gecko/2009090900 SUSE/3.0.14-0.1.2 Firefox/3.0.14
Comment 1 Andre Klapper maemo.org 2009-10-28 18:18:32 UTC
Thanks for reporting this bug.

This is fixed in package
connui-internet 2.67+0m5
which is part of the internal build version
2009.42-7
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2009-11-16 14:03:49 UTC
Please note that the fix for this issue is NOT included in the final Maemo5
version 1.2009.42-11 that was released today.
The fix will be included in the next update after 1.2009.42-11.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:28:10 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 Andrea Borgia 2010-01-14 15:34:28 UTC
(In reply to comment #3)

> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).

Verified: numbers can be entered without caps/fn and the dot works fine.