Bug 5810 (int-147026)

Summary: automatically update date/time did not update after plane journey
Product: [Maemo Official Applications] Utilities Reporter: zaheer merali <zaheermerali>
Component: ClockAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: clock-bugs
Severity: normal    
Priority: Low CC: andre_klapper, maemo, tri
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Linux   

Description zaheer merali (reporter) 2009-10-26 17:56:27 UTC
SOFTWARE VERSION: n900 1.2009 41-10
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
have date/time update automatically in settings
fly from sfo to lhr

EXPECTED OUTCOME:
timezone and hence displayed time changes when phone realises it is now in uk
(when carrier signal is received)

ACTUAL OUTCOME:
still on san francisco time

REPRODUCIBILITY:
(always/sometimes/once)
hard to reproduce flying between timezones!

EXTRA SOFTWARE INSTALLED:
none applicable

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.15 RX-51 N900
Comment 1 Andre Klapper maemo.org 2009-10-26 23:21:31 UTC
Heya, was this by any chance happening while switching DST this weekend?
Which exact time zones were covered here? What kind of connections were
available and when? :-/
Comment 2 zaheer merali (reporter) 2009-10-27 02:43:14 UTC
(In reply to comment #1)
> Heya, was this by any chance happening while switching DST this weekend?
> Which exact time zones were covered here? What kind of connections were
> available and when? :-/
> 

No. I was on plane sunday evening 20.50 san francisco time in san francisco.
when i arrived in london on monday 13.50 it did not update to london time, it
stayed on san francisco time even though it changed to carrier o2 uk.

i left it 10 hours and then just turned off automatic update and manually set
timezone and time this evening.
Comment 3 Marcin Juszkiewicz 2009-11-02 14:42:01 UTC
The problem can be also because not all cell operators provide local time
informations.
Comment 4 zaheer merali (reporter) 2009-11-02 15:03:21 UTC
Is there a programmatic way I can check if my carrier does?
Comment 5 Venomrush 2009-12-14 02:31:37 UTC
I experienced the same issue on my recent journey from Europe to Asia.

I had to manually change the time to the current timezone.

The 'update time automatically' is very ambiguous. It's not exactly clear what
the phone is doing.
Comment 6 Andre Klapper maemo.org 2010-02-25 18:16:32 UTC
This has been fixed in package
clockd 0.0.38+0m5
which is part of the internal build version
10.2010.06-10
(Note: 2009/2010 is the year, and the number after is the week.)

One Nokia employee went to London: "Verified that now network time was properly
updated also in London."

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:56:58 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).