Bug 5761 (int-148601)

Summary: Bluetooth GPS reconnect dialog refuses to go away after clicking "No"
Product: [Maemo Official Platform] Location Reporter: Ian Monroe <ian.monroe>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: location-framework-bugs
Severity: normal    
Priority: Low CC: andre_klapper, donn.morrison
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Linux   

Description Ian Monroe (reporter) 2009-10-24 17:52:13 UTC
SOFTWARE VERSION:
Maemo 5
1.2009.41-10
STEPS TO REPRODUCE THE PROBLEM:
Establish a GPS connection with a bluetooth GPS device and open Ovi Maps (so
that it actually gets used). 

Then move out of range of the bluetooth GPS. The dialog asking if a bluetooth
reconnected should be attempted pops up and the users thumbs no.

EXPECTED OUTCOME:
The dialog goes away. 

ACTUAL OUTCOME:
The dialog pops up repeatedly, until the application wanting location is closed
or until the user goes into settings and selects the internal GPS.


REPRODUCIBILITY:
always.
Comment 1 Andre Klapper maemo.org 2009-10-27 15:31:29 UTC
Thanks for reporting this!

(In reply to comment #0)
> Establish a GPS connection with a bluetooth GPS device

Which exact device? Probably unrelated but can't hurt to know...

> Then move out of range of the bluetooth GPS. The dialog asking

What is the *exact* text of that dialog?
Makes it easier to find a ticket when searching...
Comment 2 Donn Morrison 2009-10-30 03:42:49 UTC
Confirming. The text of the message is "The connection to the Bluetooth GPS has
been lost. Try to reconnect? (Yes/No)".

You may normally use a Bluetooth GPS for better fix times but may not always
have it with you when you want to casually browse a map (nor should you be
expected to have the GPS connected at all times when Maps is running). This
seems to be somewhat related to bug 5905 in that Maps assumes you must always
have an internet connection and a GPS active.
Comment 3 Ian Monroe (reporter) 2009-11-09 22:57:45 UTC
It's a Holux M1000.
Comment 4 Donn Morrison 2009-11-09 23:24:54 UTC
(In reply to comment #3)
> It's a Holux M1000. 

I have this device as well, but the bug is unrelated to the make of the
Bluetooth GPS; it's simply the fact that the location framework doesn't
remember that you pressed "No" when you dismissed the dialog.

On a side note, Ian, would you mind having a go at bug 5586 and see if you can
confirm it? I think it may in fact be specific to the Holux M1000.
Comment 5 Andre Klapper maemo.org 2009-11-26 21:15:05 UTC
Yes, this MIGHT be a duplicate of bug 5905. Good catch!

So I currently expect bug 5368, bug 5905 and bug 5761 to have the same
underlying root issue in location-proxy having a broken passing of the user
decision to click "No". This is just my uneducated guess though.
Comment 6 Andre Klapper maemo.org 2009-11-27 18:58:44 UTC
This has been fixed in the internal build version
2.2009.47-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:23:01 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.