Bug 5744 (int-144286)

Summary: Volume slider doesn't notice when you plug in headphones
Product: [Maemo Official Applications] Statusbar Widgets Reporter: Marius Gedminas <marius>
Component: SoundAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: sound-applet-bugs
Severity: normal    
Priority: Low CC: andrea, andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   

Description Marius Gedminas (reporter) 2009-10-23 15:02:54 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Start playing some music
2. Plug in headphones
3. Make sure the volume slider is set to something like 50%
4. Unplug headphones
5. Make sure the volume slider is set to 0% (i.e. muted)
6. Plug in headphones -- you hear the sound
7. Unplug headphones -- the sound is muted

Which is extremely nice!

Now for the bug itself:

8. Make sure the statusbar is not open
9. Plug in headphones
10. Open the statusbar widgets, look at the volume slider -- it will display
50%
11. Unplug headphones without touching the statusbar

EXPECTED OUTCOME:
No sound is coming from the speakers, volume slider says 0%

ACTUAL OUTCOME:
No sound is coming from the speakers, volume slider says 50%

If you now close the statusbar and reopen it, the volume slider correctly says
0%.  The user should not have to force a refresh in this manner, the statusbar
volume plugin should notice headphone events and switch to the correct
pulseaudio mixer or whatever it does.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-10-27 14:24:01 UTC
This will be fixed in maemo-statusmenu-volume 0.41.
Comment 2 Andre Klapper maemo.org 2009-11-03 13:06:39 UTC
This has been fixed in package
maemo-statusmenu-volume 0.42+0m5
which is part of the internal build version
2009.45-7
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:26:36 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.