Bug 5742 (int127366/int-147885)

Summary: Contacts: Provide "Fax" field(s)
Product: [Maemo Official Applications] Contacts Reporter: Tim Samoff <tim>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: contacts-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, archebyte, asys3, bugzilla, chemist, lionel, maemo, shreks2099
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Tim Samoff (reporter) maemo.org 2009-10-23 14:40:27 UTC
SOFTWARE VERSION:
41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open Contacts
2. Add or edit a contact
3. Add field

EXPECTED OUTCOME:
Fax field(s) are available.

ACTUAL OUTCOME:
No fax field(s) available.

OTHER COMMENTS:
I pluralized "field" above, because theoretically the fields should be "Fax,"
"Fax (Home)," and, "Fax (Work)."
Comment 1 Andre Klapper maemo.org 2009-10-23 15:57:35 UTC
Note to myself: int-127366, int-118438, int-101963
Comment 2 Lucas Maneos 2009-10-23 15:59:57 UTC
If you import a VCARD containing a "TEL;TYPE=fax" number, that number is
displayed as "Phone (other)" so it's quite easy to dial by mistake.

At least the tel type seems to be preserved internally: re-exporting the same
contact (even after editing it) results in a VCARD file still describing the
number as TYPE=fax.

Also, even if no fax functionality is currently/officially available, someone
might want to hack something together at some point.
Comment 3 Andre Klapper maemo.org 2009-10-23 16:18:56 UTC
These are *exactly* the arguments internally that make them think a bit longer
about this...
Comment 4 Lucas Maneos 2009-11-06 02:35:48 UTC
*** Bug 6050 has been marked as a duplicate of this bug. ***
Comment 5 mustali 2009-11-10 21:00:42 UTC
to accommodate more numbers (not necessarily fax #s) for a contact, I used the
fax numbers on S60. Are there any plans for the N900 to allow dialling of
fax-numbers?

either way, the fax profile should be displayed correctly as @tim noted.
(home/work). Since the address-book is aware of it, why not display it instead
of calling it "other"?
Comment 6 Andre Klapper maemo.org 2009-11-23 14:03:26 UTC
This has been fixed in the Specification.
Now waiting for the implementation...
Comment 7 Andre Klapper maemo.org 2009-12-30 20:34:41 UTC
This has been fixed in package
libosso-abook 4.20091214.1.0rtc+0m5
which is part of the internal build version
2009.52-6 
(Note: 2009 is the year, and the number after is the week.)
Note that this fix will not be included in the upcoming PR1.1 release.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Lucas Maneos 2009-12-30 20:49:46 UTC
BTW in 2.2009.51-1 this part:

(comment #2)
> If you import a VCARD containing a "TEL;TYPE=fax" number, that number is
> displayed as "Phone (other)" so it's quite easy to dial by mistake.

is already fixed - the number is displayed as "Phone (unsupported)" and is not
a button so can't be dialled any more.
Comment 9 Lucas Maneos 2010-02-25 18:20:26 UTC
*** Bug 9268 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2010-03-15 20:53:09 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 11 Shrek 2010-04-08 06:52:17 UTC
Highly agree! This bug should be fixed to give users more choices and controls
over their personal contacts. Thanks!