Bug 5716 (int-126631)

Summary: Popup menus with rounded corners missing transparency
Product: [Maemo Official Platform] Desktop platform Reporter: Marius Gedminas <marius>
Component: hildon-themeAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: hildon-theme-bugs
Severity: normal    
Priority: High CC: andrei.emeltchenko, andre_klapper, darryl-mailinglists, henri.wiren, tim, wolf.pld
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Linux   
Attachments: screenshot of a popup in the application manager
screenshot of fbreader's main (diablo-style) menu

Description Marius Gedminas (reporter) 2009-10-22 14:48:18 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Open a popup menu, any popup menu.

EXPECTED OUTCOME:
The rounded menu corners are transparent, the blurred-out main screen shows
through.

ACTUAL OUTCOME:
The rounded menu corners are solid-color, the color is sometimes unexpected.
I will attach screenshots of the application manager and FBReader.

REPRODUCIBILITY:
always

OTHER COMMENTS:
I'm just guessing which component to assign this bug to.
Comment 1 Marius Gedminas (reporter) 2009-10-22 14:49:14 UTC
Created an attachment (id=1487) [details]
screenshot of a popup in the application manager
Comment 2 Marius Gedminas (reporter) 2009-10-22 14:49:56 UTC
Created an attachment (id=1488) [details]
screenshot of fbreader's main (diablo-style) menu
Comment 3 Andre Klapper maemo.org 2009-10-26 22:23:42 UTC
Confirming.
Interesting part is that this does NOT happen always.
Comment 4 Andre Klapper maemo.org 2009-12-08 15:41:26 UTC
*** Bug 6496 has been marked as a duplicate of this bug. ***
Comment 5 Tim Samoff maemo.org 2009-12-08 16:41:48 UTC
I know that Priority isn't a huge factor in fixing bugs or making enhancements,
but I feel like this is important. I'm pretty sure anyone with an artistic eye
-- and probaby a lot of iPhone users -- would see this minor little lack of eye
candy as a huge turn-off (it's been one of the most annoying things about Maemo
5 for me since the very beginning). Therefore I changed the Priority to High.
Feel free to argue or change it back to Low Priority, but I'll diasagree. It's
the little details that make a world-class OS.
Comment 6 Tim Samoff maemo.org 2009-12-23 20:15:04 UTC
This is still a bug in 2.2009.51-1.
Comment 7 Andre Klapper maemo.org 2009-12-28 13:16:54 UTC
This has been fixed in packages
hildon-theme-alpha 9.3+0m5
hildon-theme-beta 8.3+0m5
which is part of the internal build version
2009.52-3
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2009-12-29 12:48:53 UTC
*** Bug 7419 has been marked as a duplicate of this bug. ***
Comment 9 Andrei 2010-01-04 16:07:55 UTC
BTW: IMO we shall remove all popup menus. Why do we need them?
Comment 10 Tim Samoff maemo.org 2010-01-04 17:47:44 UTC
(In reply to comment #9)
> BTW: IMO we shall remove all popup menus. Why do we need them?
> 

This bug refers to contextual popups (tap/hold). These are an integral part of
the Maemo 5 UI.
Comment 11 Andre Klapper maemo.org 2010-01-04 17:54:53 UTC
(In reply to comment #9)
> BTW: IMO we shall remove all popup menus. Why do we need them?

Is there an internal discussion about this within Nokia? Not really helpful to
start a potential debate that ends up in bikeshedding here if there definitely
won't be changes anyway...
Comment 12 Andre Klapper maemo.org 2010-01-05 15:17:40 UTC
*** Bug 7671 has been marked as a duplicate of this bug. ***
Comment 13 Andre Klapper maemo.org 2010-02-16 16:01:41 UTC
*** Bug 8528 has been marked as a duplicate of this bug. ***
Comment 14 Andre Klapper maemo.org 2010-03-15 20:53:49 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).