Bug 5708 (int-134462)

Summary: Buffalo WHR-G54S router: Internet connection via wifi very unreliable with maximum power saving
Product: [Maemo Official Platform] Connectivity Reporter: Mehdi El Gueddari <emehdi>
Component: WiFiAssignee: unassigned <nobody>
Status: RESOLVED WORKSFORME QA Contact: wifi-bugs
Severity: normal    
Priority: Low CC: andrea, andre_klapper, donn.morrison, emehdi, jukey, jussi, maemo, marko.j.berg, mikael.honkala, tscott999+bug
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0 (1.2009.42-11)   
Hardware: N900   
OS: Maemo   

Description Mehdi El Gueddari (reporter) 2009-10-22 12:50:24 UTC
SOFTWARE VERSION:
Maemo 5 - 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1) Configure a D-Link DSL-G624M wifi router with WPA2 and connect with N900.
2) Open a web page in the web browser.
3) Wait a couple of minutes

EXPECTED OUTCOME:
Internet connection still works.

ACTUAL OUTCOME:
When connecting to a D-Link DSL-G624M wifi router (haven't been able to test
with other routers), the internet connection drops after a very short period of
time (2 minutes at most maybe). The phone is still connected to the wifi
network and doesn't report any problems but the web browser fails to load web
pages ("couldn't connect to the server"), playing Internet Radio in Media
Player fails, IM fails, etc.

The only way to get the Internet connection to work again is to disconnect the
wifi connection and connect again. 

Note that this particular router has been working fine with a countless number
of laptop and smartphone (including a Nokia E90 and 5800 and an iPhone 3G and
3GS). It's also working fine with a Nokia N810. The N900 is the only device
that has serious troubles with it. 

WORKAROUND:
Editing the advanced settings of this particular access point on the N900 and
changing the "Power saving" settings from "On (maximum)" to either "On
(intermediate)" or "Off" seems to solve the problem. 

This isn't however a workable solution. It'll be impractical to have to change
this for every router that the N900 has problems with. Most users will never
figure this out. Lowering the power saving settings also has a significant
effect on battery life. 

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Fennec, Bounce, Tuner, Canola 2, Mauku, eCoach, omweather, Conboy, gPodder,
Hermes.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_1; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 Donn Morrison 2009-10-22 14:53:30 UTC
I have been having this problem as well with a Linksys WRT54GL router. All
network connectivity stops working, forcing a disconnect/reconnect to get
things going again. I haven't tried changing the power saving mode, however.
I'll try that when I have a chance.
Comment 2 Lucas Maneos 2009-10-22 19:42:56 UTC
It sounds a lot like 3945, but with different chips/drivers involved I think
it's better to keep them separate.

I haven't experienced this yet, but any information you can provide is welcome.
Comment 3 Mehdi El Gueddari (reporter) 2009-10-23 17:59:06 UTC
I have now been using my N900 with the above-mentioned D-Link router for 2 days
with the power saving setting lowered to "On (intermediate)". I can confirm
that this workaround solves the problem. 

When I was using the default power saving settings of "On (maximum)", the N900
was completely unusable with this router. I had to disconnect and reconnect
wifi every 2 minutes to get the internet connection to work. With the lowered
power saving settings, the internet connection is now rock-solid and hasn't
dropped once. I might even go as far as saying that my N900 works better than
any other Nokia and Apple smartphone I've used when it comes to wifi.

As I said above though, this workaround isn't a workable solution. This issue
really needs fixed.
Comment 4 Uwe Kaminski 2009-10-25 12:18:37 UTC
My router has the same problem. It's a
AVM Fritz!Box 7170:
http://www.avm.de/de/Service/Service-Portale/Service-Portal/index.php?portal=FRITZ!Box_Fon_WLAN_7270

English AVM Page:
http://www.avm.de/en/index.php3
Comment 5 Andre Klapper maemo.org 2009-10-26 22:32:07 UTC
(In reply to comment #2)
> It sounds a lot like 3945

Lucas, please write "bug 3945" - it will autolink and nobody has to copy&paste
:)

(In reply to comment #3)
> power saving setting lowered to "On (intermediate)"

For future reference exact steps are welcome, in this case:
Settings > Internet connections > Connections > Edit > 3xNext > Advanced >
Other > Power saving == On (maximum)


Confirming.
Comment 6 Andre Klapper maemo.org 2009-11-10 22:52:00 UTC
This has been fixed in package
kernel 2.6.28-20094302+0m5
which is part of the internal build version
1.2009.42-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Mikael 2009-12-13 19:47:21 UTC
(In reply to comment #6)
> This has been fixed in package
> kernel 2.6.28-20094302+0m5
> which is part of the internal build version
> 1.2009.42-5

I have a new device with build version 1.2009.42-11, with the bug present.
Comment 8 Uwe Kaminski 2009-12-13 23:12:31 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > This has been fixed in package
> > kernel 2.6.28-20094302+0m5
> > which is part of the internal build version
> > 1.2009.42-5
> 
> I have a new device with build version 1.2009.42-11, with the bug present.

Can you please explain which router you are using and where exactly you have
problems?  

After an upgrade to 1.2009.42.11 I never had this problem again. In different
WiFi networks and with different devices.
Comment 9 Mehdi El Gueddari (reporter) 2009-12-13 23:48:35 UTC
Apologies for not having commented on the fix earlier but I've been away from
home (and from the problematic router) for a few weeks and only got back today.
Anyway, I can confirm that this issue has been fixed for me.

With the latest public firmware (1.2009.42-11), wifi connection is perfectly
stable with the wifi router mentioned in the original bug report (D-Link
DSL-G624M). This is using the default settings for the wifi access point on the
N900 abd in particular with the power saving mode set to the default "On
(maximum)". I'm not seeing the regular loss of connectivity anymore.

Thanks a lot guys for this. I honestly didn't expct this problem to be
addressed so quickly - nice to see that Nokia is listening.
Comment 10 Mikael 2009-12-14 05:46:23 UTC
(In reply to comment #8)
> Can you please explain which router you are using and where exactly you have
> problems?  

I have Buffalo WHR-G54S with stock firmware Ver.1.40 (1.0.37-1.08-1.03).

The problem is as described for the original bug - requiring a reconnect every
know and then, problem apparently removed after moving the power saving setting
to intermediate.
Comment 11 Uwe Kaminski 2009-12-14 12:30:19 UTC
I'm making a special bug out of this generic one. Buffalo WHR-G54S is the only
router with this issue. Can someone else confirm this?
Comment 12 Lucas Maneos 2009-12-15 12:48:35 UTC
(In reply to comment #11)
> I'm making a special bug out of this generic one. Buffalo WHR-G54S is the only
> router with this issue. Can someone else confirm this?

I don't have that particular model, but no problems with several other
Broadcom-based Buffalo units (WBR-G54, WHR-HP-G54, WZR-RS-G54) running OpenWrt
which makes me think it may be a bug in the Broadcom WLAN firmware (the last
official update for the WHR-G54S seems to be 1.40 from way back in August
2006).

Note that flashing OpenWrt on your AP is not for everyone, and please don't do
this if you are not 100% sure what you are doing (you may brick it).
Comment 13 Andre Klapper maemo.org 2010-01-05 17:49:32 UTC
So according to comment 7 one user still runs into this, while two users say
that the issue is fixed for them in 1.2009.42-11.

Now wondering what to do here.

Mikael, any chance to provide a net traffic log?
Comment 14 Mikael 2010-01-07 22:49:12 UTC
(In reply to comment #13)
> So according to comment 7 one user still runs into this, while two users say
> that the issue is fixed for them in 1.2009.42-11.

Earlier the wifi router was set for a specific channel (due to problems with
Vista). After resetting the channel setting to Automatic, I have now been able
to set the N900 back to full power saving mode again, and have been running for
24 hrs without wifi problems.

This leads me to guess that the problem was due to channel conflict with other
routers in the vicinity.
Comment 15 Jussi Holm 2010-01-10 13:23:37 UTC
(In reply to comment #11)
> I'm making a special bug out of this generic one. Buffalo WHR-G54S is the only
> router with this issue. Can someone else confirm this?

I seem to have this problem with a Buffalo WHR-G300N, with latest available
stock firmware (Ver.1.64 (R1.05/B1.09)).

My N900 reports it's version as 1.2009.42-11.

Symptoms are similar to original reporter.

My observations about the problem:

* It looks like the N900 thinks it still is connected, while the router has
already disassociated it. When the connection has stopped working, there's a
log entry in the router's log:
  ra0: had been aged-out and disassociated : ec:9b:5b:xx:yy:zz

* The problem occurs when there's no outgoing traffic from the N900 in few
minutes. Incoming traffic does not seem to have effect (I've verified with
tcpdump that the N900 receives my LAN's broadcast noise).

* Leaving a 'ping -i 120 my.gateway.ip' running on the device seems to be
enough to keep the connection from dropping, even with the power saving set to
maximum on the N900.

I'm still iterating through various combinations of router settings, in order
to find something where this does not happen. I'll post an update if I find
any.
Comment 16 Andre Klapper maemo.org 2010-01-11 12:42:37 UTC
Closing as per comment 14 as WORKSFORYOU again.
Please feel free to reopen if you investigate the problem again.

Comment 15: Different hardware, please file a separate report.
Comment 17 tscott999+bug 2010-03-22 19:57:17 UTC
I have a Buffalo WHR-G54S and I have tried it with Tomato and stock FW.
My phone is LG ARENA KM900. After a few minutes I lose internet connectivity
and need to restart the router to regain it.  I have a laptop thats fine, and
my wife's laptop also does this.  I'm not sure if it is the same issue here,
but I can still browse web servers on the lan, hence the wireless side is fine,
but i cannot browse the internet.  Very odd.  Definetly the router, becuase the
problem clears if you reboot it.  I have used static and auto DHCP ip addresses
too, no joy.
Comment 18 M. Berg 2010-11-13 18:02:21 UTC
Hi, I'm facing the same problem with a different router, namely Buffalo
WZR-AGL300NH. When the network hasn't been used by the N900 for 5 minutes, the
router breaks the WLAN association. In the base station log the events show up
like this:

2010/10/20 16:38:24    WIRELESS    ra0: had been aged-out and disassociated :
<PHONE MAC ADDRESS>
2010/10/20 16:33:23    DHCPS    sending ACK to <PHONE IP>
2010/10/20 16:33:23    DHCPS    Request comein from Nokia-N900-42-11(len:16)
2010/10/20 16:33:23    DHCPS    sending OFFER of <PHONE IP> Nokia-N900-42-11
2010/10/20 16:33:21    DHCPS    Request comein from Nokia-N900-42-11(len:16)
2010/10/20 16:33:20    AUTH    ra0: set key done in WPA/WPAPSK : <PHONE MAC
ADDRESS>
2010/10/20 16:33:17    WIRELESS    ra0: had associated successfully : <PHONE
MAC ADDRESS>

After this the N900 requires a manual reconnect to be able to use the WLAN. OS
version in use is 20.2010.36-2.
Comment 19 Andre Klapper maemo.org 2010-11-20 12:23:50 UTC
(In reply to comment #18)
> Hi, I'm facing the same problem with a different router, namely Buffalo
> WZR-AGL300NH.

Feel free to post a new bug report about your hardware, with logs.