Bug 5688 (int-140138)

Summary: Improve zooming
Product: [Maemo Official Applications] Images and Camera Reporter: Tim Samoff <tim>
Component: CameraAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: camera-bugs
Severity: major    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Tim Samoff (reporter) maemo.org 2009-10-21 22:03:07 UTC
SOFTWARE VERSION:
41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open Camera app
2. Zoom

EXPECTED OUTCOME:
Zoom is smooth (especially for video).

ACTUAL OUTCOME:
Zoom is choppy and jerky.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Even if the zoom remains "choppy" (i.e., not silky smooth), I would expect that
it zooms at the same rate all the way in. Currently, if you hold the zoom
button down, it zooms a few increments and then stutters, then zooms a few more
and stutters, etc. Just improving that (without making it complete smooth)
would be a big improvement.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1.4) Gecko/20091006 Firefox/3.5.4
Comment 1 Andre Klapper maemo.org 2009-11-11 20:11:03 UTC
This has been fixed in package
camera-ui 1.0.44.4+0m5
which is part of the internal build version
2009.46-9
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:27:45 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 3 Tim Samoff (reporter) maemo.org 2010-01-14 15:44:35 UTC
I'm sorry, but this is not fixed. Unless it's a WONTFIX. We need some
verification on the ultimate functionality.
Comment 4 Andre Klapper maemo.org 2010-08-30 19:41:06 UTC
Re Comment 3:
"I've checked and it is true that in video mode there are some jumps.
Still, the zoom bar is smooth so I really think the problem is in the
performance of the GStreamer side. In Camera-UI we tweaked the zoom steps size
to make it smoother and it is right now, GStreamer is responding slower.
Because of this, I recommend to open a new bug in which to track this issue."