Bug 5633 (int-143669)

Summary: No hint that it is impossible to paste an strings containing non-numeric characters into a phone number field
Product: [Maemo Official Applications] Contacts Reporter: Uwe Kaminski <jukey>
Component: GeneralAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: contacts-bugs
Severity: normal    
Priority: Low CC: andre_klapper, john.maemo, jukey, lionel, maemo, mathias.hasselmann, mikhail.zabaluev
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Uwe Kaminski (reporter) 2009-10-20 18:52:00 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. Open a skype (or other) chat
2. Write: "Mobile phone: +123456789987"
3. Press the send button
4. Tip and hold onto the number you wrote in step 2 in the chat protocol. A
context menu will appear.
5. Select "copy".
6. Open a contact
7. select "edit contact". The contact is getting editable.
8. select "add field"
9. select one of the phone number fields
10. Try to insert the phone number from step 5 using the keys [Ctrl] + [v]

EXPECTED OUTCOME:
1. An error message occurs because in step 5 not only the whole number but the
complete line of text (remember: "Mobile phone: +123456789987") was copied in
step 5. There was no possibility to select only a part of the text.
2. The complete string will be inserted but the user has to correct the sting
(numbers and '+' only) if he wants to save the contact.

ACTUAL OUTCOME:
Nothing happens. The user doesen't know whats going on.

REPRODUCIBILITY:
always

OTHER COMMENTS:
An a little bit better solution would be to inform the user that he could not
insert strings including non-numeric characters. But than the user has to
understand that the whole line was copied in step 5 and not only the number.
Comment 1 Lucas Maneos 2009-10-20 21:16:45 UTC
I came across this when trying to clean up my imported contacts (interestingly
those are allowed to have non-numeric characters in phone fields) a bit:  copy
a number that included spaces from wrong field, try to paste it into right one,
fail.

Another suggestion would be to filter out the non-allowed characters and paste
the rest, eg "+123456789987" in the above example.
Comment 2 Mathias Hasselmann maemo.org 2009-10-20 22:05:50 UTC
AFAIK the copy-and-paste issue is in hildon-input-method.
Comment 3 Mikhail Zabaluev nokia 2009-11-03 17:29:13 UTC
The fix is underway.
Comment 4 Andre Klapper maemo.org 2009-11-04 13:25:09 UTC
This has been fixed before the internal build version 2009.44-5 was released.
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 5 Uwe Kaminski (reporter) 2009-12-26 02:22:56 UTC
Fixed in Firmware PR 1.1.
Comment 6 Andre Klapper maemo.org 2009-12-28 14:08:50 UTC
(Version field is for the version in which the bug still occurs. Resetting.)
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:04 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.