Bug 5626 (int-137633)

Summary: Button style in Bluetooth file receive applet is wrong
Product: [Maemo Official Platform] Connectivity Reporter: Thomas Perl <m>
Component: BluetoothAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: bluetooth-bugs
Severity: normal    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   
Attachments: screenshot of the status applet area when receiving a file

Description Thomas Perl (reporter) 2009-10-20 14:37:24 UTC
SOFTWARE VERSION:

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

a) Receive a file via Bluetooth from another computer
- OR -
b) Send a file via Bluetooth to another computer ("Share")

EXPECTED OUTCOME:

The status bar applet button has a correct style, and the progressbar works

ACTUAL OUTCOME:

The status bar applet looks weird and the progressbar does not show progress

REPRODUCIBILITY:

always

OTHER COMMENTS:

I just assume that the black bar on that button is supposed to be a progress
bar. If it's not, there's probably some other bug there. it would also be more
helpful to have the big text on the button say "Receiving files" and the
secondary text say "XX% from [devicename]" or something like that.
Comment 1 Thomas Perl (reporter) 2009-10-20 14:38:01 UTC
Created an attachment (id=1474) [details]
screenshot of the status applet area when receiving a file
Comment 2 Andre Klapper maemo.org 2009-10-20 21:01:10 UTC
Confirmed.
Also, the progressbar does not move.
Comment 3 Andre Klapper maemo.org 2009-11-16 15:14:10 UTC
This has been fixed in package
connui-bluetooth 2.58+0m5
which is part of the internal build version
2.2009.47-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Thomas Perl (reporter) 2009-12-23 16:57:54 UTC
I confirm that this has been fixed in 2.2009.51-1:

 * The applet looks like a proper button now

Tested cases:

 * Sending an image file via Bluetooth (Sharing)
 * Receiving an image fiel via Bluetooth

Thanks!
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:07 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.