Bug 5625 (int-150446)

Summary: Feed list (Folder tree) uses non-finger friendly classic scrollbars
Product: [Maemo Official Applications] RSS feed reader Reporter: Attila Csipa <attila.csipa>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: rss-feed-reader-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, ivgalvez, mike, pancake, quim.gil, vdv100
Version: 5.0/(2.2009.51-1)Keywords: patch
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Linux   
Attachments: oss-rss patch try #1

Description Attila Csipa (reporter) nokia 2009-10-20 14:24:37 UTC
SOFTWARE VERSION:
Maemo 5, 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Start RSS reader, try to scroll feed list

EXPECTED OUTCOME:
Act in line with Fremantle UI guidelines

ACTUAL OUTCOME:
Scrolling is done with a scrollbar (as in Maemo 4), no drag scrolling possible
(except for the scrollbars)

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4pre)
Gecko/20090916 Ubuntu/8.04 (hardy) Shiretoko/3.5.4pre
Comment 1 Andre Klapper maemo.org 2009-10-20 20:41:46 UTC
According to the Spec the folder tree uses a GTK Tree View.
It is not planned to change this for Fremantle - keeping this open for
Harmattan.
Comment 2 Andre Klapper maemo.org 2009-10-26 15:12:31 UTC
*** Bug 5799 has been marked as a duplicate of this bug. ***
Comment 3 pancake 2009-10-26 18:04:05 UTC
Here's a list of interesting usability tips I have posted in another bug report
which has been marked as dupped.

- left panel must be more finger friendly
  - add a 'planet' view on top of the subscribed RSSs feeds.
  - toggle with no possible manual panning (fixed size)
  - kinetic scrolling on left panel too
  - bigger icons
  - two line width to store the name
  - no horizontal scrolling (maybe '..' dots if doesnt fit)
  - long press to get info about the RSS (drop (i) icon from the botton bar)
  - long press to remove feeds
Comment 4 Iván Gálvez Junquera 2009-12-09 13:04:41 UTC
If this is going to be open till Maemo 6, does it means that it won't be fixed
for the N900?

I think it would be a mistake as every N900 potential customer expects it
software to be updated and improved with new features the way the iPhone is
being improved with new features.

Obviously, the main concern is if ther will be a Maemo 6 update for the N900.
Comment 5 Andre Klapper maemo.org 2009-12-09 13:09:56 UTC
(In reply to comment #4)
> Obviously, the main concern is if ther will be a Maemo 6 update for the N900.

Up to Nokia - See the corresponding threads in talk.maemo.org ...
Comment 6 Quim Gil nokia 2009-12-10 14:43:10 UTC
The RSS Feed Reader hasn't gone through major UI changes since a long time ago.
My unedicated guess (someone please correct me) that a tree view is not easy to
get with the Maemo 5 widgets without going through a replanning of the UI. 

Changes in the UI specifications for this app are very unprobable at this
point.

RSS Feed Reader is all open source:
http://repository.maemo.org/pool/maemo5.0/free/o/osso-rss-feed-reader/

If a developer wants to go ahead with an improvement like this, or any other
major improvements in this application, let us know.
Comment 7 Michael Cronenworth 2009-12-11 08:53:21 UTC
Created an attachment (id=1729) [details]
oss-rss patch try #1

(In reply to comment #6)
> If a developer wants to go ahead with an improvement like this, or any other
> major improvements in this application, let us know.
> 

Your wish is my command.

This is a simple patch to turn on ellipsis on the feed tree view and widen the
slider bar so you can actually touch it with a finger. Feel free to make any
changes. This should alleviate the immediate concerns with regards to finger
interaction.

I haven't thought up any neat ideas on how to handle the UI, but I think it
should follow the e-mail client. You get the full name of the RSS feed + count
of new items. Click on the feed to view it, etc.
Comment 8 Quim Gil nokia 2009-12-11 09:38:39 UTC
That's great, thank you! Do you mind sharing a screenshot - it will help me
finding the way to open the development of the RSS Feed reader while Andre
submits the patch for revision.
Comment 9 Iván Gálvez Junquera 2009-12-11 09:48:20 UTC
You absolutely rock guys!
Comment 10 Quim Gil nokia 2009-12-11 10:22:21 UTC
Reopening and adding the patch keyword. Andre, please file it internally.
Thanks!
Comment 11 Michael Cronenworth 2009-12-12 01:44:12 UTC
(In reply to comment #8)
> That's great, thank you! Do you mind sharing a screenshot - it will help me
> finding the way to open the development of the RSS Feed reader while Andre
> submits the patch for revision.
> 

http://i284.photobucket.com/albums/ll20/daumas/Maemo/osso-rss-screenshot.png
Comment 12 Andre Klapper maemo.org 2010-01-21 14:49:08 UTC
Michael:
Discussing with internal developers that insist on some specifications that
partially don't make sense (like "Ellipsize not allowed in Maemo5"), it would
be great if you could describe what your patch is intended to do.

* Make the slider between feed list on the left and right pane bigger?
* Display every feed in the feed list on the left in two lines instead of one?
* Ellipsize of long lines in the feed list on the left?
* Remove scrollbars in the feed list on the left completely?

Thanks a lot.
Comment 13 Michael Cronenworth 2010-01-22 03:23:46 UTC
(In reply to comment #12)
> * Make the slider between feed list on the left and right pane bigger?
Yes, that was my intention. I made it 3 times larger. This makes it easier to
adjust with a finger.
> * Display every feed in the feed list on the left in two lines instead of one?
I did not adjust how many lines the feed list uses. I only adjusted the slider
size.
> * Ellipsize of long lines in the feed list on the left?
Yes, this is a natural UI look, but I feel the feeder needs an overhaul in this
department. Instead of a feed list on the left and the HTML on the right, the
reader should function like the E-Mail application. You are initially presented
with a feed list, and when you click on a feed it swipes the screen to the HTML
viewer.
> * Remove scrollbars in the feed list on the left completely?
I don't think scrollbars need to be removed, unless using ellipsis is
prohibited by some odd "Mameo law."

> 
> Thanks a lot.
> 

You're welcome. I wish I had more time to give the feed reader the overhaul it
deserves.
Comment 14 Andre Klapper maemo.org 2010-01-28 14:28:06 UTC
Michael, thanks for explaining!

This has been fixed in package
osso-rss-feed-reader 1.7.52-1+0m5
which is part of the internal build version
2009.52-9
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 15 Andre Klapper maemo.org 2010-03-15 20:55:21 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).