Bug 5603 (int-132907)

Summary: Vertical photos from other devices should fill more space when shown in portrait.
Product: [Maemo Official Applications] Images and Camera Reporter: Daniel Martin Yerga <dyerga>
Component: Image viewerAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: image-viewer-bugs
Severity: normal    
Priority: Low CC: ab, andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   
Attachments: Photo made with the N900
Photo made with the Nokia N95
Screenshot with the N95 photo
Screenshot with the N900 photo
Screenshot on N900

Description Daniel Martin Yerga (reporter) 2009-10-19 18:56:43 UTC
SOFTWARE VERSION:
Maemo 5: 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

N900's camera photo:
1) Open the camera application in the N900.
2) Change the orientation of the device to portrait (the camera UI doesn't
change).
3) Grab a vertical photo.
4) Open the photo with the Images application, and go to fullscreen.
5) Move the N900 to portrait orientation. 

Other device's photo:
6) Copy a vertical photo made with other device to the N900 (for example with a
Nokia N95).
7) Open the copied image with the Images application, and go to fullscreen.
8) Move the N900 to portrait orientation.

EXPECTED OUTCOME:

The vertical photos made with other devices should fill more from the available
space in the screen if they are bigger than 480x800 (width x height).


ACTUAL OUTCOME:

Vertical photos bigger than 480x800 are shown with black borders for the 2
dimensions.


Photos made with the N900 are using all the available space from the screen, so
they are working correctly.

REPRODUCIBILITY:
Always: I tried with photos from a Nokia N95, Sony DSC-P72 and a cheaper Benq.


OTHER COMMENTS:
I'll attach two example photos.
Comment 1 Daniel Martin Yerga (reporter) 2009-10-19 19:03:47 UTC
Created an attachment (id=1462) [details]
Photo made with the N900

This is a photo made with the N900, it's working as it should.
Comment 2 Daniel Martin Yerga (reporter) 2009-10-19 19:05:18 UTC
Created an attachment (id=1463) [details]
Photo made with the Nokia N95

Vertical photo made with the Nokia N95.
This photo triggers the bug.
Comment 3 Alexander Bokovoy 2009-10-19 21:45:27 UTC
Have you tried to make 5Mpix photo with N900? It should behave the same way as
with N95's photos.

The reason for that is aspect ratio of the image. Default 3.5Mpix resolution in
N900 camera is close to N900's screen aspect ratio, thus almost no black space
left.

5Mpix image is 4:3 aspect ratio and your N95's photos have similar aspect
ratio.

In order words, image viewer is preserving aspect ratio when showing images in
full screen mode.
Comment 4 Daniel Martin Yerga (reporter) 2009-10-19 21:59:27 UTC
(In reply to comment #3)
> Have you tried to make 5Mpix photo with N900? It should behave the same way as
> with N95's photos.
> 
> The reason for that is aspect ratio of the image. Default 3.5Mpix resolution in
> N900 camera is close to N900's screen aspect ratio, thus almost no black space
> left.
> 
> 5Mpix image is 4:3 aspect ratio and your N95's photos have similar aspect
> ratio.
> 
> In order words, image viewer is preserving aspect ratio when showing images in
> full screen mode.
> 

Yes, I know about the aspect ratio, using a 5MP photo made with the N900 also
works correctly.

Sorry if I don't have explained well the problem. Let me attach two screenshots
taking as examples a 5MP photo from the N900 and one from the N95.
Comment 5 Daniel Martin Yerga (reporter) 2009-10-19 22:05:47 UTC
Created an attachment (id=1464) [details]
Screenshot with the N95 photo

This screenshot is with the N95 5MP photo. Note the black borders are in both
directions.
Comment 6 Daniel Martin Yerga (reporter) 2009-10-19 22:08:59 UTC
Created an attachment (id=1465) [details]
Screenshot with the N900 photo

This is the case with the 5MP photo from the N900. It uses all space available
in the Y direction, so it hasn't black borders in both directions like it's the
case with the N95 photo.
Comment 7 Alexander Bokovoy 2009-10-19 22:22:56 UTC
Yes, I see the same with this image -- it looks like it is centered as some
multiple of 320x240 image (ImageViewer also claims in properties that this
image has a thumbnail embedded size of 320x240).

If you look at it with tracker-info (tracker-info /path/to/file.jpg) then you
can see that dimensions are reported properly.

Let me check something on this internally. I'll come back in few days.
Comment 8 Andre Klapper maemo.org 2009-10-20 13:57:42 UTC
Created an attachment (id=1473) [details]
Screenshot on N900

Must admit I still don't get the issue here.
Using the picture from comment 2 this is how it looks on the N900, no black
borders.

What am I missing?
Comment 9 Daniel Martin Yerga (reporter) 2009-10-20 14:38:17 UTC
(In reply to comment #8)
> Created an attachment (id=1473) [details] [details]
> Screenshot on N900
> 
> Must admit I still don't get the issue here.
> Using the picture from comment 2 this is how it looks on the N900, no black
> borders.
> 
> What am I missing?
> 


Perhaps I'm missing an update to the latest and greatest software?

Comment #5 is my screenshot from the N900, compare it with yours ;-)
Comment 10 Andre Klapper maemo.org 2009-10-20 17:30:49 UTC
Heh. Probably FIXED in the meantime, as I'm not sure though I close as
WORKSFORME.
Comment 11 Alexander Bokovoy 2009-10-20 18:26:06 UTC
It is actually fixed and will be available in next software update. Andre,
please update alias to include proper internal bug number for it: int-132907.
Comment 12 Andre Klapper maemo.org 2009-10-20 18:27:51 UTC
Oh, even better. Thanks!
Comment 13 Andre Klapper maemo.org 2009-11-12 16:07:53 UTC
This has been fixed in package
imageviewer-ui 3.3.42.1+0m5
which is part of the internal build version
2009.43-2
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 14 Daniel Martin Yerga (reporter) 2009-12-23 17:29:26 UTC
Verified in non-public PR1.1 version (2.2009.51-1). Thanks!
Comment 15 Andre Klapper maemo.org 2010-01-14 12:27:42 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.