Bug 5597 (int-144435)

Summary: First Synchronization between N900 and Exchange 2003 Server always fails
Product: [Maemo Official Platform] Synchronization Reporter: Uwe Kaminski <jukey>
Component: Mail for ExchangeAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: activesync-bugs
Severity: major    
Priority: High CC: andre_klapper, atflex, baranguren, barney.barnes, bbris, bgetter, bugs.maemo.org, clay.babcock, corwin, emehdi, geert.devries, h.loots, info, jerome, jip, joachim.wuilmet, jonoden, jukey, kcman123, kenneth, kyle, m.rooseboom, maemo, massimo.bilvi, michaeldaniels88, moinuddeen.shaikh, mrmg, quim.gil, redonj, sami, seppo.taskunen, tierney.steve, tomas.westerholm, toojays, urbanguru, vitaly.repin
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   
Attachments: Error message screenshot
syslog with server m.google.com
Syslog of the situation with a ms exchange 2003 server
Logfile from Active Sync to Exchange 2007
Initial sync log after the 51-1 update
Syslog of failed initial sync after PR1.1 update.

Description Uwe Kaminski (reporter) 2009-10-19 16:12:10 UTC
SOFTWARE VERSION:
N900 see above
Exchange Server 2003 / Outlook Web Access 3.5

INFORMATION TO REPRODUCE THE PROBLEM:
I only selected E-Mail as sync source (but it happens also if I try to
synchronize calendar and contacts the same way).

During the first synchronisation the progress bar fills up to more or less 50%
but the it stops and an error message occours:
"Fehler bei der Kommunikation mit dem Exchange Server" (English it should be
something like "Error during the communication with the exchange server").

REPRODUCIBILITY:
always

OTHER COMMENTS:
I used the same credentials (Server URL, Username, ...) on my Nokia E52 in Mail
for Exchange and it works without any problem.

Pleas tell me what I can do to provide more information about this issue. Is
the a possibility to start the wizard from command line with some debug
parameters? Or will there be a log file if something goes wrong during
synchronization?
Comment 1 Andre Klapper maemo.org 2009-10-19 19:23:43 UTC
Do you use a certificate (bug 5509)?
Does this only happen when trying for the first time?

Actually this also happened to me when trying MfE with Google for the first
time.
Comment 2 Uwe Kaminski (reporter) 2009-10-19 22:49:55 UTC
(In reply to comment #1)
> Do you use a certificate (bug 5509)?

No, I don't use a certificate.

> Does this only happen when trying for the first time?

The first sync never ends. The progress bar keeps near 50% after the decribed
error message occurred. So a second sync is not possible because I can't create
the Mail for Exchange account on the N900.

> Actually this also happened to me when trying MfE with Google for the first
> time.

Ando how you where able to make a second sync?
Comment 3 Hans Loots 2009-10-21 14:20:40 UTC
(In reply to comment #2)

I got the feeling the problem is in Exchange 2003, we tested it with 2007 and
it works fine. We are having the same problem with 2003.



> (In reply to comment #1)
> > Do you use a certificate (bug 5509)?
> No, I don't use a certificate.
> > Does this only happen when trying for the first time?
> The first sync never ends. The progress bar keeps near 50% after the decribed
> error message occurred. So a second sync is not possible because I can't create
> the Mail for Exchange account on the N900.
> > Actually this also happened to me when trying MfE with Google for the first
> > time.
> Ando how you where able to make a second sync?
Comment 4 Mehdi El Gueddari 2009-10-22 13:22:42 UTC
I've had a different but similar problem when trying to setup contact and
calendar sync with Google via Exchange  (I didn't try to sync emails).

During the initial sync, the "Initialising sync" progress bar progressed quite
quickly. It then started to synchronise the calendar. That took forever
(between 5 and 10 minutes - note that I have exactly 0 events in my Google
calendar and 5 events in the N900 calendar I was syncing). The "Calendar"
progress bar then reached 100% and remained there forever. It never proceeded
to sync the contacts. After having waited for an hour, I canceled the whole
thing. 

Even though the initial sync said that it had done 100% of the calendar
synchronisation, none of the 5 events I had in my N900 calendar showed up in
Google Cal.
Comment 5 clay babcock 2009-10-22 23:21:14 UTC
*** Bug 5724 has been marked as a duplicate of this bug. ***
Comment 6 clay babcock 2009-10-22 23:23:02 UTC
I am having the same problem with Exchange Server 2003. I can provide a test
account for testers if needed.
Comment 7 Andre Klapper maemo.org 2009-10-27 17:58:42 UTC
*** Bug 5724 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2009-10-27 18:01:28 UTC
To everybody affected here:
How many folders does your email account on the server have?

(Note to myself: Could be int-143189.)
Comment 9 clay babcock 2009-10-27 18:04:30 UTC
Regarding folders.

My setup is straing out-of-the-box exchange.
Inbox
Outbox
Sent
Drafts

I have created no extra folders.
Comment 10 Mehdi El Gueddari 2009-10-27 18:14:55 UTC
I(In reply to comment #8)
> To everybody affected here:
> How many folders does your email account on the server have?

I didn't even try to sync emails (i unticked the option in the setup wizard). I
was only trying to sync contacts and calendar with Google.
Comment 11 Uwe Kaminski (reporter) 2009-10-27 18:45:08 UTC
(In reply to comment #8)
> To everybody affected here:
> How many folders does your email account on the server have?
> 
> (Note to myself: Could be int-143189.)

Inbox
+--folder1
   +--folder11
   +--folder12
   +--folder13
   +--folder14
   +--folder15
+--folder2
+--folder3
+--folder4
+--folder5

On the Inbox-Level there are various Folders like:
*drafts
*deleted
*sent
*Junk-E-Mail
*outbox
*Quarantäne
*quarantine
*search folders
Comment 12 Uwe Kaminski (reporter) 2009-10-27 18:52:36 UTC
(In reply to comment #4)
> I've had a different but similar problem when trying to setup contact and
> calendar sync with Google via Exchange  (I didn't try to sync emails).
> 
> During the initial sync, the "Initialising sync" progress bar progressed quite
> quickly. It then started to synchronise the calendar. That took forever
> (between 5 and 10 minutes - note that I have exactly 0 events in my Google
> calendar and 5 events in the N900 calendar I was syncing). The "Calendar"
> progress bar then reached 100% and remained there forever. It never proceeded
> to sync the contacts. After having waited for an hour, I canceled the whole
> thing. 
> 
> Even though the initial sync said that it had done 100% of the calendar
> synchronisation, none of the 5 events I had in my N900 calendar showed up in
> Google Cal. 

Could you please make a New bug for this issue? It seems to be a little bit
different from this one and would help to re-test after the bugs are fixed.

Thanks, Uwe
Comment 13 clay babcock 2009-10-29 20:31:23 UTC
(In reply to comment #3)
> (In reply to comment #2)
> 
> I got the feeling the problem is in Exchange 2003, we tested it with 2007 and
> it works fine. We are having the same problem with 2003.
> 
> 
> 
> > (In reply to comment #1)
> > > Do you use a certificate (bug 5509)?
> > No, I don't use a certificate.
> > > Does this only happen when trying for the first time?
> > The first sync never ends. The progress bar keeps near 50% after the decribed
> > error message occurred. So a second sync is not possible because I can't create
> > the Mail for Exchange account on the N900.
> > > Actually this also happened to me when trying MfE with Google for the first
> > > time.
> > Ando how you where able to make a second sync?
> 

All,
I can confirm that in our setting moving to Exchange 2007 works. Our hosted
server email is running on both servers. On 2003, it fails the initial sync
with a 50% complete bar. switching the app to the 2007 server works, the sync
competes and runs fine. It seems the issue IS with 2003.
Comment 14 Hans Loots 2009-10-30 12:29:38 UTC
We have also tested on Exchange 2007(2007 works perfect) and 2003 every time
gives a problem.....so we also think the major problem is in Exchange 2003.It
wasn't possible for us to make it work with 2003. The first sync never past the
50% in the first screen.

I think we have wait for the new firmware in the N900....hope the problem is
solved then. 

I am using :
SW Version 1.2009.40-12
Comment 15 Andre Klapper maemo.org 2009-11-03 20:31:21 UTC
*** Bug 5509 has been marked as a duplicate of this bug. ***
Comment 16 Hans Loots 2009-11-10 11:35:33 UTC
Just tryed to synchronise again with new firmware in my N900.

But 1.2009.42-11 is still not working with Exchange 2003....
Comment 17 Dart 2009-11-16 19:49:39 UTC
Shouldn't the priority of this bug be higher? This is blocking all exchange
2003 synchronisations. And there are still a lot of Exchange 2003 servers on
the market!
Comment 18 clay babcock 2009-11-16 20:04:50 UTC
I agree with DART. This is a HUGE issue. Many large organizations will run
Exchange 2003 until MS stops supporting it. This needs to get resolved, the
problem will not go away.
Comment 19 Hans Loots 2009-11-16 20:05:47 UTC
I think the last comment is a very good point! There are a lot more 2003
servers then 2007.
Comment 20 Uwe Kaminski (reporter) 2009-11-17 12:52:06 UTC
I agree with my previous speakers. But the prioritization of this bug should be
in sync with the internal bug report so somebody using both should change the
priority.
Did you already voted for this bug? It's a good method to get more attention to
bugs.
Comment 21 Geert de Vries 2009-11-23 21:28:46 UTC
Experiencing the same

Windows 2003R2 + Exchange2003 SP2 does not initial synchronise.
Please prioritize this bug as HIGH and vote to get more attention to it.
Comment 22 Sami Lavikko 2009-11-24 01:11:38 UTC
Confirmed same failure for me too. Used same settings as I had on my e71, where
this worked perfectly. Should have a very high priority in my opinion, since
this is the main application most business users need on the phone.
Comment 23 Sami Lavikko 2009-11-24 11:40:31 UTC
Created an attachment (id=1620) [details]
Error message screenshot

Here's the error message on that is displayed on the screen.
Comment 24 Quim Gil nokia 2009-11-25 11:57:56 UTC
Thanks for the feedback! We are working on this...
Comment 25 Bruno (GIP) 2009-11-25 20:00:33 UTC
I have the same problem with an exchange 2007 with the same error as comment
#23 from Sami Lavikko
Comment 26 Vitaly Repin 2009-11-25 20:48:22 UTC
Guys, could somebody take the logs from the device and attach them to this bug?

The first stem:  

1) install syslog and reboot
2) open xterm
[optional steps begin]
2A.  sudo gainroot
2B. cat /dev/null > /var/log/syslog
[optional steps end]
3) Issue the folloiwng commands:
      gconftool-2 -s --type=int /apps/activesync/AsDaemon/Syslog/MinLogLevel 0
      gconftool-2 -s --type=int /apps/activesync/modest/Syslog/MinLogLevel 0
      gconftool-2 -s --type=int /apps/activesync/AsProvider/Syslog/MinLogLevel
0
      gconftool-2 -s --type=int /apps/activesync/AsBackup/Syslog/MinLogLevel 0
      gconftool-2 -s --type=int /apps/activesync/asapplet/Syslog/MinLogLevel 0
      gconftool-2 -s --type=int
/apps/activesync/AsStatusApplet/Syslog/MinLogLevel 0
3) attach /var/log/syslog from the device to this bug
Comment 27 Kyle Cronan 2009-11-25 22:12:32 UTC
Created an attachment (id=1630) [details]
syslog with server m.google.com
Comment 28 Kyle Cronan 2009-11-25 22:13:37 UTC
You forgot to mwntion that /var/log/syslog is initially equivalent to
/dev/null.  You have to delete it first.

I've attached my log from trying to do an MfE account setup with Google
(m.google.com).
Comment 29 Sami Lavikko 2009-11-26 02:06:13 UTC
Created an attachment (id=1632) [details]
Syslog of the situation with a ms exchange 2003 server
Comment 30 Bruno (GIP) 2009-11-26 12:55:58 UTC
Hi,
I am just newbie to install syslog in the N900. Is there any wiki to install it
step by step on it ?
I will post after my log.
Thnaks.
Comment 31 Bruno (GIP) 2009-11-26 14:00:56 UTC
Created an attachment (id=1633) [details]
Logfile from Active Sync to Exchange 2007

See attached my logfile.
Comment 32 Andre Klapper maemo.org 2009-11-26 15:53:36 UTC
So, to clarify:

Comment 27 is about Google.
Comment 31 is about Exchange 2007.
Original report is about Exchange 2003.

You all face the same issue described here?

Please note that Exchange 2003 and Google are NOT officially supported by Mail
for Exchange currently, while Exchange 2007 IS officially supported.
Comment 33 Andre Klapper maemo.org 2009-11-26 15:54:05 UTC
About Google please also see bug 6140.
Comment 34 Vitaly Repin 2009-11-26 16:02:56 UTC
(In reply to comment #31)
> Created an attachment (id=1633) [details] [details]
> Logfile from Active Sync to Exchange 2007

> See attached my logfile.

Thanks a lot. Your server uses the protocol 12.0, not 12.1.  This is the reason
why you have this problem.  Quite shity.  

The only workaround I can suggest for now - to ask your admin to upgrade the
server so it will support 12.1.  If you have this option :-(

Andre, could you export this case (with log) to maemo internal bugzilla? We
need to track it there.
Comment 35 Vitaly Repin 2009-11-26 16:05:05 UTC
(In reply to comment #29)
> Created an attachment (id=1632) [details] [details]
> Syslog of the situation with a ms exchange 2003 server

Wait for sw. update, pls. :-)

Thanks for the log.
Comment 36 Vitaly Repin 2009-11-26 16:06:58 UTC
(In reply to comment #27)
> Created an attachment (id=1630) [details] [details]
> syslog with server m.google.com

OK.  Known problem with google.  Check here, pls: 
http://talk.maemo.org/showthread.php?t=35136

Thank you for attaching the log.
Comment 37 Uwe Kaminski (reporter) 2009-11-26 18:48:22 UTC
(In reply to comment #32)
> So, to clarify:
> 
> Comment 27 is about Google.
> Comment 31 is about Exchange 2007.
> Original report is about Exchange 2003.
> 
> You all face the same issue described here?
> 
> Please note that Exchange 2003 and Google are NOT officially supported by Mail
> for Exchange currently, while Exchange 2007 IS officially supported.

Excuse me, but this I hear for the first time! This bug is open for several
weeks and I never heard that there will be only support for Exchange 2007.

There are a lot of device specification pages online and I never read something
else than "Exchange support". No version number. One example is this page:
http://shop.nokia.de/nokia-de/product.aspx?sku=6958534&section_id=562&culture=de-DE

And again: On my E52 mobile phone with Mail for exchange everything works fine
with Exchange 2003.

So are you sure that there will be no official support for Exchange 2003?
Comment 38 Vitaly Repin 2009-11-26 19:03:25 UTC
(In reply to comment #37)

> So are you sure that there will be no official support for Exchange 2003?

There will be.  There is no.  Wait for sw. update.  If you want to treat lack
of Exchange 2003 support as a Mfe bug, treat it this way.
Comment 39 Uwe Kaminski (reporter) 2009-11-26 19:10:15 UTC
(In reply to comment #38)
> (In reply to comment #37)
> 
> > So are you sure that there will be no official support for Exchange 2003?
> 
> There will be.  There is no.  Wait for sw. update.  If you want to treat lack
> of Exchange 2003 support as a Mfe bug, treat it this way.

Thank you for the feedback! Now I also read most of the thread in
talk.maemo.org and not any longer confused.
Comment 40 Dart 2009-11-26 19:21:29 UTC
(In reply to comment #38)
> There will be.  There is no.  Wait for sw. update.  If you want to treat lack
> of Exchange 2003 support as a Mfe bug, treat it this way.
> 

The problem is not to treat the lack of Exchange 2003 support as a bug or not,
it's that it is not mentioned anywhere. To my knowledge, and I could be wrong,
there are still more Exchange 2003 servers than 2007.

Do we have any chance to see this bug/lack of support corrected in next
release?
Comment 41 Andre Klapper maemo.org 2009-11-26 19:46:28 UTC
Note: This report is about EXCHANGE **2003** SUPPORT which is currently not
officially supported.
As Quim wrote, support will definitely be provided by an update.

I have moved the report about the same outcome with EXCHANGE **2007** to bug
6345. Feel free to CC yourself on bug 6345 if you are interested in 2007.


(In reply to comment #34)
> Andre, could you export this case (with log) to maemo internal bugzilla?

@Vitaly: Sure - I have imported bug 6345. See the Alias field in that report...
Comment 42 Andre Klapper maemo.org 2009-11-27 13:22:37 UTC
(In reply to comment #40)
> Do we have any chance to see this bug/lack of support corrected in next
> release?

Comment 38 clearly says: "Wait for software update". Nobody knows if it's the
next one. More info will be available once more info is available. :)
Comment 43 Andre Klapper maemo.org 2009-11-27 17:27:25 UTC
(In reply to comment #30)
> Hi,
> I am just newbie to install syslog in the N900. Is there any wiki to install it
> step by step on it ?

Please see http://wiki.maemo.org/Documentation/devtools/maemo5/syslog .
Comment 44 massimo.bilvi 2009-11-30 20:31:23 UTC
I don't know if can be useful but I checked my syslog and I receive from the
server an HTTP error 403. I have attached my syslog on bug #6345 because it's a
MS Exchange 2007 server.
Comment 45 Javier Inclan 2009-12-01 19:27:13 UTC
I have a similar problem with the N900. I get a message "Account Dissabled.
Access denied". I know this is not true since my account works perfectly with
my nokia E90. Also my IT people checked and all is ok so, it is a Nokia N900
problem. We use Exchange 2003 and do not plan on going to 2007 until there is
no suppor for 2003.
Comment 46 massimo.bilvi 2009-12-01 20:44:27 UTC
(In reply to comment #45)
> I have a similar problem with the N900. I get a message "Account Dissabled.
> Access denied". I know this is not true since my account works perfectly with
> my nokia E90. Also my IT people checked and all is ok so, it is a Nokia N900
> problem. We use Exchange 2003 and do not plan on going to 2007 until there is
> no suppor for 2003.
> 

See my comments on bug 6345. Have you checked if the server allows
non-provisionable devices?
Comment 47 Javier Inclan 2009-12-02 21:56:38 UTC
(In reply to comment #46)
> (In reply to comment #45)
> > I have a similar problem with the N900. I get a message "Account Dissabled.
> > Access denied". I know this is not true since my account works perfectly with
> > my nokia E90. Also my IT people checked and all is ok so, it is a Nokia N900
> > problem. We use Exchange 2003 and do not plan on going to 2007 until there is
> > no suppor for 2003.
> > 
> See my comments on bug 6345. Have you checked if the server allows
> non-provisionable devices?

No, I will verify this with my IT people. There is one thing that they did tell
me that came to my attention and that is that they plan to move not to exchange
2007 but to 2010. Does anyone know if 2010 is supported? or will it be the same
problem. If we are moving this way, I am sure I am not the only company
thinking along these lines.
Comment 48 Vitaly Repin 2009-12-02 22:16:46 UTC
(In reply to comment #47)

> Does anyone know if 2010 is supported? 

http://talk.maemo.org/showthread.php?t=34981
Comment 49 Javier Inclan 2009-12-03 19:54:27 UTC
My German IT do not understand what you mean by Non provisional devices. Could
anyone explain a bit more.
Comment 50 Vitaly Repin 2009-12-03 20:15:08 UTC
(In reply to comment #49)
> My German IT do not understand what you mean by Non provisional devices. Could
> anyone explain a bit more.

http://technet.microsoft.com/en-us/library/bb123484.aspx
Comment 51 corwin 2009-12-04 09:48:28 UTC
Just for the record: Same issue with the first Sync on Exchange 2003 here.
Embarrassing detail: Colleagues with PREs and DROIDs have it working out of the
box ;)
Comment 52 Steve Tierney 2009-12-07 11:12:54 UTC
Same issue here for Ex2K3 Server.
Comment 53 redonj 2009-12-08 16:13:26 UTC
Gentlemen
I use my N900 for working purposes. I need to sync with my corporative server
with Exchange 2003. Can you tell me when are going to solve this problem?
Thanks.
Comment 54 Andre Klapper maemo.org 2009-12-08 16:26:48 UTC
(In reply to comment #53)
> I use my N900 for working purposes. I need to sync with my corporative server
> with Exchange 2003. Can you tell me when are going to solve this problem?

Probably like every other software issue: By writing or correcting some code.
:-D
As written here, it is not supported currently. All that is known is written in
this report already. Hence for future reference, http://talk.maemo.org is a
good place for non-technical talk about this.
Comment 55 Andre Klapper maemo.org 2009-12-08 16:35:46 UTC
Sigh. I should learn reading ("when", not "how"), sorry... :-/
Target Milestone is set, but a fix has not been committed yet. That's all.
Comment 56 Andre Klapper maemo.org 2009-12-09 12:33:27 UTC
This has been fixed in the internal build version
2.2009.49-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
For your information, Nokia does not announce release dates of updates in
advance.
Comment 57 corwin 2009-12-09 12:57:36 UTC
Thanks Andre, good to hear!
Would love to test, any chance to get the update?
Comment 58 Andre Klapper maemo.org 2009-12-09 13:05:40 UTC
(In reply to comment #57)
> Would love to test, any chance to get the update?

See bug 5709...
Comment 59 redonj 2009-12-09 13:28:33 UTC
Yes please!! I need it for my work.
Thanks
Comment 60 jonoden 2009-12-09 15:49:49 UTC
With this fix does the server still need to allow non-provisionable devices?
Comment 61 redonj 2009-12-09 17:04:25 UTC
Ok, I saw the bug 5709, but I don’t understand. How can I get the update?
Sorry fellows I’m not a technician, just a user…… Thanks a lot.
Comment 62 Andre Klapper maemo.org 2009-12-09 19:56:26 UTC
(In reply to comment #61)
> Ok, I saw the bug 5709, but I don’t understand. How can I get the update?
> Sorry fellows I’m not a technician, just a user…… Thanks a lot.

The explanation is not technical at all. Feel free to send me a private email
if it's not understandable. In short: Wait. And feel free to vote in
Brainstorm.

(In reply to comment #60)
> With this fix does the server still need to allow non-provisionable devices?

There is a separate bug report about that and it is in an OPEN state.
This should really answer the question. Feel free to CC.
Comment 63 kcman123 2009-12-10 00:21:06 UTC
So basically we are all waiting for a firmware update is that it to fix this
Exchange 2003 issue?  I hope so! :(
Comment 64 Andre Klapper maemo.org 2009-12-10 00:41:12 UTC
(In reply to comment #63)
> So basically we are all waiting for a firmware update

It's really not helpful to post the same stuff again and again, and by doing
that creating bugmail for all people CC'ed on this report.
This is not a forum, but a bugtracker.

So, see comment 56, see comment 58.
I don't know what other words are needed to repeat the same statements again.
If my English is incomprehensible, feel free to complain by private email to
me. :-P
Comment 65 Lex de Jonge 2009-12-12 21:11:40 UTC
Hi all,
Because Exchange 2003 support was not in the original release, this is not a
bug……….. ok I can live with that statement, but none of the nokia sites
(nokia.nl, nokia.com, nokia.de, nokia.co.uk)
http://www.nokiausa.com/find-products/phones/nokia-n900/specifications mentions
the lake of Exchange 2003 support therefore Nokia mismanaged the expectations
of her customers and should bugfix the problem with high priority instead of
letting us wait for the next update (maybe end of 2009………….. maybe…………)
Br
Lex
Comment 66 kcman123 2009-12-15 04:00:52 UTC
I called Nokia Tech support today about this issue to see about if there were
any new updates?
The tech responded on setting the active sync protocol on your exchange server
to "public"?  Has anyone tried this or know what he is exactly saying?

The nokia tech representative also mentioned that the software update is
actually going to be released mid january.  So are the rumors of software
updates releasing around christmas false?
Comment 67 Andre Klapper maemo.org 2009-12-15 13:44:22 UTC
(In reply to comment #66)
> The nokia tech representative also mentioned that the software update is
> actually going to be released mid january.  So are the rumors of software
> updates releasing around christmas false?

Please definitely go to talk.maemo.org for this. It's offtopic here. Thanks!
Comment 68 Uwe Kaminski (reporter) 2009-12-23 23:57:50 UTC
Synchronization between N900 ans MS Exchange 2003 Server works fine in
2.2009.51-1.
Comment 69 Andre Klapper maemo.org 2009-12-28 14:21:19 UTC
(Restoring Version field as Version field is meant for the still-buggy version)
Comment 70 Moin 2009-12-30 07:22:13 UTC
hey. am facing this problem too (Mail for Exchanges giving error with Exch 2003
and N900). kindly notify me of a fix as and when it is available.
Comment 71 Andre Klapper maemo.org 2009-12-30 10:54:12 UTC
(In reply to comment #70)
> hey. am facing this problem too (Mail for Exchanges giving error with Exch 2003
> and N900). kindly notify me of a fix as and when it is available.

Please avoid adding such unhelpful comments and just silently add yourself to
the CC list if you want to get notifications. This is how a bugtracker works.
Comment 72 Andre Klapper maemo.org 2010-01-14 12:25:59 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 73 Javier Inclan 2010-01-14 23:10:55 UTC
I updated to the new version 2.2009.51-1.002 and the problem remains. I still
get the error message "Exchange account dissabled. Access refused" and now I
have and additional message after that one that says " erorr in communication
with exchange server". I know it is not my company or my password, etc.. and
YES we are also set as public. This has to be so embarrassing for Nokia as a
whole.(In reply to comment #72)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
Comment 74 Vitaly Repin 2010-01-14 23:29:27 UTC
(In reply to comment #73)
> I updated to the new version 2.2009.51-1.002 and the problem remains. I still
> get the error message "Exchange account dissabled. Access refused" and now I
> have and additional message after that one that says " erorr in communication
> with exchange server". 

Could you take the logs as described here:
http://wiki.maemo.org/Mail_for_Exchange#How_can_I_turn_the_logging_ON_or_OFF.3F

It would be beneficial to understand the root cause.

Pls, make sure that the logs do not contain any data which you treat as a
personal.
Comment 75 mike 2010-01-15 01:02:36 UTC
(In reply to comment #72)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

I have the same problem as Javier Inclan...

will not let me do first sync. worked on iphone before.
Comment 76 bgetter 2010-01-15 02:19:08 UTC
(In reply to comment #72)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

For what it's worth, the 51-1 update worked fine for me against my Exchange
2003 Server.
Comment 77 bugs.maemo.org@falkensweb.com 2010-01-15 11:21:59 UTC
51-1 update has not enabled the first sync to Google to work for me. I am going
to attach syslogs shortly.

Re-open ?
Comment 78 bugs.maemo.org@falkensweb.com 2010-01-15 12:08:25 UTC
Created an attachment (id=1988) [details]
Initial sync log after the 51-1 update
Comment 79 bugs.maemo.org@falkensweb.com 2010-01-15 12:08:37 UTC
When setting up the account, all went well.
First progress bar filled all the way up, 2nd one got almost to end then big
pause, then both the popup errors others have seen. 

Log attached.
Comment 80 John Steele Scott 2010-01-15 12:29:41 UTC
Created an attachment (id=1989) [details]
Syslog of failed initial sync after PR1.1 update.

Here's another log of a failed first attempt to sync with my corporate exchange
server. I've censored the domain name, my IMEI and a couple of hex numbers near
"password". Apart from that it's complete.
Comment 81 bugs.maemo.org@falkensweb.com 2010-01-15 12:38:06 UTC
I see some similarities between the two most recent logs, lines like:
 activesync[1444]: AS-PERF: Transfered 0 bytes in 91 seconds. Transfer rate is
0 Kb/sec
and
 activesync[1444]: CurlConnectionManager: sendReceive attempt 3: CancelErr=901

occur in both.
Comment 82 Andre Klapper maemo.org 2010-01-15 13:19:53 UTC
(In reply to comment #77)
> 51-1 update has not enabled the first sync to Google to work for me.

How is this related to this bug report about Exchange 2003 servers?
Comment 83 Moin 2010-01-15 13:38:34 UTC
Thanks. My N900 works perfectly fine with Microsoft Exchange 2003.
Comment 84 bugs.maemo.org@falkensweb.com 2010-01-15 15:10:32 UTC
@Andre Klapper: Because Google is using the Exchange 2003 interface :
http://m.google.com/sync "Google Sync uses the Microsoft® Exchange ActiveSync®
protocol" or read through much of the google results for 'google exchange sync'
which consistantly use the 'exchange sync' feature of various platforms.

I realise the bug title  here is misleading. You'll note this bug has always
been about 'real' Exchange2003 and Google's service of same.
Comment 85 Vitaly Repin 2010-01-16 12:24:00 UTC
(In reply to comment #77)
> Re-open ?

No.  Google is a separate issue.  Different from Exchange 2003.

Check this pls: http://wiki.maemo.org/Mail_for_Exchange#PR_1.1_2  and this:
http://talk.maemo.org/showpost.php?p=393019&postcount=1
Comment 86 John Steele Scott 2010-01-18 01:40:11 UTC
(In reply to comment #85)
> (In reply to comment #77)
> > Re-open ?
> 
> No.  Google is a separate issue.  Different from Exchange 2003.

Vitaly, could you have a look at my attachment 1989 [details]? This is a regular
corporate Exchange server as far as I know. If I login to webmail I'm looking
at "Outlook Web Access", not Gmail.
Comment 87 bugs.maemo.org@falkensweb.com 2010-01-18 14:47:52 UTC
@Vitaly Repin
Are you saying I should be reporting on a different (new) bug ? If you're doing
so in an official capacity, please say so, otherwise I consider this bug still
valid, as both MS and Google are meant to be using the same '2003' protocol
(though different impls, if I quickly read OK).
Comment 88 Vitaly Repin 2010-01-18 17:01:16 UTC
(In reply to comment #87)
> @Vitaly Repin
> Are you saying I should be reporting on a different (new) bug ? If you're doing
> so in an official capacity, please say so, otherwise I consider this bug still
> valid, as both MS and Google are meant to be using the same '2003' protocol
> (though different impls, if I quickly read OK).

Google supports 12.0 and 2.5 protocols.  12.0 is the protocol which is not
supported by Exchange 2003.  Google and Exchange 2003 support are totally
different issues.  Let us not mix them here.  

This bug is about Exchange 2003 and that's it.

Give us time to analyze the logs for Exchange 2003 which you have attached.
Comment 89 Javier Inclan 2010-01-29 23:24:25 UTC
Hello, I still can not use exchange 2003. Any news ?
Comment 90 Tomas Westerholm 2010-02-03 14:50:29 UTC
(In reply to comment #89)
> Hello, I still can not use exchange 2003. Any news ?
> 
Hello, same here. Firmware 51-1 won't connect to company Exchange 2003.
Uptodate E90 phone works fine with same account.

BR Tomas Westerholm
Comment 91 Andre Klapper maemo.org 2010-02-09 01:48:04 UTC
(In reply to comment #90)
> Hello, same here. Firmware 51-1 won't connect to company Exchange 2003.

Tomas: Please see http://wiki.maemo.org/Bugs:Stock_answers#Mail_for_Exchange
and file a separate report. Thanks.
Comment 92 BarneyB 2010-06-29 13:16:46 UTC
just thought that this may be useful in our quest to fix this issue :-)  :

http://wiki.novell.com/index.php/Data_Synchronizer_Mobility_Setup_Nokia_N900

and this. n900 info is a little down in the nokia section :

http://wiki.novell.com/index.php/Data_Synchronizer_Mobility_Connector_Devices#Nokia

hope this helps

cheers
Comment 93 Andre Klapper maemo.org 2010-06-29 14:08:32 UTC
(In reply to comment #92)
> just thought that this may be useful in our quest to fix this issue :-)

This issue has been fixed for months and your comment is unrelated.
Comment 94 BarneyB 2010-06-29 15:13:30 UTC
so where is the fix documented then please?
Comment 95 Andre Klapper maemo.org 2010-06-29 15:22:53 UTC
(In reply to comment #94)
> so where is the fix documented then please?

Exchange 2003 support was added for PR1.1 (2.2009.51-1) hence this issue was
fixed (See comment 56). What does "the fix documented" exactly mean?