Bug 5593 (int-133842)

Summary: Contacts re-appear in list after disabling and re-enabling accounts
Product: [Maemo Official Applications] Contacts Reporter: Jeroen Wouters <woutersj>
Component: GeneralAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: contacts-bugs
Severity: major    
Priority: Medium CC: andre_klapper, mikhail.zabaluev, turist
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Linux   

Description Jeroen Wouters (reporter) 2009-10-19 15:11:38 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Enable Skype account (#1)
2. Merge a Skype username for account #1 in the contact list to another contact
(e.g. merge the john1978 to the John Smith contact) 
3. Disable Skype account #1
4. Enable another Skype account (#2)
5. Disable account #2
6. Enable account #1 again

I guess it is the some for other types of accounts, but I encountered it with a
Skype account.

EXPECTED OUTCOME:
The account name does not appear in the main list, but is hidden, since it is
already attached to a contact.

ACTUAL OUTCOME:
The account name appears again in the main list of contacts, as well as under
the contact's details.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Mikhail Zabaluev nokia 2009-10-19 17:18:44 UTC
Known problem, must fix.
Comment 2 Mikhail Zabaluev nokia 2009-10-19 17:24:13 UTC
Correction: it's actually fixed, coming in a future update.
Comment 3 Andre Klapper maemo.org 2009-10-26 12:48:29 UTC
Fixed in internal week 42 build.
Any public update released with or after this build version (x.2009.42-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Mikhail Zabaluev nokia 2009-10-26 16:25:10 UTC
(In reply to comment #3)
> Any public update released with or after this build version (x.2009.42-y) will
> include the fix.

Correction: the 1.2009.* builds will most likely not include it.
Comment 5 Andre Klapper maemo.org 2009-11-16 14:03:56 UTC
Please note that the fix for this issue is NOT included in the final Maemo5
version 1.2009.42-11 that was released today.
The fix will be included in the next update after 1.2009.42-11.
Comment 6 Andre Klapper maemo.org 2009-11-30 15:52:41 UTC
*** Bug 6426 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:01 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 Jeroen Wouters (reporter) 2010-01-14 19:51:08 UTC
I can confirm it is fixed.