Bug 5545 (int-141848)

Summary: Artifacts (visual noise) when tapping screen in Screen Calibration
Product: [Maemo Official Applications] Settings and Maintenance Reporter: Bernard Schendstok <bernard>
Component: Control panelAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: control-panel-bugs
Severity: normal    
Priority: Low CC: andre_klapper, maemo
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Bernard Schendstok (reporter) 2009-10-17 17:05:53 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
goto "settings-> Screen calibration"

EXPECTED OUTCOME:

ACTUAL OUTCOME:
When tapping on the screen (on the small targets or somewhere else) in the
calibration application small white lines appear through the text in the middle
of the screen.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14)
Gecko/2009090216 Linux Mint/6 (Felicia) Firefox/3.0.14
Comment 1 Andre Klapper maemo.org 2009-10-19 17:38:36 UTC
Thanks for reporting this!
Confirmed.
Comment 2 Bernard Schendstok (reporter) 2009-10-20 01:30:03 UTC
I noticed similar artifacts when using the pdf reader:
-goto More...> PDF reader
-open the "maemo_software_copyright" file in the Documents folder
-goto full screen mode (lower right icon)
-use the arrows on the hardware keyboard to scroll up and down (press up two
times for example)

you will notice that the "full screen" toggle icon on the lower right gets
similar lines through the icon. (or is this a different bug?)
Comment 3 Andre Klapper maemo.org 2009-10-20 10:55:11 UTC
(In reply to comment #2)
> (or is this a different bug?)
That is a different bug (and a WONTFIX according to int-121867)...
Comment 4 Lucas Maneos 2009-10-28 11:56:02 UTC
I'm also seeing this in various third-party apps (for example EightyOne, GPE
Sudoku and a self-compiled claws-email).

So I think the PDF reader one is related, and the real bug is probably at some
lower level.  Even if it's WONTFIX some documentation on how developers can
avoid it would be welcome.
Comment 5 Lucas Maneos 2009-11-17 03:16:42 UTC
This looks completely (including the cases in comment 2 and comment 4) FIXED to
me in 1.2009.42-11.
Comment 6 Andre Klapper maemo.org 2009-11-17 22:59:32 UTC
This has been fixed in the internal build version 2.2009.46-16.
(Note that 2009 is the year and the number after is the week.)

The internal ticket actually refers to several places in the User Interface
where this happens - this specific issue seems to be fixed in week 42, but all
issues should be fixed by week 46.

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:26:47 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.