Bug 5527 (int-143614)

Summary: Page is not rerendered when JavaScript actions increase page length
Product: [Maemo Official Applications] Browser Reporter: Ryan Abel <rabelg5>
Component: MicroB engineAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: microb-bugs
Severity: minor    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   
URL: http://talk.maemo.org

Description Ryan Abel (reporter) maemo.org 2009-10-17 07:04:44 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Open the browser.
2. Navigate to a page with JavaScript functions that increase page length
(talk.maemo.org Thanks! work nicely).
3. Activate one of these functions.
4. Scroll

EXPECTED OUTCOME:
Page is rerendered properly offscreen so rendering doesn't mess up when
scrolling.

ACTUAL OUTCOME:
Page is not rerendered and instead renders as you scroll which results in
obnoxious text adjustments.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Thanking a Thankless post on Talk then scrolling is an effective way to trigger
this bug.

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.15 RX-51 N900
Comment 1 Andre Klapper maemo.org 2009-10-19 15:42:29 UTC
I see this sometimes, but not always on talk.maemo.org.

Do you know the exact javascript command? Makes it easier to query...
Comment 2 Ryan Abel (reporter) maemo.org 2009-10-19 18:43:29 UTC
(In reply to comment #1)
> Do you know the exact javascript command? Makes it easier to query...
> 

No idea.
Comment 3 Andre Klapper maemo.org 2009-11-19 16:52:25 UTC
This has been fixed in package
microb-eal 2.5.11.5-1+0m5
which is part of the internal build version
2.2009.46-9
(Note that 2009 is the year and the number after is the week.)

It definitely works fine for me in 2.2009.47-18.

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:30:02 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.