Bug 5518 (int-144001)

Summary: Bluetooth DBUS UI dialogs - wrong args in the example code
Product: [Maemo Official Platform] Connectivity Reporter: Valério Valério <vdv100>
Component: BluetoothAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: bluetooth-bugs
Severity: normal    
Priority: Low CC: andre_klapper, dneary
Version: 5.0/(1.2009.41-10)Keywords: docs
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   
URL: http://wiki.maemo.org/Documentation/Maemo_5_Developer_Guide/Using_Connectivity_Components/Maemo_Connectivity#Bluetooth_DBUS_UI_dialogs

Description Valério Valério (reporter) maemo.org 2009-10-16 18:32:49 UTC
SOFTWARE VERSION:
ND

STEPS TO REPRODUCE THE PROBLEM:

Go to:
http://wiki.maemo.org/Documentation/Maemo_5_Developer_Guide/Using_Connectivity_Components/Maemo_Connectivity#Bluetooth_DBUS_UI_dialogs

EXPECTED OUTCOME:

The the second d-bus example should be:

dbus-send --system --print-reply \
    --dest=com.nokia.bt_ui  /com/nokia/bt_ui 
    com.nokia.bt_ui.show_search_dlg \
    string: string: array:string: string:

ACTUAL OUTCOME:

dbus-send -system -print-reply \
    -dest=com.nokia.bt_ui  /com/nokia/bt_ui 
    com.nokia.bt_ui.show_search_dlg \
    string: string: array:string: boolean:true

The last argument of the d-bus call should be a String.
From the code comments/doc:

"bonding: DBUS_TYPE_STRING"

This affects the diablo documentation and the example inside "libconbtui_1.4.1"
package as well.

Also in both d-bus examples is used only one "-" the d-bus call won't work that
way, should be "--" as exemplified above.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Andre Klapper maemo.org 2009-10-19 15:32:15 UTC
And now I wonder whether I can just quickly edit the wiki and fix this, or if
it is not the primary source and an edit would get overwritten later on.

Dave?
Comment 2 Dave Neary maemo.org 2009-10-19 16:29:20 UTC
You can edit the wiki, changes made in the wiki will be integrated into the
official sources.

Ideally, if any edits are needed before integrating, they will also get made in
the wiki.

Dave.
Comment 3 Valério Valério (reporter) maemo.org 2009-10-19 20:09:19 UTC
Please note that this bug also affects the example code inside the
"libconbtui_1.4.1" package.
Comment 4 Andre Klapper maemo.org 2009-11-24 14:16:18 UTC
This has been fixed in package
libconbtui 1.4.2+0m5
which is part of the internal build version
2.2009.47-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:04 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.