Bug 5517

Summary: Segmentation fault after Settings --> choose theme
Product: [Extras] Canola Reporter: Uwe Kaminski <jukey>
Component: SettingsAssignee: Eduardo Lima (Etrunko) <eblima>
Status: VERIFIED FIXED QA Contact: general-bugs
Severity: critical    
Priority: Low CC: andrei.mirestean, archebyte, jukey
Version: unspecified   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   
Attachments: Testing package
Testing package

Description Uwe Kaminski (reporter) 2009-10-16 18:31:36 UTC
SOFTWARE VERSION:
canola2 RC4 on latest OS version for the N900.

STEPS TO REPRODUCE THE PROBLEM:
0. Install all of the themes available in the extras-devel repository.
1. Start canola
2. Choose the Settings icon in the lower right corner --> settings menu is
comming up
3. Choose "Choose theme" from the menu.

EXPECTED OUTCOME:
I should be able to select the themes which are installed.

ACTUAL OUTCOME:
Canola closes itself immediately. Running it with command "canola -vvv" shows
that there is a segmentation fault.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Only canola2 and the themes are installed
Comment 1 Eduardo Lima (Etrunko) maemo.org 2009-10-19 23:20:37 UTC
There are a few others points where it crashes. All of them when accessing
either Settings or Options. Some that I found:

Settings/Internet Media/Download Folder
My Photos/Full Screen View/Options/Slideshow Time

Can't tell exactly what it is right now, but it looks like something related to
the ancient and unmaintained Etk library which we use on Settings and Options.

On the other hand, it only crashes on Fremantle, while on Diablo and Chinook
don't. Need to investigate a bit further, I may also be something related to
optimization flags we use during compilation of the EFL modules written in C.
Comment 2 mustali 2009-12-11 23:37:17 UTC
Confirmed on canola2 2.0.0-maemo1 from extras-testing
-Install canola2 (no additional themes installed)
-Start application.
-Applicatioin exits after selecting Choose Theme.

 $ canola
1260566940.1045 ERROR connection:218:maybe_handle_message() Exception in
handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.5/dbus/connection.py", line 214, in
maybe_handle_message
    self._handler(*args, **kwargs)
TypeError: _update_battery_level() takes exactly 2 arguments (3 given)
Segmentation fault
Comment 3 Eduardo Lima (Etrunko) maemo.org 2009-12-14 21:50:16 UTC
*** Bug 6874 has been marked as a duplicate of this bug. ***
Comment 4 Andrei Mirestean 2010-05-19 16:08:47 UTC
The bug was actually in the python-terra package. 

The commit:
http://code.openbossa.org/projects/python-terra/repos/andrei1089-clone/commits/9eb1f46ddd762dc667b32433b3cb4552ffb5fb06
will fix it.
Comment 5 Eduardo Lima (Etrunko) maemo.org 2010-05-19 16:15:55 UTC
(In reply to comment #4)
> The bug was actually in the python-terra package. 
> 
> The commit:
> http://code.openbossa.org/projects/python-terra/repos/andrei1089-clone/commits/9eb1f46ddd762dc667b32433b3cb4552ffb5fb06
> will fix it.
>

Still can't understand why the crash happens on N900 hardware _only_. Not
reproductible neither on PC nor N8x0.

Still can't believe the solution for this bug was so simple. Thank you very
much. :)
Comment 6 Eduardo Lima (Etrunko) maemo.org 2010-05-19 17:59:10 UTC
Patch integrated to mainline. Closing as fixed.
Comment 7 Eduardo Lima (Etrunko) maemo.org 2010-05-19 18:03:49 UTC
Created an attachment (id=2726) [details]
Testing package

Please download the package, install it manually (dpkg -i) and test so we can
mark this bug as VERIFIED. Thanks.
Comment 8 Uwe Kaminski (reporter) 2010-05-20 10:31:32 UTC
Thank you too. I can verify that canola does not longer crash if I try to
reproduce this bug. On the other hand now nothing happens if I select a
different theme but I will fill a seperate bug for this issue.
Comment 9 Andrei Mirestean 2010-05-20 15:24:12 UTC
(In reply to comment #8)
> Thank you too. I can verify that canola does not longer crash if I try to
> reproduce this bug. On the other hand now nothing happens if I select a
> different theme but I will fill a seperate bug for this issue.
> 
There's a bug in the patch, the new bug is related to the patch. I'll fix it
and submit a new deb asap.
Comment 10 Andrei Mirestean 2010-06-01 00:05:40 UTC
Created an attachment (id=2794) [details]
Testing package
Comment 11 Andrei Mirestean 2010-06-01 00:08:29 UTC
(From update of attachment 2794 [details])
Fix the previous package which introduced a new bug
(https://bugs.maemo.org/show_bug.cgi?id=10215).
Comment 12 Uwe Kaminski (reporter) 2010-06-01 16:01:01 UTC
Works very well now :)