Bug 5415 (int-139448)

Summary: Contact widgets move to active desktop after merge
Product: [Maemo Official Applications] Desktop Widgets Reporter: Jeroen Wouters <woutersj>
Component: ContactsAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: speed-contacts-bugs
Severity: normal    
Priority: Low CC: andre_klapper, donn.morrison, emanuele.cassioli, maemo, tenea.bogdan, zaheermerali
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Linux   

Description Jeroen Wouters (reporter) 2009-10-13 22:48:45 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Add a contact to a desktop
2. Switch to a different desktop
3. Merge another contact to the contact whose widget is on the desktop

EXPECTED OUTCOME:
Contacts are merged and the widget remains on the desktop it was placed on.

ACTUAL OUTCOME:
Contacts are merged and the widget moves to the desktop active while merging.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.15 RX-51 N900
Comment 1 Andre Klapper maemo.org 2009-10-14 01:54:54 UTC
(In reply to comment #0)
> 3. Merge another contact to the contact whose widget is on the desktop

What are the exact steps to do this?
Comment 2 Jeroen Wouters (reporter) 2009-10-14 11:29:14 UTC
3. Merge another contact to the contact whose widget is on the desktop:

3.1 Open the Contacts application
3.2 Select the contact thas has a desktop widget
3.3 Select 'Merge contact' from the menu
3.4 Select any other contact to be merged with the selected contact
Comment 3 Donn Morrison 2009-10-15 12:46:15 UTC
I can confirm this bug. After merging a contact, I noticed that contact
switched from the desktop I had originally placed it on to the current desktop.
Comment 4 Andre Klapper maemo.org 2009-10-15 17:05:21 UTC
Confirming as per second comment. Thanks for clarifying the steps!
Comment 5 thomas 2009-10-15 17:07:09 UTC
i can also confirm this bug. and finally i understand why my desktop repeatedly
got so mixed up, thanks! :)
Comment 6 zaheer merali 2009-10-17 01:47:55 UTC
also confirmed
Comment 7 Andre Klapper maemo.org 2009-11-04 12:10:34 UTC
This has been fixed in package
libosso-abook 4.20091030+0m5
which is part of the internal build version
2009.45-8
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 8 Andre Klapper maemo.org 2009-12-14 19:19:47 UTC
*** Bug 6941 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-01-14 12:27:52 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 10 EC 2010-01-14 12:34:18 UTC
This is VERIFIED, the fix works well.