Bug 5413 (int-134975)

Summary: microb doesn't trigger onchange
Product: [Maemo Official Applications] Browser Reporter: timeless
Component: MicroB engineAssignee: tuukka.tolvanen
Status: RESOLVED FIXED QA Contact: microb-bugs
Severity: normal    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: All   
Attachments: testcase

Description timeless (reporter) 2009-10-13 22:41:11 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. find an evil site that builds a state machine
2. tap into a text field
3. change the text field
4. tap out of the text field

EXPECTED OUTCOME:
at 4 the 'change' event should fire in order to allow for the 'blur' event to
do something useful

ACTUAL OUTCOME:
the 'change' event isn't fired, which results in the 'blur' event messing up

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
a link to an evil web service

OTHER COMMENTS:
the web service is evil and should be fixed. oh and there's an html5 proposal
for a field property to prevent web services from writing evil code like this:

http://www.whatwg.org/specs/web-apps/current-work/multipage/common-input-element-attributes.html#attr-input-placeholder

Sadly, some evil web pages exist. Hopefully our customers won't encounter them,
since the page is designed just for us....
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en;
rv:1.9.0.15pre) Gecko/2009091516 Camino/2.0b4 (like Firefox/3.0.15pre)
Comment 1 timeless (reporter) 2009-10-13 22:42:50 UTC
Created an attachment (id=1418) [details]
testcase

Note that from memory this was a design decision. So, we might fix this by
documenting it and then yelling at the site in question. Or we might spend
months trying to add more code ....

Yelling at the site in question seems exciting and might be easier (although,
having tried to yell at them for around a year, i have had a perfect failure
rate so ...)
Comment 2 timeless (reporter) 2009-10-14 15:00:18 UTC
fwiw, this also affects twitter's ability to tell you how many characters you
csn type bwfore hitting its limit.

it turns out this was reported internally in late august and fixed near the end
of september. as usual, it missed the first boat.

given it affects a major site, hopefully it'll make the next one.
Comment 3 Andre Klapper maemo.org 2009-11-10 12:16:38 UTC
This has been fixed in internal build version
2009.46-2
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:30:01 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.