Bug 5409 (int115957/int-166107)

Summary: Cannot send empty SMS
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Lennart Poettering <lennart>
Component: MessagingAssignee: rtcomm <rtcomm>
Status: RESOLVED FIXED QA Contact: im-chat-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, bugzilla, demonminds, kimitake, kostas.pav, lennart, mikhail.zabaluev, naba.kumar, omelfata, zim-xboxlive
Version: 5.0/(1.2009.41-10)   
Target Milestone: Harmattan   
Hardware: N900   
OS: Linux   

Description Lennart Poettering (reporter) 2009-10-13 21:02:45 UTC
N900 Maemo 5, 1.2009.41-10

My telecom company (Hansenet/Alice) can send the GPRS APN/yadda yadda per SMS
to customer if one sends in an empty SMS. Unfortunately the N900 does not allow
me to send an empty SMS. And the bot on the other side does not take non-empty
sms.
Comment 1 Andre Klapper maemo.org 2009-10-14 01:44:21 UTC
The "Write message" popup is not very friendly either. Sigh....

As per internal ticket this is a WONTFIX:
"We don't allow sending of empty sms messages. We consider it more useful to
prevent sending of empty sms messages by accident." even though it is more
complicated to send an empty SMS accidentally on an N900 compared to average
phones.
Comment 2 Lennart Poettering (reporter) 2009-10-14 02:19:54 UTC
(In reply to comment #1)
> The "Write message" popup is not very friendly either. Sigh....
> 
> As per internal ticket this is a WONTFIX:
> "We don't allow sending of empty sms messages. We consider it more useful to
> prevent sending of empty sms messages by accident." even though it is more
> complicated to send an empty SMS accidentally on an N900 compared to average
> phones.

Uh? WONTFIX? Why's that? How am I supposed to send an empty SMS?
Comment 3 Lennart Poettering (reporter) 2009-10-14 02:33:49 UTC
Or are you suggesting that the N900 is not compatible with my mobile provider?
That would suck?
Comment 4 Andre Klapper maemo.org 2009-10-14 13:17:15 UTC
Currently you cannot, and it looks like we have to convince Naba to change
that...
Comment 5 Mikhail Zabaluev nokia 2009-10-14 13:59:02 UTC
Let's rebrand this as an enhancement...
Comment 6 kimitake 2009-11-14 00:08:29 UTC
N900 2..9.42-11
I'm using T-Mobile prepaid in US, and it returns some kind of info when I
sending short codes, e.g. #BAL# (#225#) returns account balance info.

I cannot send this SMS because empty message is not supported on N900.
In addition, if I dial instead of SMS, Phone app shows "Incorrect Number".

If need, I will file the last one above as another bug.
Comment 7 Naba Kumar nokia 2009-11-14 01:17:02 UTC
(In reply to comment #2)
> 
> Uh? WONTFIX? Why's that? How am I supposed to send an empty SMS?
> 
It's unfortunate, but it's even bigger problem if we enable it in n900. Because
of the way conversations are presented, you can literally send empty message
accidentally a lot of time. You open the conversation with the person, and you
click "send" repeatedly. How many empty smses do you think your friend on the
other side should get :).

Anyways, it looks like your service's bot in that specific case seems
unreasonable to error out on non-empty sms. It could easily just ignore the
content. But working around for just that in n900 would be even more
unreasonable IMO.
Comment 8 Naba Kumar nokia 2009-11-14 01:20:09 UTC
(In reply to comment #6)
> N900 2..9.42-11
> I'm using T-Mobile prepaid in US, and it returns some kind of info when I
> sending short codes, e.g. #BAL# (#225#) returns account balance info.
> 
> I cannot send this SMS because empty message is not supported on N900.
> In addition, if I dial instead of SMS, Phone app shows "Incorrect Number".
> 
> If need, I will file the last one above as another bug.
> 
Doing it the call way is the right way. We are aware of the missing feature
(it's called USSD), but fortunately it's still not implemented yet. We plan to
fix it in some release update.
Comment 9 kimitake 2009-11-14 01:25:34 UTC
(In reply to comment #8)
> Doing it the call way is the right way. We are aware of the missing feature
> (it's called USSD), but fortunately it's still not implemented yet. We plan to
> fix it in some release update.
thanks for the input, I found Bug 5357.
https://bugs.maemo.org/show_bug.cgi?id=5357
Comment 10 Lennart Poettering (reporter) 2009-11-14 01:28:15 UTC
(In reply to comment #7)
> (In reply to comment #2)
> > 
> > Uh? WONTFIX? Why's that? How am I supposed to send an empty SMS?
> > 
> It's unfortunate, but it's even bigger problem if we enable it in n900. Because
> of the way conversations are presented, you can literally send empty message
> accidentally a lot of time. You open the conversation with the person, and you
> click "send" repeatedly. How many empty smses do you think your friend on the
> other side should get :).

That's easy to fix. Just do what most modern mailers to these days if you send
a mail with an empty subject: just ask the user. Popup a little box "Hey, you
just tried to send an empty SMS! Are you sure you want to do that?". There's
not much that could be simpler than this.

> Anyways, it looks like your service's bot in that specific case seems
> unreasonable to error out on non-empty sms. It could easily just ignore the
> content. But working around for just that in n900 would be even more
> unreasonable IMO.

Come on. It is a simple fact that various mobile providers have bots that react
on empty SMS. I have that here at O2 Germany, and kimitake had it with T-Mobile
in the US. If you don't allow empty SMS to be sent then you make the N900
incompatible with these mobile networks. The n900 is not even released yet and
this problem became visible on two big networks, you can be sure its going to
be more than that as soon as the device is released...
Comment 11 Naba Kumar nokia 2009-11-14 01:33:26 UTC
(In reply to comment #10)
> 
> Come on. It is a simple fact that various mobile providers have bots that react
> on empty SMS. I have that here at O2 Germany, and kimitake had it with T-Mobile
> in the US.
> 
kimitake had a different problem. You did not make it clear what service it was
for you on O2 network.
Comment 12 Lennart Poettering (reporter) 2009-11-14 01:38:33 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > 
> > Come on. It is a simple fact that various mobile providers have bots that react
> > on empty SMS. I have that here at O2 Germany, and kimitake had it with T-Mobile
> > in the US.
> > 
> kimitake had a different problem. 

Did he? "I cannot send this SMS because empty message is not supported on
N900."

> You did not make it clear what service it was
> for you on O2 network.

Hansenet/Alice is a reseller of O2. I probably should have mentioned that
right-away.
Comment 13 Naba Kumar nokia 2009-11-14 01:49:09 UTC
(In reply to comment #12)
> 
> Did he? "I cannot send this SMS because empty message is not supported on
> N900."
> 
Yes, he did. Please read the following comments. He is not suppose to send
empty messages to dial in USSD codes.

> > You did not make it clear what service it was
> > for you on O2 network.
> 
> Hansenet/Alice is a reseller of O2. I probably should have mentioned that
> right-away.
> 
What I meant it what you used it for. Such as what do you send and what do you
receive.
Comment 14 kimitake 2009-11-14 02:02:37 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > kimitake had a different problem. 
> 
> Did he? "I cannot send this SMS because empty message is not supported on
> N900."
Sorry I confused you.
Actually I have another problem, USSD, but I agree with your idea
of pop-up alert.
Comment 15 Naba Kumar nokia 2009-11-18 10:58:24 UTC
(In reply to comment #0)
> N900 Maemo 5, 1.2009.41-10
> 
> My telecom company (Hansenet/Alice) can send the GPRS APN/yadda yadda per SMS
> to customer if one sends in an empty SMS.

Hi Lennart, could you please give more details on the problem you faced. What
number you dialed and what was the return sms?
Comment 16 Andre Klapper maemo.org 2009-11-18 13:33:37 UTC
One usecase (no idea if the N900 supports it):
1. Get an O2 Sim card via Alice/hansenet Reseller in Germany.
2. Send an empty SMS to 80100.
3. Receive WAP/GPRS access configuration by SMS
4. Confirm it by entering your PIN (if your phone supports that)
5. Have WAP/GPRS access automatically set up (if your phone supports that)
Comment 17 Mikhail Zabaluev nokia 2009-11-18 13:57:26 UTC
(In reply to comment #16)
> One usecase (no idea if the N900 supports it):
> 1. Get an O2 Sim card via Alice/hansenet Reseller in Germany.
> 2. Send an empty SMS to 80100.
> 3. Receive WAP/GPRS access configuration by SMS
> 4. Confirm it by entering your PIN (if your phone supports that)
> 5. Have WAP/GPRS access automatically set up (if your phone supports that)

Well, this one is moot because Fremantle does not support provisioning by SMS.

But I think the general case for this bug is valid, we'll consider its
prioritization internally.
Comment 18 Andre Klapper maemo.org 2009-12-05 02:16:03 UTC
*** Bug 6589 has been marked as a duplicate of this bug. ***
Comment 19 Andre Klapper maemo.org 2010-01-01 22:57:44 UTC
*** Bug 7557 has been marked as a duplicate of this bug. ***
Comment 20 zim-xboxlive 2010-10-08 19:30:49 UTC
Try pressing on the space key, then send. It worked for me.
Comment 21 Andre Klapper maemo.org 2010-12-16 19:17:55 UTC
Fixed for Harmattan - User Interface specification now says:

"Note: empty message is possible to send in sms conversation but not in IM
conversation."
Comment 22 demonminds 2011-06-18 05:51:07 UTC
forbidding empty sms saved me lots of accidental sms. and i really recommend
that you keep this feature.

just add a confirmation screen in case sms is empty.

this will be a very fair solution for all.