Bug 5395

Summary: No rubber-banding effect in the Main "More..." menu (task launcher)
Product: [Maemo Official Platform] Desktop platform Reporter: Tomasz Dominikowski <dominikowski>
Component: HomeAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: HAF QA mailing list <desktop-platform-general-bugs>
Severity: enhancement    
Priority: Low CC: andre_klapper, Edwinem_von_Forresterra
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Linux   

Description Tomasz Dominikowski (reporter) 2009-10-13 17:24:49 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

Go to the main menu, tap More...
Scroll through the menu, you need to have a few more applications than the
standard to see this issue I think.

EXPECTED OUTCOME:

Rubber-banding effect should occur at the end of the list, both at the bottom
and when scrolling up, at the top.

ACTUAL OUTCOME:

Nothing happens, just a standard list with kinetic scrolling. This is
inconsistent UI.

REPRODUCIBILITY:
(always/sometimes/once)

Always.

EXTRA SOFTWARE INSTALLED:

Nothing that would interfere.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Andre Klapper maemo.org 2009-10-13 17:31:36 UTC
Weird, as this works fine for me with exactly the same hardware and software
version. Maybe one or two other persons could test this and comment here?
Comment 2 Tomasz Dominikowski (reporter) 2009-10-13 17:41:21 UTC
Andre, no offence, but are you sure you're not confusing rubber-banding with
kinetic scrolling? I've seen many, many N900 during the summit and none of them
had rubber-banding in the main menu.
Comment 3 Andre Klapper maemo.org 2009-10-13 18:38:23 UTC
Ah, the Bounce effect. No I got it.
Confirming, but it's optional in other cases too, Not everything has that
effect (e.g. textviews generally don't).
Comment 4 Tomasz Dominikowski (reporter) 2009-12-24 11:54:34 UTC
Fixed in PR1.1. :)
Comment 5 Andre Klapper maemo.org 2009-12-28 14:18:03 UTC
True. Thanks for testing. :)
Comment 6 Andrew Flegg maemo.org 2010-01-06 13:33:09 UTC
*** Bug 7698 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:31 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.