Bug 5367 (int-132402)

Summary: Spacebar scrolls more than 1 page
Product: [Maemo Official Applications] Browser Reporter: Ryan Abel <rabelg5>
Component: User interfaceAssignee: tuukka.tolvanen
Status: VERIFIED FIXED QA Contact: browser-bugs
Severity: normal    
Priority: Low CC: andre_klapper, darren.long, sc
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: All   
URL: http://talk.maemo.org
Attachments: Page 1
Page 2
Page 3

Description Ryan Abel (reporter) maemo.org 2009-10-13 11:28:29 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Load a website in the browser that's more than one page long.
2. Press the spacebar.

EXPECTED OUTCOME:
Spacebar should scroll one page or slightly less (keeping a line or two would
be nice).

ACTUAL OUTCOME:
Spacebar scrolls about 1.2x of a vertical page width, making scrolling with the
spacebar useless.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Compare the attached screenshots to the http://talk.maemo.org homepage.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_1; en-US)
AppleWebKit/531.9+(KHTML, like Gecko, Safari/528.16) OmniWeb/v622.10.0
Comment 1 Ryan Abel (reporter) maemo.org 2009-10-13 11:29:47 UTC
Created an attachment (id=1409) [details]
Page 1
Comment 2 Ryan Abel (reporter) maemo.org 2009-10-13 11:31:02 UTC
Created an attachment (id=1410) [details]
Page 2
Comment 3 Ryan Abel (reporter) maemo.org 2009-10-13 11:31:47 UTC
Created an attachment (id=1411) [details]
Page 3
Comment 4 Andre Klapper maemo.org 2009-10-13 20:53:31 UTC
Bah, how ugly. Confirming.
Comment 5 timeless 2009-10-14 03:06:09 UTC
fwiw, this was reported internally in August and a fix was selected in early
September. Sadly, it missed the release boat (which sailed very early for the
Browser because of Flash certification among other problems) and is now waiting
for the first service release boat to open.
Comment 6 Andre Klapper maemo.org 2009-10-19 12:08:11 UTC
Fixed in internal week 42 build.
Any public update released with or after this build version (x.2009.42-x) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2009-11-16 14:03:59 UTC
Please note that the fix for this issue is NOT included in the final Maemo5
version 1.2009.42-11 that was released today.
The fix will be included in the next update after 1.2009.42-11.
Comment 8 timeless 2009-11-29 18:55:59 UTC
*** Bug 6419 has been marked as a duplicate of this bug. ***
Comment 9 timeless 2010-01-05 01:09:37 UTC
*** Bug 7657 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2010-01-14 12:30:00 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.