Bug 5343 (int-144488)

Summary: "More..." applications launcher does't allow scrolling
Product: [Maemo Official Platform] Desktop platform Reporter: Benoît HERVIER <khertan>
Component: Application MenuAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: task-navigator-bugs
Severity: major    
Priority: Medium CC: aapo.rantalainen, andre_klapper, arnims, davidk, jukey, luarvique, maemo, mvartiainen, tim, tmedmonds, tri, zaheermerali
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Benoît HERVIER (reporter) 2009-10-12 20:12:13 UTC
SOFTWARE VERSION: 1-2009-41-10
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Open the application menu from the desktop
Click on other list
Try to scroll in the available applications

EXPECTED OUTCOME:
You can scroll in the applications list.

ACTUAL OUTCOME:
You cannot scroll in application list. But you can exit.

REPRODUCIBILITY:
sometimes



EXTRA SOFTWARE INSTALLED:
PyGTKEditor
Bounce
Conboy
PyMaemo
mSaber
Mauku

OTHER COMMENTS:
Seems to occurs after installing new software from the application manager
A reboot fix the problem

Does there is a way to help you with log somewhere to track this problem when
it s appear ?

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; fr-FR; rv:1.9.2a1pre)
Gecko/20090928 Nokian95
Comment 1 Andre Klapper maemo.org 2009-10-13 16:02:09 UTC
I just again ran into this, for the third time. I installed four 3rd party
updates two hours ago - might be unrelated though.

This does not always require a reboot. When I installed another package by
using apt-get clicking on the taskswitcher in the left upper corner made the
main menu get repainted (one per one icon) and I could scroll in "More..."
again.

This has been fixed internally very recently. Not yet part of 1.2009.41-10.
Comment 2 Lucas Maneos 2009-10-13 17:36:30 UTC
*** Bug 5374 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2009-10-16 23:14:11 UTC
(Moving application menu bugs to new subcomponent "Application Menu"
(previously "Task navigator") and splitting up Application Menu and Application
Switcher (Dashboard) bugs.)
Comment 4 Andre Klapper maemo.org 2009-10-19 22:27:38 UTC
*** Bug 5600 has been marked as a duplicate of this bug. ***
Comment 5 luarvique 2009-10-22 14:30:46 UTC
*** Bug 5713 has been marked as a duplicate of this bug. ***
Comment 6 Lucas Maneos 2009-10-26 03:11:50 UTC
*** Bug 5787 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2009-10-29 12:47:42 UTC
I'm going to reopen this as this is NOT fixed for me yet.
Comment 8 Tim Samoff maemo.org 2009-10-29 19:12:43 UTC
I experienced this after updating KMPlayer, but looking at the other comments,
I don't think "it" is the reason for the bug. Must be something in the "update"
functionality?
Comment 9 Tim Samoff maemo.org 2009-10-29 23:24:58 UTC
Hehe. Coincidentally, I just tried to install Fennec and got a "Not enough
memory in target location" message. Afterward, this bug occurred. After
uninstalling Fennec, I was able to scroll the 'More' apps again.

Anyone else remember if this occured after something like this?
Comment 10 Mikko Vartiainen 2009-10-30 02:31:50 UTC
This happens almost everytime when installing application with dpkg from ssh
session. It happens too often when installing with application manager, but I
haven't found anything special which triggers the bug.
Comment 11 Lucas Maneos 2009-10-30 09:45:07 UTC
I saw this for the first time after installing grsync (although the actual
package is probably irrelevant) with apt-get.  Uninstalling it fixed things,
and re-installing it again (both with apt-get) didn't break scrolling again.

One thing I noticed which may have something to do with it is that installing
it added a new row to the app menu.  Couldn't reproduce by installing another 5
packages though.
Comment 12 Tim Samoff maemo.org 2009-10-30 13:48:40 UTC
Let it be known that I get this bug by installing via the App manager and not
apt-get. So, in either case, it occurs.
Comment 13 aapo.rantalainen 2009-11-02 21:29:11 UTC
Almost each time I install package I must reboot if I want scroll on 'More'.
Comment 14 Andre Klapper maemo.org 2009-11-05 13:21:59 UTC
This has been fixed in package
hildon-desktop 2.2.110-1
which is part of the internal build version
2009-44
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 15 Lucas Maneos 2009-11-12 08:07:01 UTC
*** Bug 6132 has been marked as a duplicate of this bug. ***
Comment 16 Andre Klapper maemo.org 2010-01-14 12:28:11 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 17 Venomrush 2010-03-01 22:43:36 UTC
Verifying
I can scroll in application list in PR1.1

Note: "More..." application menu will be remove in PR1.2