Bug 5331 (int-146259)

Summary: Add AVRCP support to the Media Player widget (and system-wide?)
Product: [Maemo Official Applications] Desktop Widgets Reporter: luarvique
Component: Media playerAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: mediaplayer-applet-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, fredrik, krisolafson, mail, theloz86
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description luarvique (reporter) 2009-10-12 17:09:57 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Place Media Player widget onto the desktop.
2. Pair the device with a headset that supports AVRCP.
3. Start playing a few songs using the widget from #1.
4. Try controlling playback with headset controls.

EXPECTED OUTCOME:
You can stop/resume playback and go to the next/previous song using headset
controls, over AVRCP. In fact, it may be useful to treat AVRCP controls as
normal hardware keys, at the system level (i.e. make them available to all the
applications, via normal key events).

ACTUAL OUTCOME:
This functionality is only available when the full Media Player application is
running.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-10-19 00:39:51 UTC
So Google told me that this means Audio/Video Remote Control Profile (AVRCP)
(Please explain next time).
I wonder if this would fit better in the Bluetooth component as this is
something low-level I think...?
Comment 2 luarvique (reporter) 2009-10-19 07:50:35 UTC
(In reply to comment #1)
> So Google told me that this means Audio/Video Remote Control Profile (AVRCP)
> (Please explain next time).
> I wonder if this would fit better in the Bluetooth component as this is
> something low-level I think...?
The way it is implemented right now (only works in Media Player app) seems to
imply that it is currently done in the Media Player application, not in
Bluetooth component. Ideally, it would have to be done at much lower level and
look like a "media keyboard" to the system.
Comment 3 Fredrik Wendt 2010-01-11 20:41:49 UTC
I know this is a little of (bug) topic: but other handsets also send a text
message telling what is being played, such as "Michael Jackson - Bad". I was a
little set back now that my beautiful BT headset screen doesn't show this
information anymore. (The phone's screen is much prettier now OTOH, but also
200 $ more expensive.)

Is the source code of the media player and the desktop widget open sourced?

(BTW: The desktop widget nowadays never works for me. I have to start the
application to have the widget's play button actually start playback.)
Comment 4 Kris 2010-01-21 15:20:48 UTC
I have the same problem running version 2.2009.51_1.203.2 when paired with my
car bluetooth audio (built-in Toyota system that supports A2DP and AVRCP, works
with other older phones just fine).
Comment 5 Laurence Lowe 2010-04-07 01:14:58 UTC
@Fredrik The metadata transfer feature is part of AVRCP 1.3, which the N900
doesn't support. I can't confirm whether that's a hardware limitation or
something that could be added with a driver update, but it's definitely not a
bug.

I find that the AVRCP control only works when the media player is already open.
If it's not open, the playback doesn't start. Shouldn't a 'play' command launch
the media player if it's not already open?
Comment 6 Andre Klapper maemo.org 2010-04-15 15:36:13 UTC
This has been fixed in the internal build version
10.2009.51-8

The next public update (PR1.2) will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-04-21 22:48:55 UTC
*** Bug 8161 has been marked as a duplicate of this bug. ***
Comment 8 Fredrik Wendt 2010-06-01 14:18:48 UTC
For reference: Bug 7436 is related and isn't fixed in PR1.2.